Solved

Raid controller/driver troubles - is it possible to move a raid from one board to another?

Posted on 2003-10-22
16
288 Views
Last Modified: 2010-04-03
    Hi, recently I was having power troubles with my computer and replaced the power supply.  However something must have happened in the install because when I booted up my computer windows xp re-booted just as it started to load.  This happened everytime I reset the computer. Well, a little frustrating but nothing a re-install can't fix, right? However, when I loaded up the winxp install cd when I pressed enter to continue the setup the system hung while scanning the hdd's on the raid0 array.  This happened whether I selected the repair console or the install setup options.  This was a little confusing because the drives seemed ok, the raid array AND the drives were both sucessfully detected in the Fasttrak100 bios.  
     I put in a hdd on one of the other (non-raid) mobo controllers and installed winxp without a hitch.  Once I was in windows I went to install the drivers for the raid array - no problem.  But, when I rebooted the computer it now hangs just after the windows load-up screen but before the login screen.  I've been using the raid setup/drivers with no problems for about 2 years on an msi k7t 266 pro2a.  I suspect that the drives may be okay because they are still being detected, but I'm not sure.  Is it likely that the Promise Raid controller (onboard) is fried? If so is there any way to move the drives to another computer and keep the array/data?  Are there any other logical possibilities?

I was hoping that I might even be able to just format the drives and attempt a recovery with some software but I can't even attempt to format the drives because the xp cd hangs while scanning the drives, and winxp won't boot after the raid drivers are installed.
0
Comment
Question by:Jakethesnake99
  • 9
  • 7
16 Comments
 
LVL 18

Expert Comment

by:chicagoan
ID: 9602816
Check to make sure the Fasttrak100 isn't shaing an interrupt with another device, If can assign an explicit IRGQ in the bios, great, otherwise disable you onboard IDE controller, com ports and LPT port and 'reset data' in the bios.  Interrupt Sharing is not supported by onboard IDE controllers.

Do not reference C: or D: in the Mainboard Standard CMOS for drives attached to the FastTrak100 controller. Only enter drive information in the Mainboard CMOS for drives attached to a conventional add-on or onboard IDE controller.

According to Promise, drive sets can be moved between all of their FastTrak controllers as the data format is identical, so if your board is fried, that would be one way to do. You'd have to zero out that drive you installed XP on and let the controller attempt a rebuild IF the other drive is OK.

Single-drive striped (RAID 0) (JBOD) and Mirrored (RAID 1) array configurations allow the drive(s) to be accessed individually on another controller. Multiple-drive striped (RAID 0 or RAID 0+1) will not work on your onboard controller.

0
 

Author Comment

by:Jakethesnake99
ID: 9603259
Chicagoan:

Thanks for the advice, however it did not solve the problem, I disabled all ports (serial/parallel) etc, and disabled all onboard devices (sound/usb/ide) however I still can not access the drives.  I didn't reference any drives in the mainboard standard cmos, it is set to auto, and I did try disabling all onboard ide except for the raid ide.  The only irq that is being shared is one with the onboard usb (irq 10) however I recall that being the case before the incident, and I did try disabling onboard usb.

I'm not quite sure what you mean by 'reset data' in the bios.  The one lucky thing (I suppose) is that, as you said, I could move the array to another board with fasttrak raid.  

The drive I installed XP on was on a seperate ide channel, not one of the raid drives (a different hdd) so I haven't changed any of the raid array settings.  It is on a multi-drive raid 0

I'm still hoping though that there is some solution to this other than moving the array, if I could even just access the drives that would be ok.

When the onboard raid channel is disabled, the winxp I installed on the seperate drive boots up fine.  Even when it is enabled the regular ide channel xp installation works great.  But as soon as I try to boot from the raid array (which has an install of winxp on it from before the problems) it hangs just as it starts loading windows - OR - as soon as I try to install the raid drivers (to the winxp installation on the regular ide channel) windows won't boot.  It's crazy - I have no idea why windows wouldn't boot just because it DETECTS the raid array!
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9604004
Usually there is a BIOS option to "reset configuration data" which rewrites the plug'n'pray info and reassigns IRQ's.

The fastrak controller use a sector of the disk to keep their config on, try zeroing out the disk with wdclear or the disk manufacturer's utility, then do your windows install, loading the 3rd party storage drives at intallation time (hit F6 when prompted)
0
 

Author Comment

by:Jakethesnake99
ID: 9604043
I did try the "set to default" in the bios to reset all of the options, that was one of the first things I tried.  Also, I can't zero out the raid disks at all, because I load the 3rd part storage drivers at installation, but as soon as the computer tries to access the drives (just to scan it, not even copying files or anything) it hangs.  I can't even format the disks because I have to have the raid drivers installed to see them and I can't install the drivers anywhere but windows (during the install or in the working winxp install on the primary ide cable (NOT the raid drives))  Are you talking about going into the RAID bios and re-setting the array?

0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9604174
Once you've got your data off the drive, while still on the IDE controller, zero them out. Then reconnect them to the reid controller and try to reconstruct the array.
0
 

Author Comment

by:Jakethesnake99
ID: 9604315
It's a multi-drive raid 0 striped array, I didn't think I could get the data from a regular ide channel.
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9604400
>  I put in a hdd on one of the other (non-raid) mobo controllers and installed winxp without a hitch.
One of the striped drives???
0
 

Author Comment

by:Jakethesnake99
ID: 9604469
No sorry, it was another hdd I had lying around, I haven't touched the raid drives.  I didn't want to wreck the array since there is no redundancy with raid0 on multiple drives
0
Give your grad a cloud of their own!

With up to 8TB of storage, give your favorite graduate their own personal cloud to centralize all their photos, videos and music in one safe place. They can save, sync and share all their stuff, and automatic photo backup helps free up space on their smartphone and tablet.

 
LVL 18

Expert Comment

by:chicagoan
ID: 9605788
If the raid bios said the array's healthy, and you can't start in safe mode, you might want to start from the CD (installing the storage driver at boot time) and run XP's  recovery console
0
 

Author Comment

by:Jakethesnake99
ID: 9607353
I already did try that, as I mentioned in earlier posts, when I start trying to install off of the cd, right after the option menu that says "press enter to setup, press R for recovery console, press F3 to exit" it scans all of the drives after you press enter but before the licensing agreement comes up.  It only takes a split second to do normally, but if I press f6 and install the raid drivers (during the startup of the cd when it asks you to) it hangs when it's scanning the drives.  Otherwise I would be able to re-install windows and/or format the drives.  The problem is as soon as windows is aware of the drives and attemps to access them for any reason (even just scanning) the whole system hangs. That's why I think it might be the controller.  Have you ever heard of this? Is it likely that swapping the board will fix the problem?
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9607811
And the RAID bios - does it report the array as healthy?
0
 

Author Comment

by:Jakethesnake99
ID: 9607979
Yes, it detects both drives and says the array is funtional
0
 
LVL 18

Accepted Solution

by:
chicagoan earned 125 total points
ID: 9608334
I think I'd pop the card and drives onto another mobo and try to boot to safe mode.
Generally a failed power supply is more likely to corrupt data than screw up hardware, unless the 12V side goes out enough to overheat thing because fans spin down.

Interrupt sharing and corrupted "reserved sector" issues seems to be the main cause of hanging on these controllers, and if you're trying to recover data you'll have to eliminate motherboard problems and then controller failure.
If you can get it on another system and have the same issue, it's either buy another controller and pray or get promise involved.
If you're not interested in data recovery, then zeroing the drives out with the manufacturer's utility or a generic test like wdclear (using the on-board controller) and reconstructing the array is the avenue to pursue.
0
 

Author Comment

by:Jakethesnake99
ID: 9608703
It's an onboard raid controller, otherwise for sure I would have already done that.  However your theory on corrupted sectors due to the power supply failure may be accurate, I just ran the disk diagnostic utility from ibm/hitachi (I have ibm drives) and it found on one of the drives a single corrupted sector.  What was funny was that when I attempted to repair the sector, it said that it was of an "unknown file structure (not fat16/32 or ntfs)" which I thought was REALLY strange, but I went ahead and said "repair anyway" and it just completed, I'm going to see what happened and let you know.
0
 

Author Comment

by:Jakethesnake99
ID: 9609940
Actually, thanks for your help but I solved the problem.  There wasn't any problem with the raid array at all, what must have happened is the 1 sector that was corrupted must have been the kernel32.dll (which would account for why the system kept re-booting) so after I did a physical repair using the ibm diagnostic tools, I used the repair console to copy over the kernel32.dll file and that fixed the problem.
0
 

Author Comment

by:Jakethesnake99
ID: 9609947
Thanks anyway for your help
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Ever notice how you can't use a new drive in Windows without having Windows assigning a Disk Signature?  Ever have a signature collision problem (especially with Virtual Machines?)  This article is intended to help you understand what's going on and…
AWS Glacier is Amazons cheapest storage option and is their answer to a ‘Cold’ storage service.  Customers primarily use this service for archival purposes and storage of infrastructure backups.  Its unlimited storage potential and low storage cost …
This video teaches viewers how to encrypt an external drive that requires a password to read and edit the drive. All tasks are done in Disk Utility. Plug in the external drive you wish to encrypt: Make sure all previous data on the drive has been …
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now