OWA Authenticates but no graphics

I have a SBS 2000 Server SP4 running IIS 5 and ISA SP1 w/Exchange 2000 SP 3.  I have rebuilt this a number of times, mot recently because all of a sudden the icons and other graphics such as buttons in OWA have disappeared and are replaced with code or blue boxes with red X's in them.

I have rebuilt this server several times as it is really a test lab.  It has worked fine before, this is a fresh install with no modifications to IIS or ISA.  ISA does have the feature pack installed, but it did when it worked before.  I recently rebuilt this server becuse of just this problem.  I completely reformatted all drives when I rebuilt the server.  So it is a clean install with all service packs and security patches.

I have tried accessing OWA externally and insternally with different versions of IE.  I have tried accessing it from the server as the Admin, same issues.  At one point I thought it was McAfee GroupShield, but during the last rebuild I tested it before installing GroupShield.  I am not running SSL yet.

I am really at a loss on this one, as a long time fellow EE member any suggestions or help would be appreciated.  Extra points if you want them.
LVL 9
MSGeekAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David WilhoitSenior Consultant, ExchangeCommented:
http://support.microsoft.com/default.aspx?scid=kb;en-us;290113

Would you verify for us that your server is configured correctly? I'm thinking this is somehting simple, take your time :)  I'm thinking disable the socket pooling...

D

0
David WilhoitSenior Consultant, ExchangeCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MSGeekAuthor Commented:
Kidego..  I did use the SBS Connection Wizard but I will look into it and reply this evening.  I think it is something simple as well.  From the second KB:"The Exchweb virtual directory in Internet Services Manager is not configured correctly, or it is missing virtual directories, for example, Img and Views."  this seems to more likely be the problem.  I will post status this evening.   Can't get at the server right now. Thanks, MSGeek.
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

David WilhoitSenior Consultant, ExchangeCommented:
you're welcome :)

d
0
jivenojiveCommented:
Install the October Roll-up for Exchange.
0
MSGeekAuthor Commented:
jivenojive... already applied.

Kidego.. I worked thru the first KB you provided.  Still need to check on Auto Discovery in ISA.  No luck yet.  Ran out of time.  I am upgrading a major ERP system this weekend, have been busy preparing for that.  I hope to work on it this evening.  Thanks, MSGeek.
0
MSGeekAuthor Commented:
I may be rebuilding IIS.  I restored my website from a backup copy when I built the server.  I am wondering if there is a file or files and folders under \Inetpub\wwwroot that may not be restored from backup.  Mind you I did not restore all the files, just those that were missing or central to my site.  Any thoughts along those lines?  I am going to attempt to follow the second KB's link on recreating the Exchange virtual directory.

One more item worth noting.  The Exdamin IIS folder has this path: \\.\BackOfficeStorage  I am not certain where that should be pointing.  Another rebuild may be quicker than trying to figure this one out.
0
David WilhoitSenior Consultant, ExchangeCommented:
the path in IIS is correct. Since the restore, you need to apply the windows sp, then reinstall exchange and the exchange service pack. then you'll know if you need to go deeper.

D
0
MSGeekAuthor Commented:
A reinstall of Exchange and SP3 along with post SP3 roll-up did not cure the problem.  I will be attempting to recreate the virtual directories over the next couple of days.  This is looking like another rebuild.

If I do rebuild I will go step by step in application of servcice packs, installation of antivirus software, etc. noting if and when the problem occurrs again.  Let me know if you have any other ideas as I am not relishing another rebuild which is not likely to happen until late on the 31st.  Thanks, MSGeek.
0
David WilhoitSenior Consultant, ExchangeCommented:
post again, before Friday, to remind me to take another look....

D
0
MSGeekAuthor Commented:
One last chance before a rebuild, anyone?
0
David WilhoitSenior Consultant, ExchangeCommented:
Does it work when you use IE on the server itself?
0
MSGeekAuthor Commented:
No. Thx, tried that.
0
David WilhoitSenior Consultant, ExchangeCommented:
Do this, try it again, see if we get any different errors.

1.      In Internet Explorer, on the Tools menu, click Internet Options.
2.      Click the Advanced tab.
3.      Under Browsing, click to select Display a notification about every script error.

D
0
David WilhoitSenior Consultant, ExchangeCommented:
You know, you could pull IIS off completely, and delete the metabase.bin file. But I think that would blow up ISA as well, so you'd be better doing a full rebuild. But try the script error trick, there's something that has got to tell us where the problem lies. Does the everyone group have local logon rights for this box?

D
0
MSGeekAuthor Commented:
Unreal.  I changed the setting and pulled up the page and it came up with no errors.  The setting had no relation to the problem.

I have this setup with ISA server and wanted to set it for SSL, but since the errors were coming up I disabled SSL until I could troubleshoot the problem.  Recently I reenabled SSL just to keep areas of IIS including OWA secure.  It must have something to do with how I configured this with ISA server.  It certainly came from a link in the KB's Kidego gave me.

What stinks is for this to be of any benefit to the site I am going to have to find exactly where in ISA things went screwy.

Kidego, I'm going to award the points to you as the links you provided wher very strong for anyone attempting to work with and or setup OWA.  I am awarding a grade of A, while I cannot pinpoint the exact problem Kidego's links provded the solution as I made no other changes than what were suggested.

Thanks.  I will post here if I can figure this out.  In the mean time I am getting screwed as I am running this on a cable (DHCP) connection.  If you were not already aware a lot of ISPs areblocking SMTP from a Dynamic IP:
http://abuse.easynet.nl/dynablocker.html

I recently ran an upgrade on McAfee Groupshield.  I wonder if the the old engine was causing the problem and not ISA?
0
David WilhoitSenior Consultant, ExchangeCommented:
it's hard to say, since we made so many changes over time, but hey, now it works. The first link I sent you is the basic on configuring OWA behind, so you can start there. Sometimes, stuff just works :)

Let me know!

D
0
MSGeekAuthor Commented:
I was not able to determine the problem, too many variables.  However I may be opening a new post concerning ISA and SSL bridging where you are runnning ISA on the same server as exchange (SBS Server) and you want to implement OWA over SSL.   Yeah I am getting the dreaded DNS 500 error and have rad the two schools of thought on this topic (Web publishing vs. Server publishing).  I am convinced some sort of hosts file sor split DNS is required.  Can't figure out why it was working fine before, but am learning some great stuff.

Will post link to next quetsion here.
0
MSGeekAuthor Commented:
0
CraigHuckCommented:
We just recently had this issue with SBS 2003 Premium and the solution is as follows:

In IIS the ExchWeb virtual directory must be configured to allow anonymous access under Directory Security -> Authentication and access control.

The problem is that something (ISA?) that gets installed changes the IUSR_<SERVERNAME> password or stops Windows from managing the IUSR_<SERVERNAME> password correctly. If you change this accounts password and specific the new password in this location that should fix your problem.

Craig Huck
Integrita Systems
http://www.integritasystems.com
0
David WilhoitSenior Consultant, ExchangeCommented:
I've noticed Sharepoint can wreak havoc in SBS for this type of thing, but I hadn't thought of it here. Nice one, Craig....

D
0
MSGeekAuthor Commented:
Ditto that Craig

I left you some points here:  http://www.experts-exchange.com/Networking/Email_Groupware/Exchange_Server/Q_20938060.html

Thanks,  MSGeek.
0
MSGeekAuthor Commented:
Kidego.. Are you able to accept the question I posted for Craig, I see he is a new member and he had a great observation in this post.  I'd like him to have the points.  Please advise, Thx.  MSGeek
0
adamant40Commented:
Check to make sure your ISUR_<servername> user account isn't disabled in Active Directory (if DC) or Local Users (if Member Server).  We had this exact problem and after looking around, found it to be disabled.  Also, make sure the passwords are synchronized (I even did it manually).
0
MSGeekAuthor Commented:
adamant40.. I saw that somewhere researching this, it is all wrapped up.. on to bigger and better fish.  Thanks for the input, perhaps it will help somebody else.  MSGeek
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.