• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 207
  • Last Modified:

Linux n00b... networking WinXP and Mandrake 9.1 (no server, DHCP @home) simple fix I'm sure...

I am taking another shot at setting up a Linux PC on my home network. (Finally, Unix class next quarter, woohoo! hopefully the instructor isnt full of theory :)
I am using my switch to assign DHCP (no server, and I am using workgroup).
Mandrake 9.1 and WinXP.  Linux sees all Win PC's on the network and has internet but when I click on these Win PC's in my list (LinNeighborhood) I get nothing.
On the Windows side, it doesn't see the Linux machine in "show workgroup computers" but in "My Network Places" I see my Linux share, ( /tmp on Samba Server 2.2.7a localhost )
but when I click on it, I get a "no access error".
To share this dir on the Linux machine I simply right clicked-sharing tab and shared for all users /user/tmp. I ran through a little wizard and now I seem to be half way there?
Dont know why I can see the share but dont have access? I obviously have Samba installed, but dont know where to go to configure it? Question: do I need to install anything on Win side?
I want to use Linux so bad, but it always ends up being entirely frustrating to do simple things; But I am fairly familiar with networking just need to be weened from Windows!
Ultimately, I want to have 2 NIC's in Linux PC and use it as a gateway server/router/firewall with my Windows net behind it, and so on...

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Which brings me to my other question, What the hell does a guy have to do to get a static IP? I have comcast cable and they do not offer static IP's.
The only person I know with static is my buddy with a T1 and I certainly cant afford that! (neither can he, lucky devil) Does anyone know how I can get a static IP with my existing setup?

Any help is much appreiciated!
Thanks
0
kevindolan
Asked:
kevindolan
1 Solution
 
AgelmarJagadCommented:
The problem with your samba setup is that even though you added all of the users on your system with whatever wizard you used the users on your WinXP  don't match the usernames and passwords of the users on your Linux box.  There are a couple of things you can do depending on how secure you want your setup to be.

Your first option is probably the easiest to setup, but also the least secure.  Open the samba configuration file (/etc/samba/smb.conf) in your favorite text editor (make sure you back up smb.conf before you do this, as you probably aren't familiar with manually editing configuration files just yet).  Add the line 'map to guest = Bad User'.  It doesn't matter that much where you put this line as long as it is after the line that says '[Global]' and before anything else by itself on a line and in brackets ( ex. [homes] ).  You will probably want to put it near any lines that mention guest or security.  Now save and exit smb.conf.  You may have to restart the samba server now, and as I don't know how to do that with Mandrake utilities in a GUI, your best bet would be to type in on the command line (as root) '/etc/init.d/smb restart'.

Your other option is to add a user on your XP machine that has the exact same user name and password as a user on your Linux box.  That user should then have access to the shared folder.  In my experience this doesn't work very well on networks that don't have centralized domain servers, and that is definitly more than you need to worry about, so try the first method first.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now