Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

FTP error

Posted on 2003-10-23
3
Medium Priority
?
347 Views
Last Modified: 2010-03-17
Hello All,

My requirement:

My system is behind firewall. I am connecting to one of the systems with public IP on the internet using ssh ( putty ) and then do an ftp from that system (which is a solaris 8 O.S).
to a system in My DMZ.

What is going through correctly:

I am having all the ports opened from my hardware firewall.
I was able to get connected to the system with public IP from my LAN using ssh (putty).
And I was able to get the connection to the ftp server in my DMZ from that public IP system.
I could able to initiate the download from the server to my ftp server.
I have enabled all the required ports in passive mode i.e. from 1024 - 65536 for tcp.

The problem is:

After about an hour long of download (the size of file to download is 550mb). the system gives an error saying "netout: Broken pipe".

Could some one help me solve this issue.

Thanks,

Rajesh
0
Comment
Question by:avrajesh_99
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 40

Expert Comment

by:jlevie
ID: 9609439
Does the error come from your local machine (the one you initiated the ssh connection from)? If so it probably is a result of the local firewall timing out what it believes to be an idle session. And it might think that because you aren't sending data from the local machine once you've started the FTP transfer. That can be remedied by setting the "Seconds between keepalives" under the PuTTY "Connection" configuration to a non-zero value.
0
 
LVL 1

Author Comment

by:avrajesh_99
ID: 9612037
Yes, you are correct I am getting the error from my local system.

Yes, I do have the setting of "seconds between keepalives" set to "1".

Any idea what else could be wrong.

Rajesh
0
 
LVL 40

Accepted Solution

by:
jlevie earned 400 total points
ID: 9613511
Since the error is from the local machine I'd think that it must be a case of a firewall timing out the connection, event though PuTTY should be sending keepalives. The solution to that might be to background the FTP transfer and occasionally do domething on the remote, like an ls.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question