Solved

Search component doesn't work - displays [FrontPage Search Component] message

Posted on 2003-10-23
27
10,690 Views
Last Modified: 2013-12-24
I'm having a problem getting the FrontPage search component to work on a newly configured Windows 2003 Server that is running IIS 6.0.  The install was configured as an application server with only the FrontPage server extensions option selected (no .net)

When you view the page you get the following message:  [FrontPage Search Component] and the component does not display (no box to type in search criteria).

No matter what I try, I can not get the FP search component to work.  I tried other FP components such as a counter and it works.  I do have indexing running on the server.  I am able to query the windows catalog and I do get results back.

I have done the following:

1)  Recalculated hyperlinks
2)  Checked server health and repaired any problems
3)  Recalculated the web

I have gone as far as uninstalling the app server and reconfiguring it.  No matter what I do, I can not get the search feature to work.  I have the same functionality working on a Win2k server running IIS 5.0 and I haven't had any problems with it.

Any solutions would be greatly appreciated!

0
Comment
Question by:slimjim28
  • 12
  • 10
  • 2
  • +2
27 Comments
 
LVL 31

Expert Comment

by:seanpowell
ID: 9608118
Just want to make sure first that your search page is not an asp page, correct?
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9608198
Also, you don't mention the version - you're using the 2002 extensions?
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9608215
And you have done the following to enable the Indexing Service Web Extension:

1. Click Start, point to Administrative Tools, and then click Internet Information Services Manager.
2. Expand ServerName, where ServerName is the name of the server, and then click Web Service Extensions .
3. In the right pane, right-click Indexing Service, and then click Allow.
4. Quit Internet Information Services Manager.
0
 
LVL 1

Author Comment

by:slimjim28
ID: 9610059
seanpowell:

1)  No this is a standard HTML page - no asp is involved.
2)  These are 2002 server extensions - installed right from the Windows 2003 server disk when the application server was configured through the wizard.
3)  When I followed your instructions to verify that the index service is enabled in IIS, I did not have an option to enable indexing in the right pane.  All I'm able to do here is allow/disable components such as FP server extension, server-side includes, asp, etc.  If I right click on the default website - under the home directory tab, the option to "index this resource" has been checked.  If I go to "manage my computer" and look under the indexing service, I do see that inetpub/wwwroot is being indexed.
0
 
LVL 1

Author Comment

by:slimjim28
ID: 9610087
The actual version of the FP 2002 server extensions is v5.0.2.5012 if that makes a difference.

Yesterday I also tried downloading the 2002 server extensions from Microsoft's site (which happened to be an older version) and I experienced the same problem with them.

This morning I uninstalled the application server and reinstalled it using the server extensions that were supplied on the Win2003 Server cd.
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9610967
Can you post the code from the page here? (Just in case...)
0
 
LVL 1

Author Comment

by:slimjim28
ID: 9613687
Here's a copy of the code:

<html>

<head>
<meta http-equiv="Content-Language" content="en-us">
<meta name="GENERATOR" content="Microsoft FrontPage 5.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<title>test</title>
</head>

<body>

<p>test</p>

<!--webbot bot="Search" S-Index="All" S-Fields S-Text="Search for:" I-Size="20" S-Submit="Start Search" S-Clear="Reset" S-TimestampFormat="%m/%d/%Y" TAG="BODY" startspan --><strong>[FrontPage Search Component]</strong><!--webbot bot="Search" i-checksum="62951" endspan --><p>&nbsp;</p>

</body>

</html>
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9613794
The only thing I see missing initially in the code is this:
b-useindexserver="1"
but I need to confirm if FP2003 still uses that field to confirm that index server is enabled.

Can you add it in and resave the page...
0
 
LVL 1

Author Comment

by:slimjim28
ID: 9614760
I actually tried something similiar today.  I have an existing search running on our current production (Win2k with FP2002 extensions).  I copied and pasted the code from this server into the html page that resides on the Windows 2003 Server.  The search still failed.

Here's an extract of the code that I got from our Win2k Server (production server) that functions properly.  This same code fails on the Win2k3 server:

<!--webbot bot="Search" S-Index="All" S-Fields="TimeStamp,DocumentK," S-Text="Search for:" I-Size="20" S-Submit="Start Search" S-Clear="Reset" S-TimestampFormat="%m/%d/%Y" TAG="BODY" b-useindexserver="0" startspan --><form action="../_vti_bin/shtml.dll/search/index.html" method="POST"><input type="hidden" name="VTI-GROUP" value="0"><p><b>Search for: </b><input type="text" name="search" size="20" value></p><p><input type="submit" value="Start Search"><input type="reset" value="Reset"></p></form><!--webbot bot="Search" i-checksum="39542" endspan --><p align="center">&nbsp;</p>

Notice that the code from the existing and functional server has the b-useridnexserver set to 0 rather than 1.  I tried it both ways on the new 2003 Server and it still failed.

0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9614871
There is definitely a problem with the server extensions.

Right click on your web in IIS
Choose "All Tasks"
Check Server Extensions and Calculate Server Extentions

Do you see any errors reported?
0
 
LVL 1

Author Comment

by:slimjim28
ID: 9615192
I checked the Server extensions and the only problem it found was the recommendation to "tighten security" - which I did let it fix.  I also recalculated the server extensions.  No matter what I do it doesn't fix the problem.  I bet I have checked server extensions and recalculated at least 20 different times now.

I'm starting to wonder if anyone has succesfully implemented a search component on a Win2k3 Server?  Might this be a bug with Win2k3?
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9615242
I certainly hope not :-(

Let me do some more checking...
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9617059
You are currently creating the form directly on the live FP site, yes?
0
Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 1

Author Comment

by:slimjim28
ID: 9617097
Yes, the form was create on the live FP site.  It wasn't created locally then moved over.
0
 

Expert Comment

by:grwood
ID: 9714292
Has anyone got an answer for this one? I've got the exact same problem and have been through the same loops - no luck so far!
0
 
LVL 1

Author Comment

by:slimjim28
ID: 9714774
I've done some checking around and other users are experiencing the problem but no solution has been found yet.
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9715301
Are you using UNC Content?

From Microsoft:
Index Server Does Not Support UNC Content
As of this writing, Index Server on Windows Server 2003 only supports indexing of local content; therefore, UNC content searching is not supported. In addition, FrontPage Server Extensions 2002 on Windows Server 2003 no longer includes the Wide Area Information Server (WAIS) search engine, which is used by FrontPage webs that use a search component. As the currently recommended replacement is to use Index Server in place of WAIS, FrontPage webs using the search component will not work on UNC-based storage.
0
 
LVL 1

Author Comment

by:slimjim28
ID: 9715471
I am not using UNC content.  I am only indexing the local content that resides within the c:\Inetpub\wwwroot\ folder and the search fails.  If I query the local index server catalog, the infomation is there.  The problems appears to be with the link between the indexing service and FP2002 server extensions.
0
 
LVL 1

Author Comment

by:slimjim28
ID: 9818477
Ok...I couldn't wait any longer so I dumped $ 245.00 into Microsoft's pocket to get a solution on this issue.  Can I award the points to myself? *grin*

Here's what I found out:

By default, Windows 2003 Server does not install the indexing server.  You should actually see an option in the IIS console to "allow" or "prohibit" the indexing service under the Web Service Extension section.  

The solution:
1)  Go to "add/remove components" - "Windows Components" and uncheck the indexing service so it can be uninstalled.
2)  Reboot the system
3)  Go back to "add/remove components" and reinstall the indexing service.
4)  In the IIS console, under "Web Service Extension", "allow" the indexing service.
5)  Recalculate the website

The search should function properly!

I expressed concern to Microsoft that many others are experiencing this problem and more than likely they will create a knowledge base article for this problem.
0
 
LVL 31

Expert Comment

by:seanpowell
ID: 9818669
So my comment from above:

1. Click Start, point to Administrative Tools, and then click Internet Information Services Manager.
2. Expand ServerName, where ServerName is the name of the server, and then click Web Service Extensions .
3. In the right pane, right-click Indexing Service, and then click Allow.
4. Quit Internet Information Services Manager.

Only applies after the indexing service is uninstalled and then re-installed? Just trying to make sure I understand...
0
 
LVL 1

Author Comment

by:slimjim28
ID: 9818822
Yes, it only applies after the indexing service is uninstalled and re-installed.  Do you see the indexing option before doing the uninstall of the indexing service?  My scenario is based on a clean install of Windows 2003 Server.  Based on the conversation with the tech, the scenario might look different for a server that was upgraded.
0
 
LVL 1

Author Comment

by:slimjim28
ID: 10664014
I agree this should be PAQ/Refund since I had to pay Microsoft to get the answer and I answered my own question.  I think it would be helpful for other users if these posts were archived.  Is there something I need to do on my end for the refund of points?
0
 
LVL 29

Accepted Solution

by:
coreybryant earned 0 total points
ID: 10664057
No - I'll take care of it but of you would like to post the solution, it might help as well.

Thanks!

-Corey
0
 
LVL 1

Author Comment

by:slimjim28
ID: 10666819
Here's the solution that Microsoft provided to correct the problem for me:


By default, Windows 2003 Server does not install the indexing server.  You should actually see an option in the IIS console to "allow" or "prohibit" the indexing service under the Web Service Extension section.  

The solution:
1)  Go to "add/remove components" - "Windows Components" and uncheck the indexing service so it can be uninstalled.
2)  Reboot the system
3)  Go back to "add/remove components" and reinstall the indexing service.
4)  In the IIS console, under "Web Service Extension", "allow" the indexing service.
5)  Recalculate the website

The search should function properly!

I expressed concern to Microsoft that many others are experiencing this problem and more than likely they will create a knowledge base article for this problem.
0
 
LVL 29

Expert Comment

by:coreybryant
ID: 10666843
Hm, maybe this came at a good time?  I am getting ready to install Windows 2003 today.   Weird the way they do it but I have seen very unusual things.  Thanks for posting this!

-Corey
0
 

Expert Comment

by:copas2
ID: 10851336
Hi all,
Same problem, but I'm not able to reinstall the Indexing Service because it doesn't matter if I check it or uncheck it, it seems to be installed: service is running, checkmark won't show up.
So I would ask slimjim28 to tell me:
What are the required files by that Indexing Service under Web Service Extensions?
I don't think it'll help but this seems to be the last chance...
Thanx,
copas2
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

In this short web based tutorial, I wanted to show users how they can still use the powers of FrontPage in conjunction with Expression Web 3.  Even though Microsoft eliminated the use of Web components, we can still use them with FrontPage and edit …
This article provides a case study on how our local youth baseball league deployed a new website, including the platform selection, implementation and benefits to the league.
The purpose of this video is to demonstrate how to update a WordPress Site’s version. WordPress releases new versions of its software frequently and it is important to update frequently in order to keep your site secure, and to get new WordPress…
The purpose of this video is to demonstrate how to integrate Mailchimp with Facebook. This will be demonstrated using a Windows 8 PC. Mailchimp and Facebook will be used. Log into your Mailchimp account. : Click on your name. Go to Account Setti…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now