Solved

I  have denied myself and everyone else access to the C drive of our server - can somebody help

Posted on 2003-10-23
12
295 Views
Last Modified: 2010-05-18
I was trying to reconfigure security settings on the server to restrict access by certain users.  The C drive had been originally shared and allowed full access to 'everyone' becasue 'everyone' only included trusted users.  With some new users coming online I thought I would reconfigure this by removing the access to everyone, and then start again with new access rights to specific groups.  Unfortunately, the result of this is that I now have no access to the contents or the security settings of the C drive (when logged on as Administrator).  I can't open the administrator console, or run .  The C drive now shows as not shared, and I dont have permission to change this.

Before you all laugh too much, I am only the network administrator by default becasue I work for a small company and I know more than most about computers, but apparantly from my last achievement, not enough yet.

I'm not sure what to try now, I was reluctant to re-boot, as it may not be possible to restart without access to the c drive.

I would like to award this 500 points for importance of resolution, but I only have 125 points available, and the site currently wont accept my credit card details to purchase more.  I'm a new user, and I don't know if this is possible, but if anyone can help me sort this out I'll award 1000 points once I can get through to billing and get my credit card authorised.

Martin
0
Comment
Question by:LevelDevelopments
  • 4
  • 3
  • 2
  • +2
12 Comments
 
LVL 6

Expert Comment

by:bkoehler-mpr
Comment Utility
Did you change the share permissions or the NTFS drive permissions?

Share permissions:
If you changed the share permissions remove the Everyone group, create a group of trusted users, and add that group with rights.  You can also add the Domain Administrators group (or just the Administrators group if you're not on a domain) with Full Control. I recommend always removing the Everyone group from shares (unless you are stuck in a peer to peer network).

NTFS permissions:
Do NOT follow these steps if you didn't change the NTFS rights

Right-click the folder you want to take ownership of, and then click Properties.
Click the Security tab, and then click OK on the Security message (if one appears).
Click Advanced, and then click the Owner tab.
In the Name list, click your user name, Administrator if you are logged in as Administrator, or click the Administrators group. If you want to take ownership of the contents of that folder, click to select the Replace owner on subcontainers and objects check box.
Click OK. The following message appears, where folder name is the name of the folder that you want to take ownership of:
You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you Full Control?
All permissions will be replaced if you press Yes.
Click Yes.
Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.

0
 
LVL 4

Expert Comment

by:darth_wannabe
Comment Utility
HAHAHA.....ok I'm sorry. :)

Try a tool called ADMNALOW ( http://www.bookcase.com/library/software/winnt.util.system.html ). We used to run into jacked up permissions all the time, and this tool will allow admins in when nothing else seems to work.

You can use it locally, or from the command line of another machine ( ADMNALOW \\SERVERNAME\C$ )
0
 
LVL 4

Expert Comment

by:darth_wannabe
Comment Utility
sorry, looks like that link is broken

try here http://www.winsite.com/bin/Info?500000029999
0
 
LVL 3

Expert Comment

by:dshuang5858
Comment Utility
Hi, LevelDevelopments,

Follow these guidelines:
1.  Make sure you log in as administrator
1.  Right-click the folder or drive that having problem and choose Properties
2.  Click on "Security" Tab
3.  Click "Advanced" button in Security Tab
4.  Click on "Owner" Tab
5.  Under change owner to: select administrator name (usually comes with 2, Administrators Group and administrator), choose one
6.  Check on "Replace owner on subcontainers and objects
7.  Click "OK"

Now, you should able to access the folder without problem.

Hope this help!

dshuang5858
0
 

Author Comment

by:LevelDevelopments
Comment Utility
Unfortunately the situation is more serious than this.  I have no access to the C drive from the server or any other machine as it is no longer shared.  As a result, there is no security tab under the C drive properties, and I don't have permission to re-share it.  To make matters worse (or possibly just moving on to the next inevitable stage) I had some advice to re-start using 'last known good data' to try and restore the previous security settings, but now the machine wont reboot at all, and just displays a blue warning screen advising me of this.

What to do?  Can I repair using the windows 2000 discs without losing my files and exchange mailboxes? Can I run the ADMNALOW program from a command prompt and if so how do I get to a command propmpt on a Windows 2000 machine?  Otherwise, can I plug the hard drive into another computer, and change the security settings (or the files that contain them) here.

Your help is much appreciated.

Martin
0
 

Accepted Solution

by:
solver7 earned 125 total points
Comment Utility
Howdy,
You may be able to slave the drive and copy the files you need to another
drive since it will take on the permissions of the destination folder.

 OR, you can login locally with a utility such as ERD commander

http://www.winternals.com


 It launches in its own shell, so you are not booted into the operating
system on the drive. then, you may unlock files, reset user account
passwords, and a few other things.

  You will not be disappointed. It is a job saving utility.
0
Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

 
LVL 6

Expert Comment

by:bkoehler-mpr
Comment Utility
I agree with solver7, I have used many Winternals utilities in job saving situations.
0
 

Author Comment

by:LevelDevelopments
Comment Utility
Solver 7 gets the points for offering the most useful advice, although I didn't actually use it.

After tring many other routes, I eventually had to plug the hard drive into another machine and change the security settings here to enable access by 'everyone', then plug it back into the server and start again.  This worked sort of, but I was still having lots of problems becasue the ownership and security settings hadn't propogated to all the files (just left some random files without ownership) so some software (including exchange) wouldn't start.  4 hours later I worked this out and re-propogated the ownership and permissions again from the root.  So now all the files have the same security level which isn't perfect, but at least I can change it!

I'm still not happy about the fact that it let me remove all ownership and permissions from the C drive.  It was pretty stupid looking back, but at the same time remarkably easy. My mistake was that I assumed that as the administrator I would always be able change permissions etc.. no matter what I did.  Still a lesson learned!

Thanks to all for your advice - I'm sure I'll be using the service again in the future (if the site can get its billing sorted out!)

Martin
0
 
LVL 4

Expert Comment

by:darth_wannabe
Comment Utility
hmmm...your system should automatically reshare your drive as C$
0
 

Author Comment

by:LevelDevelopments
Comment Utility
Nice to know it should, but it didn't.  I couldn't load any programs, go into any settings, it emptied the desktop and start menu, wouldn't run programs from the cd, and eventually when I rebooted wouldn't restart.  I was getting quite worried at this point.  I tried repairing using the repair faciltiy booting up with the windowss 2000 discs, and then tried to copy the security file from the backup directory to the sytem directory, but it wouldn't allow me access.  Eventually when the drive was plugged into another computer I still couldn't access the files, but it did at least let me change the security settings.  I was getting quite worried at this point.
0
 
LVL 4

Expert Comment

by:darth_wannabe
Comment Utility
I bet....yeah, I think putting it into the other machine was the best fix.
0
 

Expert Comment

by:solver7
Comment Utility
Hey LD,
I'm relieved you got it mostly sorted out.
 I want to encourage you to get some kind of utility like the ones
mentioned above to save your behind in the future.
 There WILL be times when you need data recovery for
other reasons...corrupted f.a.t., corrrupted registry, hardware
problems, whatever..
   I am sure you will get good use out of a utility that can look
at the hard drive even when you cannot boot into the os.
  Peace -
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
This article will show you how to create an ISO CD-ROM/DVD-ROM image (*.iso), and MD5 checksum signature, for use with VMware vSphere Hypervisor 6.5 (ESXi 6.5). It's a good idea to compare checksums, because many installations fail because of a corr…
This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're looking for how to monitor bandwidth using netflow or packet s…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now