Why does graphics quality of an .exe made out of a flash file reduces

HI.
when i publish a .fla and make an .exe from it... the overall quality of the graphics gets reduced. to be clear... the images get pixelated.

this happens dispite of the fact that the background i m using in the .fla has been created in Photoshop with a high resolution of 1200X900 pixels at 150dpi.

the document size in the .fla is also 1200X900.

why does that happen and how can i rectify it. i want the output at premium quality.
LVL 18
SethiAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

negatyveCommented:
1. Check the jpg compression quality in the "Flash" Tab of the Publish Settings Panel (File\Publish Settings or Ctrl+ Shift + F12)

2. Use LossLess (PNG/GIF) as Compression in the properties of image in the library

3. Are you using the command

fscommand("showmenu", false);

or the corrisponding:

Stage.showMenu = false;

?
SethiAuthor Commented:
In the Flash Tab of the Publish settings panel ... i have unchecked Compress Movie option... and i have set the jpeg quality to 100%.

secondly... i have changed the properties of the image to Lossless (PNG/GIF).

still the image is getting pixelated when an .exe is made out of the flash file.
the pointed to be noted is that the image does not looses its quality when u view it in the .fla file... it is only after when i make an .exe out of it that it looses its quality
Devario JohnsonSoftware EngineerCommented:
in your publish setting you have to make sure that you dont have quality for the images set to minimal.  Go to file>publish settings> jpg  right there you should be able to see how much qualiity you want.  The better quality comes from higher file size meaning you have to have the file as UNcompressed as possible
  hope this helps
        -devarioj
SethiAuthor Commented:
ya devarioj... ya wrote in my previous comment that  i have set the jpeg quality to 100%... i.e uncompressed.
SethiAuthor Commented:
i'v solved the problem myself. i made the graphics in a very high resoultion of 2200 X 1800 pxls at 500dpi so that even when the quality dimnishes.. it doesn't look ugly in .exe.

i would request the moderator to please delete the question.

thank u.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Adobe Flash

From novice to tech pro — start learning today.