MS IIS 5 Will Not Access Folders That Have A Suffix

I've discovered that any link to a file in a folder that has a suffix fails in my IIs5 running on a Windows 2000 server. Example:
http://psych.csufresno.edu/phs217cal/default.mmd/d031001.htm

The default.mmd folder is the problem. I verified that my IIS will not allow access to ANY folder that has ANY suffix.  The same web pages worked well on my old Windows NT IIs4.  The UNC (\\psych.csufresno.edu\wwwroot\....." works fine when the file is opened with Internet Explorer. I can remove the .mmd, change the link in the calling page, and it works fine.

So the problem is isolated to my IIS.  The .mmd suffix is NOT a registered file type. Permissions are definitly set correctly. I cannot set the web pages to use no suffix because they are automatically generated by Meeting Maker. This problem occurs even when I access the http link in Internet Explorer while at the server keyboard.

I can't find any reference to such a problem anywhere. Not sure how to search for a solution since the .mmd is more likely called an extension which gets confused with the MS IIs extensions.

The server is up to date with MS patches and IIS Extensions.

Any clues would be appreciated.

Ron Zastovnik
Cal State University, Fresno
ronz@csufresno.edu
ronzeeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

daniel_cCommented:
Are you using URLScan?
If so, you need to modify your urlscan.ini a little bit.
- Go to <windows_path>\system32\inetsrv\urlscan\
- Open urlscan.ini
- Under [ Options ] section, change AllowDotInPath = 1, instead of 0
- Restart IIS and try it again.

HTH.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Servers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.