Solved

SSL on multiple sites on same IIS server

Posted on 2003-10-23
4
989 Views
Last Modified: 2013-12-04
I'm trying to configure SSL on multiple sites on the same server.  By default they all try to use port 443 as the SSL port and when I try to go to any of the sites using the https url I'm directed to the first site that I added SSL to no the server.  How can I accomplish this?  Do I have to enable other ports on the firewall and use those?  Is there a way to do this in the host headers?  Do I have to assign different IPs to the SSL sites?  Any help would be greatly appreciated.
0
Comment
Question by:smueller72
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 12

Accepted Solution

by:
gidds99 earned 125 total points
ID: 9611166
Yes you need different ip's for each site:

http://www.winnetmag.com/Web/Article/ArticleID/21205/Web_21205.html
0
 
LVL 1

Assisted Solution

by:jimcpl
jimcpl earned 125 total points
ID: 9719804
smueller,

I'm assuming that this is with IIS and a Windows Server?

First of all, host headers don't work with SSL.

Assuming that that this is a server, you have (at least) 2 choices:

1) You can assign more than 1 IP address to the NIC (go to Network, TCP/IP Properties, then click on Advanced, then add your IP addresses).  Then, in the IIS manager, "bind" each website to one of the IP addresses.  OR...

2) You can assign a different port # for the SSL port for each website.  If you took this approach, and, say, assigned ports 4430 and 4431 for two different websites, this would mean that the URLs for the sites would be, for example, https://mysite.com:4430, https:/mysite.com:4431, etc.

BTW, option #1 can only be done with Windows Servers (e.g., Windows 2000 Server, but not Windows 2000 Pro).

Jim
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Users of Windows 10 Professional can disable automatic reboots using the policy editor. This tool is not included in the Windows home edition. But don't worry! Follow the instructions below to install (a Win7) policy editor on your Windows 10 Home e…
OfficeMate Freezes on login or does not load after login credentials are input.
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
Are you ready to implement Active Directory best practices without reading 300+ pages? You're in luck. In this webinar hosted by Skyport Systems, you gain insight into Microsoft's latest comprehensive guide, with tips on the best and easiest way…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question