Solved

Boot failure

Posted on 2003-10-23
42
7,427 Views
Last Modified: 2013-12-27
I have a Solaris 8 (5.8) on a Sun Ultra10 box.  When I did a reboot, the system stalls at the line:

Rebooting with command:  boot
Boot device:  disk:a  File and args:
|

That last line is supposedly the spinning cursor, but it stops spinning.  No error messages produced whatsoever.  Can't get past this stage.  I have a set of Solaris 8 install disks.

Any suggestions as to what I can do?  I imagine there's something wrong with the boot block or the mounts, so I would need to run fsck, but how do I run it from here?

So, any suggestions would greatly help.  Thanks so much.

0
Comment
Question by:h3chan
  • 18
  • 11
  • 6
  • +2
42 Comments
 
LVL 38

Expert Comment

by:yuzh
Comment Utility
You can try the followings:

1. at ok prompt, type in:

probe-ide

# to verify if the box can see the Hard disk, if not hareware problem,
open the box chech power cable, IDE cable and the HD, or the IDE controller.

2. if 1) ok them, boot up sytem to single use mode use Solaris software CD:
   boot cdrom -s

   run "format" command to find out your harddisk divice name, eg c0t0d0.

   You might have a corrupted boot block, use the following command to fix it,

/usr/sbin/installboot /usr/platform/`uname -i`/lib/fs/ufs/bootblk /dev/rdsk/c0t0d0s0

   Please replace /dev/rdsk/c0t0d0s0 with the real / filesystem name in your system.
(it is likely the same !)


    Good luck!

    PS:  If you have got the answer for your old questions, please close them.
0
 
LVL 24

Expert Comment

by:shivsa
Comment Utility
I would suggest booting with kadb and let us where it stuck.
i can help with the interpretation of those messages.

and try to boot single user mode, to see if we reaches to that state or not.

ok boot kadb -s

0
 

Author Comment

by:h3chan
Comment Utility
Dear YUZH,

I followed the steps outlined by you, adn when I ran reboot after finishing the steps, the same result occured in that my System hangs at booting up at the exact same point as before.

Regarding answers from old questions...how do I close them?  I'm afraid I didn't know I had to do that.  Apologies here.

And to SHIVSA,

I ran boot kadb -s at the OK prompt, and this is my console after reset...

Rebooting with command:  boot kadb -s
Boot device: /ci@1f,0/pci@1,1/ide@3/disk@0,0:a  File and args:  kasdb -s
kadb:  kernel/sparcv9/unix
Size:  344568+90106+76202 Bytes
/platform/sun4u/kernel/sparcv9/unix loaded - 0xe0000 bytes used
/

...this is it.  The last '/' is where the cursor is and it has hung right there.

So, it seems that I still have the same problem as before.  Any recommendations now?  Thank you very much.
0
 
LVL 38

Expert Comment

by:yuzh
Comment Utility
Was the Ultra 10 working before, have you change any setting to the Sun box, change IP,
move the box to a different network?

Use the Solaris CD to boot up from single use mode,

boot cdrom -s

run fsck to all the filesystem on the HD, eg. (use format -> verify to find
out how many partitions you have, then fsck)

fsck -y /dev/rdsk/c0t0d0s0

then shultdown the system to ok prompt
sync
halt

At OK prompt,

try

boot disk

IF you still have problem, at ok prompt, type in:
printenv

and post the output

PS: To close an old question, you can accept a comment as the answer, or accept multiple
      comment as answer and split the points. have a look at the following page for more infor:
      http://www.experts-exchange.com/help/#13
0
 
LVL 24

Expert Comment

by:shivsa
Comment Utility
looks like it is hanging while building up the device tree.
could u do one more things and make sure where it is hanging.

when it hangs,
try to send break signal(STOP A/~#/<ctrl ] and break> and drop to kadb.
at the kadb prompt type,
kadb: $c

and send us the output.
0
 
LVL 16

Expert Comment

by:Hanno Schröder
Comment Utility
You may also try
  boot -avs
0
 

Author Comment

by:h3chan
Comment Utility
Dear YUZH,

I followed your steps to run fsck on my c0t0d0s0 partition, which turns out had many many problems.  After fsck finished, I got to the OK prompt and ran boot disk.  However, now my machine just keeps on resetting and resetting endlessly.  So, the problem is different now, but the result is the same.  No booting.

Also, how do I save or print the output of 'printenv' from the OK prompt?  I wanted to show you but I don't know how to copy that stuff over to my PC.

Thanks alot.
0
 

Author Comment

by:h3chan
Comment Utility
To JustUNIX,

I tried running 'boot -avs' and the output is:

Boot device: /pci@1f,0/pci@1,1/ide@3/disk@0,0:a  File and args: -avs
Enter filename  [kernel/sparcv9/unix]:

I entered all 3 of those choices, but it returns 'cannot open xxxx', or 'File not executable.  boot failed'.

What is 'boot -avs' anyways?
0
 
LVL 38

Expert Comment

by:yuzh
Comment Utility
You need to do fsck to all the filesystem, not only c0t0d0s0!

see my previous comment:

"run fsck to all the filesystem on the HD, eg. (use format -> verify to find
out how many partitions you have, then fsck)"

you can use format -> verify to find out, or boot up the system from cdrom
to single user mode, then mount the root filesystem, check the vfstab to find
out how your system is partition, eg:

boot -s
fsck -y /dev/rdsk/c0t0d0s0

mount /dev/rdsk/c0t0d0s0 /a
TERM=sun
export TERM
more /a/etc/vfstab

write down all the filesystem you have, and the do fsck.

eg:
your vfstab looks like:
#device         device          mount           FS      fsck    mount   mount
#to mount       to fsck         point           type    pass    at boot options
#
#/dev/dsk/c1d0s2 /dev/rdsk/c1d0s2 /usr          ufs     1       yes     -
fd      -       /dev/fd fd      -       no      -
/proc   -       /proc   proc    -       no      -
/dev/dsk/c0t0d0s3       -       -       swap    -       no      -
/dev/dsk/c0t0d0s0       /dev/rdsk/c0t0d0s0      /       ufs     1       no      -
/dev/dsk/c0t0d0s6       /dev/rdsk/c0t0d0s6      /usr    ufs     1       no      -
/dev/dsk/c0t0d0s1       /dev/rdsk/c0t0d0s1      /var    ufs     1       no      -
/dev/dsk/c0t0d0s7       /dev/rdsk/c0t0d0s7      /export ufs     2       yes     -
swap    -       /tmp    tmpfs   -       yes     -
/etc/vfstab (END)

you do:

fsck -y /dev/rdsk/c0t0d0s[167]

then shult it down:

umount /a
sync
sync
sync
halt

at ok prompt, type in

boot


0
 

Author Comment

by:h3chan
Comment Utility
Dear YUZH,

I have done that already and have fsck'ed all of the filesystems that I have.  The result is the same....a continuous loop of resetting!!

So that appears not to be the answer for some reason.

0
 
LVL 16

Expert Comment

by:Hanno Schröder
Comment Utility
boot -avs
-a    "ask", do interactive boot asking for options like boot device, kernel, system file etc.
-v    "verbose"
-s    "single user", boot to single-user reun level only

Getting the output
Boot device: /pci@1f,0/pci@1,1/ide@3/disk@0,0:a  File and args: -avs
Enter filename  [kernel/sparcv9/unix]:

reveils that
a) boot sector and boot device are OK
b) pressing Enter accepts the default (64 bit kernel), entering kernel/unix will boot 32 bit kernel
c) in the next step the system will start loading driver modules and you can supply a modified search path for modules (just use the default pressing Enter again) and name of the system file (enter dev/null, _without_ the leading slash! if not sure if yours is OK)
If the system stalls while loading modules there's not a lot you can do but trying to find out when it stops. That's why I'd like to see which messages is the last one loading modules (-v).
If nothing else happens after the first message (asking for kernel) try to boot the 32bit kernel. If this does not help either you will have to check your kernel files :-(((
0
 
LVL 16

Expert Comment

by:Hanno Schröder
Comment Utility
You said "continuous loop of resetting" -- what is the last message you get before the system does the reset?
0
 
LVL 38

Expert Comment

by:yuzh
Comment Utility
You might end up have to backup all the data, and reinstall the box.

try to post the message when the system is crashed, it might be a hardward problem
0
 
LVL 24

Expert Comment

by:shivsa
Comment Utility
Try to post the reset message somehow.
if u boot with the kadb, it will not boot all the time and drop to kadb.
then u can capture $c stack trace.
0
 

Author Comment

by:h3chan
Comment Utility
To JustUNIX,

Trying to boot with 'boot' or 'boot -avs' results in the same thing, the machine just winds up resetting itself, and then it boots itself again, only to reset itself, and so on.

This is what I see on screen when I did a STOP-A just before the system resets itself:

Boot device: disk:a  File and args:
WARNING: cannot open system file: etc/system
SunOS Release 5.8 Version Generic_108428-18 64-bit

panic[cpu0]/threads=10408000: read_binding_file: etc/name_to_major file not found

0000000010407650 genunix:read_binding_file+40 (10437324, 1045bf00, 5, 7530, 1045bf00, 0)

***** then a bunch of '0's and stuff *****

skipping system dump - no dump device configured
rebooting...


So, any ideas on what that means?
Lastly, apologies for my reply delay.  I was off for a bit.

Thank you kindly.
0
 
LVL 24

Expert Comment

by:shivsa
Comment Utility
it looks like that either your files are gone(like /etc/system and etc/name_to_major), means filesystem got corrupted, thus they are not mounted.
may be u can try to reinstall the OS. when trying to bootup the system choose option upgrade, if it ask u to choose.


0
 

Author Comment

by:h3chan
Comment Utility
SHIVSA,

But that would erase all my stuff within the current OS, right?  (if I select 'upgrade').  I think booting from CD will not be a problem I don't think.

Is there a workaround to my current problem without me having to lose all of the data inside (which I want to keep)?

Thank you.
0
 
LVL 24

Expert Comment

by:shivsa
Comment Utility
if u select upgrade than your all the data will be saved.
if u choose fresh install then your data will be lost.
0
 
LVL 38

Expert Comment

by:yuzh
Comment Utility
If you want to play safe, backup all the stuff in the HD, and then use the same version of OS CD
to run an upgrade installation. (same OS version will ensure all the app still work, don't forget
to apply the lastest patches)

http://sunsolve.sun.com/pub-cgi/show.pl?target=patchpage

Good luck!
0
 

Author Comment

by:h3chan
Comment Utility
Thanks for your tips.  2 questions...

1.  'boot cdrom' doesn't work anymore.  It just resets as if I ran 'boot'.
2.  How do I go about backing up everything on my disk??  (if I select install)

If my 'boot cdrom' doesn't even work, what options do I have?

Lastly, any idea what the heck happened to my disk?  Why did it f**k up like this, anyone seen these symptoms before?

I have nothing more than a file polling script running and an iPlanet application running (something like a directory server).
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 38

Expert Comment

by:yuzh
Comment Utility
you were able to run "boot cdrom -s" a few days ago!

open the box, check the cable connetion, and the cdrom (you could put the cdrom in a PC to
see if it work, it could be cable, cdrom, or the motherbpard problem)

If you have a boot server,  install it from your installation server
0
 

Author Comment

by:h3chan
Comment Utility
YUZH,

Yes it was a cable connection....very weird.  I don't think my Solaris was built every good!!

Question now is:  before I go ahead with the upgrade from CD, how can I access the disk and backup the relelvant files?
0
 

Author Comment

by:h3chan
Comment Utility
Also, when I run 'boot cdrom -s', thus putting me into single user mode, how do I run the CDROM such that I can perform the said upgrade?

Thank you very much.
0
 
LVL 38

Expert Comment

by:yuzh
Comment Utility
If you have a tape drive attached to the machine, you can use ufsdump or tar or cpio to copy your data
files.

If you don't have a tape drive, you can add HD to the box and dump the data to the new HD. (the IDE
HD is very cheap now, just get a small HD will do (well, it should big enough for your data !)

Have a look at the following pages to get soem idea about how to backup, and add new HD etc:
http://oldlook.experts-exchange.com/Operating_Systems/Solaris/Q_20782407.html
http://oldlook.experts-exchange.com/Operating_Systems/Solaris/Q_20556230.html

'boot cdrom -s' only boot up in sigle user mode, it is for backup or repair your system.

To install from CD, type in:

boot cdrom

PLEASE REMEMBER TO DO AN upgrade INSTALLATION !!!
Good luck!
0
 
LVL 16

Expert Comment

by:Hanno Schröder
Comment Utility
After done with backup ("boot -s") simply exit the shell and the system will proceed to installation automatically.

Last resort: Do a "boot -sba" to have a look. When asked for etc/system file enter "dev/null" (without the leading slash!). The system should come up withh root fs mounted read-only.
Earlier statements from some other participants that root is not mounted are simply wrong as root is getting "mounted" (but read-only) right after the kernel has load and starts to load its modules ("drivers").

It really looks like the system really got screwed up somehow :-(

Cheers
0
 

Author Comment

by:h3chan
Comment Utility
To YUZH,

Running 'boot cdrom -s' works, and gets me in single-user mode.
Running 'boot cdrom' does NOT work...it resets itself over and over.  I cannot get to the 'install or upgrade' selection.

So in light of this, how can I go about doing upgrade installation from CD???

To JustUNIX,

Running 'boot -sba', I'm presented with the following options:

Enter filename: [kernel/sparcv9/unix]:     ***I pressed ENTER***
Enter default directory for modules...      ***I pressed ENTER***
Name of system file [/dev/null]:             ***I entered 'dev/null'***
can't find file dev/null

Did I do something wrong here?  Geez none of the ideas seems to be working.  I cannot even do an upgrade installation.

Any help would be appreciated.  Thank you very much.

0
 
LVL 38

Expert Comment

by:yuzh
Comment Utility
which CD are  you using, please tell use the lable on the CD.
0
 

Author Comment

by:h3chan
Comment Utility
Solaris 8 Installation, 4/01

Should be the right disk!
0
 
LVL 38

Expert Comment

by:yuzh
Comment Utility
You are using the WRONG CD, you should use:

Solaris Software CD 1 of 2

Good luck!
0
 

Author Comment

by:h3chan
Comment Utility
When I selected the 'Upgrade' instead of 'Initial', it returned a pop-up saying:

The Solaris Version (Solaris 8) on slice c0t0d0s0 cannot be upgraded.

The file system table (vfstab) could not be opened.

So I had to quit the install console.

Secondly, I tried running boot from OK prompt again.  Now, it gives the following return on the console:

Rebooting with command: boot
Boot device: disk:a  File and args:
Boot load failed.
The file just loaded does not appear to be executable.
Boot device: disk:a  File and args:
Boot load failed.
The file just loaded does not appear to be executable.
ok

So, no more continuous resetting....but what is this above from the console now?  **shaking head**
0
 
LVL 38

Accepted Solution

by:
yuzh earned 50 total points
Comment Utility
Have you backup up all your data?

It may be the /etc/vfstab is corrupted, or the filesystem is dameged. (or you
may lost some other system file as well)

run fsck to check all the filesystems again, and then try the upgrade installation.
If you still have problem, consider to perform an fresh installation, you can use
a new HD for the new installation if you don't have data backup, and then try
to transfer the data from the old HD back to the new one.

I think you should ask an experienced Solaris sys adm to help you out. it is very
hard for us to tell you what to do via this little webpage.

0
 

Expert Comment

by:h_rock
Comment Utility
It's been a while since I've continued with this post....

I'd just like to know, at this juncture, what the specifics are for me to backup my data within the harddisk.  There seems to be no way I can get the system to boot properly.

I even did what's stated in this site:

http://www.sunmanagers.org/pipermail/summaries/2002-April/002796.html

And it didn't work.  Although that is really for Solaris 2.6.  Mine is Solaris 5.8, but it should be the same, regarding the overwrite of SUNWcar (Core architecture files)

Any ideas?  My priority now is to backup my data, but I can only get into single user mode now.  So what's my options?

If anyone has an idea on how I can get my system to boot, I'd appreciate that too.

I thought I'd just continue with this thread rather than start a new thread.

Thank you all.
0
 

Author Comment

by:h3chan
Comment Utility
Question,

In an attempt to backup the data from my harddisk which doesn't boot, is it possible for me to install a harddisk used for Windows (Maxtor brand, IDE) onto the Sun Ultra 10 machine?

Could I install Solaris 8 on it?  And then if that's viable, I can then mount the unbootable harddisk, which is now a slave harddisk, onto my new Solaris harddisk, and copy everything over?

Are my assumptions correct?

0
 
LVL 24

Expert Comment

by:shivsa
Comment Utility
Yup this might work if that harddisk is supported on sun hardware.
u can always try there is no harm inthat.

first remove your harddisk which u want to backup from the system.
put the new disk into the system and see if obp recognize this.
at ok prompt type
reset-all
probe-ide-all

if u see the disk.
try to install the solaris, if u are able to install then bring in backyour old disk and put it back to the system.
mount it and backup your data.
0
 

Author Comment

by:h3chan
Comment Utility
Yes, apologies,

Yes, h3chan and h_rock are indeed me.  I wish to retain h3chan, so you can close h_rock.

I have an explanation.  I use my original h3chan account at work.  However, when I attempt to log in at home with h3chan, it NEVER lets me log in.  Every time I log in and enter my password, then submit, the next screen comes up as if I never logged in (ie. it doesn't say my username under "Your status").

Due to this fact, I had to create a new account.

I really want to use ONE account, of course, for convenience.  So any reason or remedy as to why I cannot log in at home with h3chan?

I use Win2K Pro, IE5 at work.  I use WinXP Pro, IE6 at home.
0
 
LVL 16

Expert Comment

by:Hanno Schröder
Comment Utility
Back to your restauration attempts:
The message "can't find file dev/null" shows that there's really quite some essential
files missing on your system!
a) Try to backup as much as possible
    - boot from CD (using boot cdrom -s)
    - mount your root fs (mount /dev/dsk/c0t0d0s0 /a)
    - backup files to tape using tar, ufsdump, cpio or whatever you like
    - look into /a/etc/vfstab to see what additional fs there are
       - mount and backup these too
b) Do a clean install from CD
0
 

Author Comment

by:h3chan
Comment Utility
Question:

Now that I've installed Solaris 8 on another harddisk, I must plug my corrupted harddisk back into the Sun system as slave.

So, I've set the harddisk jumper to slave and plugged it in, then booted my system.

How do I mount the slave drive??  Where can I find it?
0
 

Author Comment

by:h3chan
Comment Utility
I plugged my old corrupted drive into the system, set its jumper as slave, booted the system, and when I ran 'format', it only showed 1 disk (the primary, uncorrupted one).

I'm assuming that this is not right.  However, I've plugged the slave drive in properly.

What is wrong?  I just want to be able to read the slave drive's contents so I can back it up.

Any thoughts?
0
 
LVL 38

Expert Comment

by:yuzh
Comment Utility
at ok prompt,

type in:
probe-ide

to check if your sun box can see all the HDs.

If not, you need to check jumper settings, power cable, IDE cable etc

0
 

Author Comment

by:h3chan
Comment Utility
yuzh,

Both harddisks are there when I run probe-ide (primary master and primary slave).  I've checked this before.  I ran 'reset-all' after I installed the slave drive.

BUT, still, when I run 'format', it lets me select ONLY the primary master disk.

Thus, how can I mount the slave drive??
0
 

Author Comment

by:h3chan
Comment Utility
Anyone have any insight towards my query?  Please see my previous comment.

I cannot find my slave drive when I run 'format' (it only shows my primary disk), and therefore I cannot mount it.

I'm trying to mount my slave drive so that I can backup stuff from the slave drive to my new primary drive.  My slave drive seems to be corrupt.

Thanks for your help.

0

Featured Post

What Security Threats Are You Missing?

Enhance your security with threat intelligence from the web. Get trending threat insights on hackers, exploits, and suspicious IP addresses delivered to your inbox with our free Cyber Daily.

Join & Write a Comment

A metadevice consists of one or more devices (slices). It can be expanded by adding slices. Then, it can be grown to fill a larger space while the file system is in use. However, not all UNIX file systems (UFS) can be expanded this way. The conca…
Installing FreeBSD… FreeBSD is a darling of an operating system. The stability and usability make it a clear choice for servers and desktops (for the cunning). Savvy?  The Ports collection makes available every popular FOSS application and packag…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
In a previous video, we went over how to export a DynamoDB table into Amazon S3.  In this video, we show how to load the export from S3 into a DynamoDB table.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now