Solved

Coldfusion 5.0/Apache Virtual Hosting/Caching/mapping problems (linux)!

Posted on 2003-10-23
18
456 Views
Last Modified: 2013-12-24
Hi,

to make things simple, i bascially have the same problem this person had:
http://www.experts-exchange.com/Web/WebDevSoftware/ColdFusion/Q_20563247.html

but with coldfusion server 5.0 for linux. I have a few virtualhosts and ips using redhat 8.0 and apache1.3.28.

so yeah, it only loads files from the mapping "/" set as my document root, and it only looks there no matter what domain i am trying to access.

my virtualhosting is setup as /home/usernamehere/public_html

my documentroot is /var/www/html, at least it is set as that for now.

anyone has any sort of suggestions whatsoever! i have been trying to solve this problem for over 5 days now and it has been a complete headacke.

Again it doesn't appear i can turn of caching (i have Trust cache UNchecked)

thanks ahead of time!

oh yeah, i have this error in my logs as well:

[Thu Oct 23 23:33:02 2003] [warn] mod_mime: analyze_ct: cannot get media type from 'type-coldfusion'

which is some sort of apache issue
0
Comment
Question by:jfrydman
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 4
  • 3
  • +1
18 Comments
 

Author Comment

by:jfrydman
ID: 9612366
oh yeah, i have this error in my logs as well:

[Thu Oct 23 23:33:02 2003] [warn] mod_mime: analyze_ct: cannot get media type from 'type-coldfusion'

which is some sort of apache issue
0
 
LVL 17

Expert Comment

by:anandkp
ID: 9612841
hmmm with MX - its basically the change in jrun.xml

/opt/coldfusionmx/runtime/servers/default/SERVER-INF/jrun.xml
 
Find the entry named "cacheRealPath" within the file. The default for this setting is "true," as shown here:
<attribute name="cacheRealPath">true</attribute>
 
Change the entry to "false," as shown here:
<attribute name="cacheRealPath">false</attribute>
 
Save the file. Stop and restart ColdFusion MX

try & do this for 5.0 & see if it helps ... i never faced this problem ...

let me know

K'Rgds
Anand
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 9616099
do you have the coldfusion.so module configured to work with CF 5.0?

Can you load any CF page (not virtual host mapped) just localhost?

CJ
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 

Author Comment

by:jfrydman
ID: 9616234
yes. the coldfusion administrator works. plus any coldfusion page in the document root loads just fine. I compiled it my self from the src in the webservers/apache folder.
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 9616441
so you have your virtual hosts specified in the httpd.conf file right?

CJ
0
 

Author Comment

by:jfrydman
ID: 9616613
yes, there are virtualhosts via ips and everything. i can paste the httpd.conf. it was all generated by direct admin, a web panel for linux....
0
 
LVL 17

Expert Comment

by:anandkp
ID: 9618669
just a thought - do ur applications tags have the same name for ur applications ???
0
 

Author Comment

by:jfrydman
ID: 9618681
no they don't, at least i don't even have an application tag in a script that is being used at the moment.
0
 
LVL 4

Expert Comment

by:procept
ID: 9619120
Hi,

please check your <VirtualHost> section of httpd.conf. You might have to configure a DocumentRoot directive for each <VirtualHost> block, something like this:

<VirtualHost *>
    ServerName www.domain.tld
    DocumentRoot /www/domain
</VirtualHost>

<VirtualHost *>
    ServerName www.otherdomain.tld
    DocumentRoot /www/otherdomain
</VirtualHost>

HTH,

Chris


0
 

Author Comment

by:jfrydman
ID: 9619129
hi,

thanks for the suggestion, yes i actually have

<VirtualHost MYIPADDRESSHERE>

but i have a documentroot set for every vhost.
0
 

Accepted Solution

by:
jfrydman earned 0 total points
ID: 9619225
refund points please, i got it working. i just installed CFMX 6.1....5 appears it was never going to work on this server
0
 
LVL 4

Expert Comment

by:procept
ID: 9619236
Glad you upgraded... 6.1 is much better (and faster!!) than 5. Hope you like it. :-))

Cheers,

Chris
0
 

Author Comment

by:jfrydman
ID: 9619239
it was still a super pain to get working, had to compile the connector and everything...but yeah, just glad it is up and running and i spent more money :/
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 9619309
Ask Communit Support to Refund your points.

CJ
0
 

Author Comment

by:jfrydman
ID: 9619312
where do i do that? this is the first time i have ever used this site
0
 
LVL 19

Expert Comment

by:cheekycj
ID: 9619318
Go here:
http://www.experts-exchange.com/Community_Support/

Ask a 0 point question directing an Admin to this question:
http://www.experts-exchange.com/Web/WebDevSoftware/ColdFusion/Q_20776700.html

And ask them to either PAQ it or Delete it.  It usually gets done pretty fast as the Admin/mod team here is pretty good.

CJ
0
 

Author Comment

by:jfrydman
ID: 9619330
cool thanks.

and also big thanks to everyone who tried to help me! really appreciate it.
0
 
LVL 17

Expert Comment

by:anandkp
ID: 9624928
ur welcome :)
0

Featured Post

Free NetCrunch network monitor licenses!

Only on Experts-Exchange: Sign-up for a free-trial and we'll send you your permanent license!

Here is what you get: 30 Nodes | Unlimited Sensors | No Time Restrictions | Absolutely FREE!

Act now. This offer ends July 14, 2017.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Article by: kevp75
Hey folks, 'bout time for me to come around with a little tip. Thanks to IIS 7.5 Extensions and Microsoft (well... really Windows 8, and IIS 8 I guess...), we can now prime our Application Pools, when IIS starts. Now, though it would be nice t…
What You Need to Know when Searching for a Webhost Provider
The purpose of this video is to demonstrate how to manually back up a WordPress Database. This will be demonstrated using a Windows 8 PC. The Host used will be IPage.com Log into your Hosting account. IPage will be used for demonstration : Locat…
The purpose of this video is to demonstrate how to exclude a particular blog category from the main blog page. This is can be used when a category already has its own tab, or you simply want certain types of posts not to show up on the main blog. …

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question