Solved

Shared disks not showing on clustered server

Posted on 2003-10-24
17
555 Views
Last Modified: 2013-11-15
We have a clustered server, a Compaq Proliant CL380. We had some problems with the shared disks, so we changed the SCSI controler board for one identical from another server.

When restarting the server, the shared disks does not show up either as drives in the exporer, nor in the disk management. Not on any of the nodes.

They do show up in the Array Configuration Utility, though. As they do, they should also be available in the disk management...

Anyone got a lead on this?
0
Comment
Question by:Göran Andersson
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
17 Comments
 
LVL 11

Expert Comment

by:ewtaylor
ID: 9614052
I have had some issues with this also, how are they shared out? If they are shared out the normal way then when the cluster rolls (nodes switch) the shares will be lost. The shares must be created through cluster manager. I found this out the hard way with user shares, after having to recreate em several times.
0
 
LVL 29

Author Comment

by:Göran Andersson
ID: 9614193
Thanks for the prompt response.

I didn't get any closer to the solution, though. This server has been running in this setup for over a year, and we have switched nodes many times without problems.
0
 
LVL 11

Expert Comment

by:ewtaylor
ID: 9614408
I take it you are running win2k? What version of cluster services are you running? Have you made sure all the cluster resources are running on a single node? I would shut down one side while you troubleshoot.
0
Free Webinar: AWS Backup & DR

Join our upcoming webinar with experts from AWS, CloudBerry Lab, and the Town of Edgartown IT to discuss best practices for simplifying online backup management and cutting costs.

 
LVL 29

Author Comment

by:Göran Andersson
ID: 9614550
Yes, I'm running win2k, hence the post in the win2k area... ;)

The version of the Cluster Administrator is 5.0 The version of the Compaq Manamgement tools is rev. 4.90. Does that tell you what you wanted to know?

The resources are not working from any node. If I could reach the disks from any node, I would be happy... I have tried starting the server with a single node or both nodes.
0
 
LVL 11

Expert Comment

by:ewtaylor
ID: 9614717
You would be surprised how many non win2k questions are posted here, safer to just ask. That looks like the most recent version of MSCS It sounds like a hardware issue, have you checked all the dip switches, jumpers and terminators?
0
 
LVL 4

Expert Comment

by:darth_wannabe
ID: 9615517
If you swapped out the controller, it won't know about the disks. I think you have to save the config (to a floppy or something), install the new controller, and then load the old config.
0
 
LVL 29

Author Comment

by:Göran Andersson
ID: 9617127
No, ewtaylor, I havent checked all the switches and such actually... but we have two almost identical clustered servers (both are Proliant CL380, but differs in production date) that we are currently trying the cluster controler (CR3500) in. I can't imagine than any switches suddenly has changed by themselves... and not on four nodes at the same time...

We have two servers, so we have two CR3500 units. When we put one of them in either of the servers, it fails to recognise the disks correctly. Warning light flashing. When we put the other in either server, it seams to recognise the disks correctly. So it seams we have one CR3500 that doesn't works, and one that does. But none of the nodes in either of the servers are able to use the disks with either of the controlers...

darth_wannabe, we have done that in a different way. We have run the erase disk on the node (with all hard drives removed) to clear the nvram, and then run the system setup disks to reconfigure the hardware setup from scratch. That's what the support said we should do... Is that wrong?

The Array Configuration Utility knows about the disks, and shows all the information correctly, but the disks doesn't show up in the disk management. So the information about the shared disks are available to the nodes, but they fail to recognise them as disks...

As both servers have the same problem, maybe the controler that seams to work also is faulty in some way? As we have two complete servers except for the controler, this is the only common part... Any thoughts?
0
 
LVL 11

Expert Comment

by:ewtaylor
ID: 9617408
Anything in the event viewer? Maybe an event id 1034?
0
 
LVL 29

Author Comment

by:Göran Andersson
ID: 9617812
I found no 1034 in any even log. I get event id:s 9, 1009 and 7031 in the system log when the cluster service fails to start. Wan't details on those? (I'll browse from the cluster then, so I can copy from the logs...)
0
 
LVL 11

Expert Comment

by:ewtaylor
ID: 9621268
Not sure which applies here, the first says an event id 9 is due to timeout on the scsi controller. http://support.microsoft.com/?kbid=259237

This link talks about authentication problems which does not seem likely. http://support.microsoft.com/?kbid=272129
0
 
LVL 29

Author Comment

by:Göran Andersson
ID: 9621485
I think that the timeout is because the disks cannot be accessed at all by windows...

The other article does not apply exactly to my situation, as the cluster service can't start on any of the nodes. I'll look a bit closer on what it has to say about permissions, though.
0
 
LVL 11

Expert Comment

by:ewtaylor
ID: 9627314
You might want to get compaq to send you a new controller and test that. After that I have used up all my cluster knowledge, sorry I could not be of help. Please keep us updated.
0
 
LVL 29

Author Comment

by:Göran Andersson
ID: 9810066
Right, forgot to close this one... Sorry.

This is what has happened:

We talked to Compaq support, and they said that there was no way of restoring the data. The information needed was stored in the controller that does not work any more.

So, we experimented a bit, as we thought there was nothing to lose. We put the disks in another server, and configured them. They worked fine, but there was no data on them.

Then we put them back in the original server, to reinstall it. When we had installed the operating system on one node, and started to configure the shared disks, they show up as already configured, and the data is intact. There were a few bad clusters that we had to repair, but other that that, we managed to copy all the data we wanted from the disks before formatting them again.

So, more or less by chance, we managed to do something that even Compaq says is impossible.

I don't know how to reward points for this question, though. I'd like to reward points for the help given on the way, but there is not really any "correct answer" to accept...
0
 
LVL 11

Expert Comment

by:ewtaylor
ID: 9815228
Thanks for the update, good to know...have them paq and refund this question for you
0
 

Accepted Solution

by:
PashaMod earned 0 total points
ID: 10088772
PAQed, with points refunded (500)

PashaMod
Community Support Moderator
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Cannot load device driver, error code 39 25 207
Backup Exec & Exchange 2 52
how to run this deletion request 4 39
Anything wrong with Window server backup? 8 92
How to update Firmware and Bios in Dell Equalogic PS6000 Arrays and Hard Disks firmware update.
In this article we will learn how to backup a VMware farm using Nakivo Backup & Replication. In this tutorial we will install the software on a Windows 2012 R2 Server.
To efficiently enable the rotation of USB drives for backups, storage pools need to be created. This way no matter which USB drive is installed, the backups will successfully write without any administrative intervention. Multiple USB devices need t…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question