553 Requested action not taken: mailbox name not allowed

One particular company is trying to email my site and keeps getting this error for any person she trys to email here (i've had her try four):

----- The following addresses had permanent fatal errors -----
<anyuser@mydomain.com>
    (reason: 553 Requested action not taken: mailbox name not allowed or
chunk too large)

I've been digging around here and 2 other sites and haven't really found any info on this error, let alone a possible solution.

I'm running NT 4 SP6a, EX 5.5 SP4.  We also have a Watchgaurd FB1000 III.  It's been in place since May and this is the first person to at least report this error to us.

She has emailed me the error report to my yahoo account.  Just to reiterate, she's the only one to get this error when emailing my company.  The only thing out of the ordinary lately, and it's just growing out of control as you all know, is we have been getting 10 fold the ammount of spam as we use to get just in this past month.  One user who use to get 50 spams a day now can get up to 300-500 a day.  We use Spamscreen from Watchgaurd.
stigxpAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JasonBighamCommented:
Technically, this is a problem on their end, not yours. So technically, it's their problem... but, we all know how that goes. This is not an Exchaneg error though.

I think this is caused by their firewall denying esmtp out. Have them check...
0
JasonBighamCommented:
Both parties should check their usage of SMTP filters on their respective firewalls as well, though I am still inclined to believe it's them... but take a peak on your Watchgaurd SMTP filter settings as well.
0
JasonBighamCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
stigxpAuthor Commented:
Damn, I think I like this site.  3 comments by the same guy in a matter of minutes of me posting here.  Thanks so much J.  I'll have a peak at that site a little later, I have to eat now, it's 2 hours past my lunch.  I did just find a blurb about turning off ESMTP commands?  I'll have to look into that as well.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.