Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people, just like you, are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
Solved

Win2K Wireless Lan Setup

Posted on 2003-10-26
6
5,428 Views
Last Modified: 2013-11-29
I have a Toshiba Portege 4000 laptop with built in WIFI card and just purchased new DLink wireless router and ADSL hub.  I can get the desktop machine working on the workgroup fine, connect to the internet, ping the router etc... all fine using the built in DHCP in the router. The laptop says I have EXCELLENT Wifi connection but am unable to ping ANYTHING, when I use IPCONFIG it says the Wireless LAN connection DOES NOT have IP address, also says Wireless network cable is unplugged.

Have tried anything and everything, even assigning IP address by hand but cant seem to get through to the router at all, have opening up all necessary ports and turned off the router firewall, also allowed ICMP to work etc etc  I can ping localhost from the laptop so know TCPIP is working properly just seem to be unable to "attach" the TCP to the wireless LAN card and hence use internet / local LAN.

I am ready to throw everything out the window! Please help!
0
Comment
Question by:alexcn
6 Comments
 
LVL 49

Expert Comment

by:sunray_2003
ID: 9622200
Disable all the firewall if any

Go to the web management of the router and check the SSID and channel are set the same in router and wifi card

go to status in web management of router and check to see if there is a button for connection or connecting.click on that

Make sure you have setup the router the correct way

Restart the machine and try

Sunray
0
 
LVL 17

Expert Comment

by:John Gates
ID: 9624522
Make sure that you don't have any WEP enabled also for testing (Just until you establish connectivity)

D
0
 
LVL 1

Accepted Solution

by:
flanque earned 250 total points
ID: 9626027
Okay I will assume that you haven't set the wireless up correctly, so here's a brief tutorial on how to do it. Despite having an "excellent connection", that doesn't mean your wireless is correctly configured from a network perspective.

Firstly, your wireless access point must have an IP, unless it is a transparent bridge, but even then I would think it would still have an IP address. Oh and just for the sake of completeness, ensure that both your AP and laptop are using the 802.11b protocol.

Now...

Disable all firewalls just for testing.
Set your wireless AP to have a LAN IP.
Select a channel for your AP and an SSID. Use the same on your laptop wifi card.
You both will need your own UNIQUE "wireless network name".
Make sure that your laptop wifi card is set to be in wireless client mode. Yeah I know it will be but just check.
Now, assign your laptop an IP address on the same network as the AP. That means for example, the wireless AP could have 192.168.0.1 and your laptop could have 192.168.0.2. I don't think that the wifi card will require an IP address. If it does, place it on the same network, say 192.168.0.3.
Disable WEP for the sake of testing.

You should now be within range, and if you are you should still have excellent signal strength. Try to ping your local IP and then the wireless AP. I would be suprised if it doesn't work.

Hope this helps.


Cheers.

0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 1

Author Comment

by:alexcn
ID: 9626116
Thanks for comments thusfar, my first question on here so hope I pull this off correctly.  Anyway, in terms of further info in response to your kind suggestions:

1) Have tried with WEP disabled / enabled and all firewalls on desktop shutdown.  Laptop DOES NOT have any firewall software installed whatsoever.
2) D-Link DI-624 router has DCHP installed which works fine for desktop, IPCONFIG /ALL in laptop says no IP address assigned to internal Wifi card.  Tried setting an IP address manually, on either and both machines but still nothing on the TCP over Wifi.
3) DCHP on router set to allocated IP's in range 192.168.0.100 thru .199.  Desktop correctly picks up 192.168.0.100, have set laptop manually to 192.168.0.101 on previous attempts.  Router is set to 192.168.0.200 (D-Link this morning suggested using 192.168.1.1 for the router IP address, and keep 192.168.0.1 for the D-Link ADSL modem instead but it should still work)
3) Can ping the localhost AND 127.0.0.1 on laptop which, I think, would indicate that TCPIP is installed properly and DNS is being resolved? Yes?
4) Use the same network name (workgroup name as opposed to domain name?) on both machines.
5) Web-based management tool of D-Link DI-624 router says in Wireless Status page that laptop is connected.
6) Strange occurence that Network / LAN connection icon next to the clock (i.e. the two little monitor screens) has a red X against it, and hovering over the mouse brings up popup saying "Cable Disconnected"
7) Have even tried plugging the other network card in the laptop into the router directly, and that works fine!

Its almost like the wireless connection is there, but the laptop does not see using TCPIP and hence the workgroup network over the wireless part as being an option, and has left me wondering if there is a software switch somewhere to turn this bit on?

I just downloaded Laptop manual from Toshiba's website and am wondering if the setup of the profile as being of type "Access Point" for an enterprise network verses "Peer-to-Peer Group" for a workgroup is the reason? Am I right in thinking the AP is in terms of when a Domain Controller is in existence on the work?

I really appreciate your help and support!
0
 
LVL 1

Expert Comment

by:flanque
ID: 9626152
Um, okay, your wireless in the laptop CANNOT be in Access Point mode. I didn't know it was possible for that. Your laptop's wireless component needs to be in a client mode. Try the peer-to-peer and using my instructions above.

Let me know how it goes.

0
 
LVL 17

Expert Comment

by:John Gates
ID: 9626628
The differences are Ad-Hoc (No AP just card to card) and infrastructure (With an AP) Your clients should be set up as Infrastructure.
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Short answer to this question: there is no effective WiFi manager in iOS devices as seen in Windows WiFi or Macbook OSx WiFi management, but this article will try and provide some amicable solutions to better suite your needs.
When it comes to security, there are always trade-offs between security and convenience/ease of administration. This article examines some of the main pros and cons of using key authentication vs password authentication for hosting an SFTP server.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question