?
Solved

Win XP versus Win98/W2k on ACPI (Added TI Cardbus PCI-1225 causes boot hangup)

Posted on 2003-10-26
12
Medium Priority
?
7,513 Views
Last Modified: 2011-04-14
Hello,

I had a system with a dual boot Win98SE/Win2kSP4.

I tried to install WinXP Prof SP1a as a third OS, only to find the installation to hang.
After a lot of trial and error I have found the source of the problem: a TI Cardbus Controller PC-1225. When I removed this card, WinXP installed normally, but as soon as I put the card back in, it hangs at boot (MUP.SYS is the last driver I see loading). When I put it in a different PCI slot, WinXP boots normally, but when it detects the cardbus controller it hangs.

The strange thing is that the same configuration works fine under Win98 en Win2k.
I have found MS KB article, describing the behaviour I experience under Win XP
(http://support.microsoft.com/default.aspx?scid=kb;en-us;295629), only this article refers to Win98SE and WinMe?

I suspect ACPI is involved, I base this on the text in the following KB article:
http://support.microsoft.com/default.aspx?scid=kb;en-us;314830&Product=winxp
"A computer that works properly with Microsoft Windows 98 may not work with Windows XP. Windows 98 does not necessarily use all of the ACPI functions that Windows XP uses. Windows 98 may allow workarounds that Windows XP cannot use because of its more stringent requirements for system stability)."

Any ideas on how to solve this? Or is the only workaround a reinstall of WinXP with Standard PC HAL instead of ACPI?

Thanks,

Peter.
0
Comment
Question by:qpete
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
12 Comments
 
LVL 7

Expert Comment

by:Jonybrv
ID: 9623735
Did you try a BIOS update ?
0
 

Author Comment

by:qpete
ID: 9623864
I have already upgraded to the latest available bios for my motherboard (BIOS ID 07/11/2002-8363-686B-6A6LMA19C, it pertains to a Abit KT7A), but no changes in behaviour there. Win XP SP1a just won't boot when the cardbus controller is put in (I have tried different sequences of PCI cards too).

I have now inquired at http://www.esupport.com/biosagent/ whether they can provide a bios upgrade, but no answer there yet (I have only just asked a few a hours ago).

Any other thoughts?

Thx,

Peter.
0
WatchGuard's M Series Appliances - Miecom Approved

WatchGuard's newest M series appliances were put to the test by Miercom.  We had great results and outperformed all of our competitors in both stateless and stateful traffic throghput scenarios! Ready to see how your UTM appliance stacked up? Download the Miercom Report!

 

Author Comment

by:qpete
ID: 9625194
Yes, I already indicated that solution in my original question, but is that really the only way? Will this not lead to loss of functionality (e.g. the computer no longer being able to perform a shutdown with auto power off?)?
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 9625453
You can still "soft off" if you enable APM support in the BIOS and add a new device manually via add new hardware "NT APM/Legacy Support" which will allow soft off.

This is a PCI card, right?  Have you tried installing the VIA HYperion drivers (4in1) from http://www.viaarena.com/?PageID=300 ?

-dog*
0
 

Author Comment

by:qpete
ID: 9629367
Thanks for the tip, dog, I downloaded the latest version of the 4in1 drivers (4.49 dd. 20/08/2003), installed it, but alas, no change, I can see the via*.sys drivers are loaded (safe mode), but the booting stops again at mup.sys.

I have searched the net on updated drivers for this Texas Instruments PCI-1225 Cardbus controller, but I can only find drivers for Win95/Win98.

But if I understand you correctly, switching to Standard PC HAL instead of ACPI, would not result in a loss of functionality?

Pete.
0
 
LVL 16

Accepted Solution

by:
Kyle Schroeder earned 1000 total points
ID: 9630692
http://www.experts-exchange.com/Operating_Systems/Q_20584708.html
Similar problem to yours, there is a note in there that is likely correct...the mup.sys file is probably just fine and it just happens that this is the last file that loads.  Do you have a USB mouse on this system by chance?

After you flashed the BIOS, did you enter BIOS setup and choose "Load Setup defaults"?  This fixed a hanging problem I was having with my old Abit KA7 board (Slot-A Athlon 700!)

The card appears to be XP compatible:
http://www.microsoft.com/windows/catalog/default.aspx?subID=22&xslt=search&qu=pci1225&scope=1

I think the problem is going to be cleared by BIOS adjustments.  What settings are you using under the "PCI/PnP Configuration" section of BIOS?  Is "Plug n Play OS" enabled? If so, set it to NO/disabled. APIC? MPS setting (if there)?  Take a look at Sudhian Media's "Paul's Unofficial Abit KT7A-(RAID) FAQ":
http://www.sudhian.com/showfaqs.cfm?fid=2
Especially see the IRQs and Resources section: http://www.sudhian.com/showfaqs.cfm?fid=2&fcid=26
There is a table of how the IRQs are shared between PCI slots.  Try disabling unused COM/LPT ports in BIOS (and the RAID controller if you're not using that).

-dog*
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 9630712
ALso, verify the exact model of your board.  It should be printed on the board near the PCI slots, also note the revision from the barcoded sticker (i.e. 1.2, 1.3) as the BIOSes are different for these models.
KT7A <1.3: http://www.abit-usa.com/downloads/bios/bios_revision.php?categories=1&model=88
KT7A v1.3: http://www.abit-usa.com/downloads/bios/bios_revision.php?categories=1&model=126

See also:
http://www.abit-usa.com/downloads/bios/amd.php

-dog*
0
 

Author Comment

by:qpete
ID: 9632578
My mobo is the 1.0 version of the Abit KT7A (no RAID), and I have the latest available BIOS A9 dd. 11/07/2002. I cleared the CMOS (with the jumper on the mobo) after upgrading to this version.

I do not have a USB mouse. There are quite a few USB 1.1 and USB 2.0 devices connected though. I tried booting without any USB device hooked up, with USB support disabled in the BIOS, no serial or parallel ports enabled, with the PNP OS set to "No" (it was originally set to "Yes"), with the BIOS "fail-safe defaults", and with the BIOS "optimized defaults": still the same result.

There is no BIOS setting to disable ACPI: the only option I have there is the "ACPI Suspend Type", currently set to "S1(POS)". I can only choose "S3 (STR)" as another option, I haven't tried that yet. MPS setting is not available. I'm using the settings from the following site:
http://www.building-your-own-computer.com/bios_settings.shtml.
Do you see any settings in there that might help solving the problem?

Pete.
0
 

Author Comment

by:qpete
ID: 9632695
I do not think it is a problem of shared IRQ's since I also tried booting with only the AGP video card (a Radeon 7000 Dual Display) and only one PCI card (the TI PCI-1225), and it also didn't boot.

One more thing, before the trouble started I had WinXP without SP1a, and didn't have any problems.
It was only after installing SP1a, that the system didn't boot anymore, so it must be one of the fixes in this SP that causes the problem:

http://support.microsoft.com/default.aspx?scid=%2fsupport%2fServicePacks%2fWindows%2fXP%2fSP1FixList.asp

In that list there are updates for the PCMCIA driver (since this driver controls the TI PCI-1125):
http://support.microsoft.com/default.aspx?scid=kb;en-us;310772
http://support.microsoft.com/default.aspx?scid=kb;en-us;318213

Would it help if I restored the PCMCIA.SYS driver from the original WinXP?
Or does this require registry settings as well?

Pete.
0
 

Author Comment

by:qpete
ID: 9642324
Guess what! Restoring the PCMCIA.SYS file from the WinXP disc (without SP1a) fixed the problem!

Thanks everyone for thinking along, and the points go to dogztar for the many usefull hints that made me think of the final solution.

Cheers,

Pete.
0
 
LVL 16

Expert Comment

by:Kyle Schroeder
ID: 9647814
Well, glad you got it working Pete, and that I was able to offer some insight, even if you did end up figuring it out yourself.

-dog*
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This is about my first experience with programming Arduino.
This paper addresses the security of Sennheiser DECT Contact Center and Office (CC&O) headsets. It describes the DECT security chain comprised of “Pairing”, “Per Call Authentication” and “Encryption”, which are all part of the standard DECT protocol.
NetCrunch network monitor is a highly extensive platform for network monitoring and alert generation. In this video you'll see a live demo of NetCrunch with most notable features explained in a walk-through manner. You'll also get to know the philos…
Visualize your data even better in Access queries. Given a date and a value, this lesson shows how to compare that value with the previous value, calculate the difference, and display a circle if the value is the same, an up triangle if it increased…
Suggested Courses
Course of the Month13 days, 8 hours left to enroll

801 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question