Solved

Windows XP seeing UDMA5 drive as UDMA4

Posted on 2003-10-26
28
2,142 Views
Last Modified: 2012-08-13
Hello,

My UDMA5 hard disk is only being seen as a UDMA4 hard disk in Windows XP pro device manager

I did a few benchmarks in sandra pro 2k3 and my drive is running at around 8mb p/s... (pitiful... around ata33 speed)

Should be around 20mb p/s if it was on udma5

here's my config:
Gigabyte GA-6vtxe-a / PIII 1.0GHz / via 694 (Apollo Pro 133T) chipset / 256mb 133 sdram
Quantum Fireball lct 20gb udma5 hdd on pri master (80wire cable)
LG 50x udma2 cdrom on secondary master
ATI radeon 9000 pro
Windows XP Pro SP1a

I can confirm that the drive and the ide controller support up to UDMA5
I should note that the bios shows the hdd as being udma5 at boot time so i don't believe it is a hardware/cable issue.

Here's what I've tried so far:
Clean install of xp pro from scratch - dm shows udma4
Installed sp1a - dm shows udma4
Installed hyperion 4.49vp2 - dm shows udma4
replaced 80 wire cable - no change
confirmed bios is most recent available (AMI F9) for this board
confirmed all bios settings are correct
ran a utility to enable all hidden options in the bios

changed hdd to pio mode only as a test and sandra reports the system as udma5, however benchmark showed around 2.8mb p/s ... soon changed that back

has anyone been able to find a fix for this? I've seen the issue mentioned in a few other forums but nobody has a fix for it...
0
Comment
Question by:mawdryn
  • 13
  • 8
  • 6
  • +1
28 Comments
 
LVL 18

Expert Comment

by:chicagoan
ID: 9625048
Check your event logs. XP will throttle down drives when it detects errors. You have to solve the cabling or driver problem, delete the drive into in the registry and start over.
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9625203
Are you sure the IDE drivers (from the motherboard driver kit) are properly installed ? Download the latest motherboard drivers and install them.
Is the drive alone on the cable or it has a slave? If yes, temporary remove the slave.
0
 

Author Comment

by:mawdryn
ID: 9631623
Thanks for your input ppl :)

chicagoan: I checked the event logs and unfortunately, there is nothing in system and application other than a heap of information alerts which do not relate the hdd at all and security is completely blank. There seem to be a lot of people with this issue, but the only common link I can see is that they are running XP...

kronostm: according to VIA, the best drivers are shipped with XP, however I have installed the latest version of their Hyperion bus master ide drivers and also tried their miniport drivers. According to benchmarks, using the via/gigabyte supplied drivers actually shows a reduction in hdd transfer rate.. I only have the one drive on each channel.

VIA have a software tool called "IDETOOL" which allows you to set the mode of the drive. When I load it up, it states that it is currently in UDMA4 mode. If I change it to UDMA5 and update, it asks to reboot, and when it does, it's back in UDMA4... My primary concern is that the hdd is transferring data so slowly.
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9633895
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x
The last four digits will be 0000, 0001, 0002, 0003, and so on.
Under each key, delete all occurences of the following values:
MasterIdDataChecksum
SlaveIdDataChecksum.
Reboot the computer. Windows will now redetect DMA settings.
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9634160
g'morning Chicagoan (it's morning on your side of planet, aint it?) .... I think it's time for kronos to go to sleep  ;-)
Is that a fix for a known issue or what ? I'm dead curious ?
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9635371
XP will throttle down devices based on the number of errors experiences on the device.
Assuming you fix the problem, drivers, proper 80 wire cable, misbehaving slave devices, goofy SMART BIOS implementation etc., you can reset the process
0
 

Author Comment

by:mawdryn
ID: 9640189
Hi again.

Unfortunately, killing the keys in the registry didn't change a thing. I ran a full scandisk over the drive, and ran a little utility called "activesmart" to check the smart data on the drive... everything appears to be ok.

The drive itself is identified as follows:
QUANTUM LCT20 20.4GB EIDE 4500RPM ATA/100 2MB CACHE 12ms seek

here's the report from activesmart:

Created by Active SMART (http://www.ariolic.com)

S.M.A.R.T. status
Date: 29 October 2003 15:19:02
Drive model: QUANTUM FIREBALLlct20 20
Serial number: 552107130261
Capacity: 20.4 GB
Drive interface: IDE

-------------------------------------------------------------------------------------------------------------
         Attribute Name                               Threshold     Value       Worst     Raw value   Status
--------------------------------------------------------------------------------------------------------------
1   (01) Raw Read Error Rate                          20          100         253              0            OK
3   (03) Spin Up Time                                     20           81          79            2422          OK
4   (04) Start/Stop Count                                 8            98          98            1595          OK
5   (05) Reallocated Sector Count                     20          100        100              0            OK
7   (07) Seek Error Rate                                  23          100        100              0            OK
9   (09) Power-on Hours Count                        1            77          77           15382          OK
10  (0A) Spin Up Retry Count                           0            100        100              0            OK
11  (0B) Calibration Retry Count                       20          100        100              0            OK
12  (0C) Power Cycle Count                             8            98          98            1480          OK
13  (0D) Soft read error rate                            23          100        100              0           OK
195 (C3) Unknown attribute                              0           100        100          71619         OK
196 (C4) Reallocation Event Count                     20         100        253              0           OK
197 (C5) Current Pending Sector Count              20         100        100              0           OK
198 (C6) Off-line Scan Uncorrect. Sector Count   0           100        253              0          OK
199 (C7) Ultra ATA CRC Error Count                   0           200        199             2          OK
--------------------------------------------------------------------------------------------------------------

I have a utility called QDPS which is specific to quantum drives and gives the drive a thorough testing. The results all came back as a pass so I don't believe there is any fault with the drive, controller or cable.
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9641755
checked
 http://www.maxtor.com/en/support/downloads/fireball_lct20_udma33to100.htm
to make sure DMA100 wasn't turned off?
0
 

Author Comment

by:mawdryn
ID: 9648714
Thanks for the site, although unfortunately, it did not change anything. After running the utility, I re-removed the "MasterIdDataChecksum" entries in the registry and removed the ide controller from device manager. I might try another OS to see if this problem still occurs..

I blame the parents for this.. :P
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9654214
Try the whole salami at once:
Latest BIOS, VIA 4in1 and ATAPI drives (from mobo vendor or XP)
Drive alone on UDMA 80 wire cable.
Drive set to UDMA100 With Quantum/Maxtor Utility
Remove drive and controllers from device manager
Reboot
Enter bios and set access mode
Turn SMART support off in bios
Cross fingers
Start XP and redetect devices
0
 

Author Comment

by:mawdryn
ID: 9662159
Thanks for the input, but still no go..

I've read somewhere that some VIA chipsets will not do ata100 with winXP... does anyone know if this is possible?
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9662473
HAHA ... no way.  This is not true.  
That's your mobo's specifs http://www.motherboardhq.com/hardware/partinfo-id-6868.html
and it states clear that it can do ATA100. And if it is able, HAS to work in any OS. Only a damaged driver can grant such issue, and since you've tried a couple I it's out of discussion.
If I were you I'd install another OS (make a dual boot) in order to check if that's not a hardware issue anyways.
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9663173
nope - if you have the 4.48 4in1 drivers it should be no problem.
0
 

Author Comment

by:mawdryn
ID: 9669967
I've since come across some info which (unless I'm mistaken) shows gigabyte as dishing out false info.. stop me if I'm wrong at any point  

This is assuming that the Southbridge is what controls the IDE subsystem?

mobo specs: Gigabyte GA-6VTXE(-A) rev 1.1 - Bios ver F9

According to the manual, The summary of features has the follwing excerpt:

--------------------------------------------------------------------------------
Chipset: VT82C694T (VIA Apollo Pro 133T)
............. VT82C686B

On-Board IDE: 2 IDE bus master (UDMA 33/ATA 66 /ATA100) IDE ports for up to 4 ATAPI devices
--------------------------------------------------------------------------------

My new info is based on the following info from this link:
http://www.viaarena.com/?PageID=14

Apparently the Apollo Pro 133A Southbridge (VT82C686B) does not support ATA100
whereas the Apollo Pro 133T Southbridge (VT82C596B) does...

So, perhaps despite what the manual and product advertises, i cannot obtain ata100 ?
I'm chasing this up with gigabyte and via to determine whether this is a possibility.
0
Get up to 2TB FREE CLOUD per backup license!

An exclusive Black Friday offer just for Expert Exchange audience! Buy any of our top-rated backup solutions & get up to 2TB free cloud per system! Perform local & cloud backup in the same step, and restore instantly—anytime, anywhere. Grab this deal now before it disappears!

 

Author Comment

by:mawdryn
ID: 9669976
in addition, I had the same problem in win2k although device manager only showed that I was running in UDMA mode.. Sandra stated that it was only in udma4
0
 
LVL 18

Expert Comment

by:chicagoan
ID: 9670285
You DO have XP SP1 installed, I trust?
0
 

Author Comment

by:mawdryn
ID: 9670315
yes :) had SP2 on win2k as well.
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9670392
mawdryn ..... according to what VIA states , 133T chipset http://www.via.com.tw/en/ProSavage%20Chipsets/pl133t.jsp (that your motherboard uses)supports ATA100.
0
 

Author Comment

by:mawdryn
ID: 9670548
that's the problem... I have half of the 133t and half of the 133a... the part that controls the ide subsection is the 133a which apparently doesn't support ata100... It is the southbridge that controls the ide subsystem right?
0
 
LVL 18

Assisted Solution

by:chicagoan
chicagoan earned 250 total points
ID: 9670864
Via suplies 2 drivers, a filter driver and a replacement drive, the latter is at  http://www.viaarena.com/?PageID=340.
The VIA IDE Miniport driver does not install with the VIA Hyperion 4in1 drivers.
The ATA100 claim is all over their product literature, I'd be all over them for a replacement if what you suspect is true.
0
 

Author Comment

by:mawdryn
ID: 9676394
There's one site that states that the 686B does support ata100, whereas the 686A doesn't... I've looked at the chips on the board and confirmed that I have the 686B southbridge.... I'm still waiting for Gigabyte or VIA to get back to me, however I can tell you that the miniport drivers are not recommended for XP going on my own experience.. My hdd speed slowed from 8mb per second with the basic XP drivers down to 2.2mb per second with the miniport drivers.

Once I find out more, I will post further.
0
 

Author Comment

by:mawdryn
ID: 9686212
Here's an interesting link... kind of backs up my theory

http://www.microsoft.com/windows/catalog/default.aspx?subid=7&xslt=detail&pgn=5e0d44a1-0ae9-9b3e-6f71-888bf19fd0b1&tab=3

I would really like to know if there is someone out there with a GA-6VTXE mobo that is running XP see if they are experiencing similar issues....

Still no word from Gigabyte or VIA as yet :(
0
 

Author Comment

by:mawdryn
ID: 9726770
Seems that the chipset capability idea was a bum steer. Still didn't hear from VIA or Gigabyte >:(

I installed win2k again and twiddled around with it, but couldn't be sure what mode it's running in as it
only states "Ultra DMA Mode" in device manager.

I ran HDTach and was getting the same results as with XP (30+ms access times and 18.9Mb transfer) until I found a small utility on the Microsoft KB called DMAcheck which is meant for windows NT.

After running that, I ran HDTach again and obtain a much better result (12ms access time and 29.5Mb transfer) Sandra even says it's running in UDMA5 and my benchmark is comparable to it's reference drives.

Wonderful news for me, although I still can't get it going in WinXP. So now I Know it's a driver/XP issue, any ideas on how to go about resolving it?

Summary of things done:
------------------------------
Reformat and Install XP
Installed SP1
Installed Latest VIA Hyperion Drivers (4.49vp2).
Confirmed latest bios on motherboard (reflashed anyway to make sure it wasn't screwy).
Confirmed all BIOS options correct.
Turned off APIC (had to reinstall XP).
Removed All peripheral cards (except video).
Turned off all onboard peripherals (except IDE1).
Ran Quantum's UDMA tool to make sure the drive was in ata100 mode.
Placed My Quantum Drive in another system - ok at UDMA5.
Placed Maxtor ata100 40gb drive in my system - showed as udma4.
Ran MS's DMAcheck tool to make sure UDMA was turned on.

Notes:
Win2k worked after some messing around with utilities and drivers.
BIOS reports drive as UDMA5 at boot time.
0
 
LVL 14

Accepted Solution

by:
kronostm earned 250 total points
ID: 9738808
mawdryn .... I hate to say it and hope the chipset's manufacturer or the guys from Gigabyte to contradict me, but I think you've done everythig a man can do, in the end you should admit the obvious. UDMA 66 is the best your mobo can do. It's a "hybrid" motherboard .... a step into evolving to a new generation of boards.
0
 

Author Comment

by:mawdryn
ID: 9759816
Update :)

Seems that this chipset and Quantum don't mix too well.....

My previous post was slightly incorrect

I have a maxtor 40gb as mentioned previously which seems to perfectly with my board.. When I installed win2k, it was with the Maxtor drive and not the Quantum.

The Quantum comes up as udma5 in the SiS board but only udma4 in my Gigabyte board regarless of the OS.

So it seems to me that Via and Quantum have a little compatibility issue...

I'll split the points between kronostm and chicagoan as you both did what you could to help me.
Cheers for the future.

0
 

Author Comment

by:mawdryn
ID: 9817536
Further update....

I received a response from gigabyte with a beta bios update. This appears to have fixed the problem at long last.
If anyone else is having similar probs with the same board, I'd recommend contacting Gigabyte support.

Cheers for your help ppl.
0
 
LVL 14

Expert Comment

by:kronostm
ID: 9818031
You have done a great job mawdryn. YOU should be awarded points!   :-)
0
 

Expert Comment

by:harrem
ID: 11013622
where can we download the bios my problem is same and i can not find the bios that fixed your problem
0

Featured Post

Enabling OSINT in Activity Based Intelligence

Activity based intelligence (ABI) requires access to all available sources of data. Recorded Future allows analysts to observe structured data on the open, deep, and dark web.

Join & Write a Comment

Suggested Solutions

I previously wrote an article addressing the use of UBCD4WIN and SARDU. All are great, but I have always been an advocate of SARDU. Recently it was suggested that I go back and take a look at Easy2Boot in comparison.
The article will include the best Data Recovery Tools along with their Features, Capabilities, and their Download Links. Hope you’ll enjoy it and will choose the one as required by you.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This Micro Tutorial will teach you how to reformat your flash drive. Sometimes your flash drive may have issues carrying files so this will completely restore it to manufacturing settings. Make sure to backup all files before reformatting. This w…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now