Solved

IIS Lockdown Tool and NTFS Permissions of M:\domain\Public Folders

Posted on 2003-10-26
3
380 Views
Last Modified: 2008-02-07
Hello all!

I'm using Windows 2000 Server, Exchange 2000 Server, all latest Service Packs

Just 2 days ago i installed IIS Lockdown Tool. After that i saw that all clients had access to all public folders, so not respecting their user access policy. I tried to control this to Exchange System Manager, but i received error 80040102. I searched for help and found something at Microsoft web site.

Anyway. I uninstalled IIS Lockdown Tool. I correted the NTFS permissions for every public folder and now also Exchange System Manager is working with Public Folders.

The only problem now is that Everyone has access to List Folder Content of Public Folders in M drive. So every user can see all the list of Public Folders. Of course he/she can't access all of them, but he can see all the list.

I tried to change NTFS Permissions of M:\domainname\PublicFolders, but was impossible, because the owner for that folder was System account. Of course i used Administrator account to do that change.

Anyone has an idea how to change NTFS permissions of M:\domainname\PublicFolders  ?

Thanks to all!
0
Comment
Question by:renis
3 Comments
 
LVL 24

Accepted Solution

by:
David Wilhoit earned 500 total points
ID: 9626475
NOOOOOOOO!!! NEVER, EVER, change the permissions on the M: drive. Don't even look at it. Permissions for public folders are changed in the ESM or on the Outlook client. This can have consequences later or immediately, the M: drive is not to be toyed with. If you've already done it, stop, and check to see that all items are visible.

If you remove the everyone group, NOBODY will access the folders. Everyone group is essential to the ACL. Whatever perms are laid down on the public folders in the M: drive, are base perms, and should not be changed. If you removed anything in the way of permissions, and you have any trouble later, remember this and be prepared to resolve it. The below article is more of an FYI, than a resolution for you. Just making sure you know about this part:

http://support.microsoft.com/default.aspx?scid=kb;en-us;298924

I have personally seen several cases where MS has to reset the perms on the public folders from the command line because admin removed the everyone group from the ACL list.

D
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Exchange 2010 fails to send outgoing email 7 49
exchange 19 40
Outlook importing calendar entries 6 55
Urgent Exchange 2003 disk space problem 4 20
Following basic email etiquette rules will help you write a professional email and achieve a good, lasting impression with your contacts.
Read this checklist to learn more about the 15 things you should never include in an email signature.
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…

929 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now