Exchange 2003 Public Folder Replication

Hi All,

I am trying to replicate Public Folders to a newly installed second Exchange 2003 server and I am having problems finding a single concise answer from Microsoft's (limited) documentation.

Regards
Adam Yates
artyatesAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David WilhoitSenior Consultant, ExchangeCommented:
ok. what's the issue?

D
0
artyatesAuthor Commented:
I thought replication was easy - right click on the folder click Replicate and select the server.  I have noticed a load of MSExchange MTA error messages with event 9297 in the application log of the new server and no replication is taking place.  MS site states that this problem is due to Exchange 5.5 - do not have 5.5 servers.
0
artyatesAuthor Commented:
Should also add that the new server is Windows 2003 Member server - no ADS.
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

David WilhoitSenior Consultant, ExchangeCommented:
I don't understand. you have to have AD, or else 2003 will not install. I assume you mean this is only a member server, not a domain controller. Secondly, what kind of server are you trying to replicate with? another exchange server in the same org?
D
0
artyatesAuthor Commented:
AD is installed it is just that this server is only a domain server.  The other server is Exchange 2003 in the same organisation.
0
David WilhoitSenior Consultant, ExchangeCommented:
ok. Same org, same RG, same AG? Just need details. Second, have you checked that you can access the public folders on both server thru the System Manager cleanly?

d
0
artyatesAuthor Commented:
Same everything, ORG, RG, AG etc. Not sure what you mean by access the public folders.
0
artyatesAuthor Commented:
Think I understand what you mean - everytime I try and access the Public Folders from either the new server (SERVER5) or the existing (SERVER4) I get a userid and password prompt.  The administrator id etc does not work.
0
David WilhoitSenior Consultant, ExchangeCommented:
ok, there it is. Don't know what's happened here, but somethign is WAY off. What policies or permissions changes have been made? Anybody played with NTFS? Rename the admin account? Are you sure your server is logging into the domain account, and not the local machine account?

d
0
artyatesAuthor Commented:
There have been no policy changes made, no changes to NTFS.  The domain admin account has not been changed or renamed and the machine is logging in as the domain administrator account.

A
0
David WilhoitSenior Consultant, ExchangeCommented:
well, your perms are way off, no doubt. you didn't remove the everyone group from the top-level PFs, did you? No implicit denies? Use ADSIedit to check the permissions on the public folder. Have you made sure that the public folder store is mounted? Hate to ask the silly stuff.....

D
0
artyatesAuthor Commented:
The public store is mounted and everyone can access all the public folders they require access to.  How would I check the top level access to PF?
0
artyatesAuthor Commented:
I have also noted that some of the public folders do not appear on the Exchange virtual drive.
0
David WilhoitSenior Consultant, ExchangeCommented:
Virtual Drive? there's no M: drive that I am aware of in 2003, where are you looking? In IIS?

D
0
artyatesAuthor Commented:
No on my first server there is a virtual drive accessible through My Computer that Exchange sever created. Details:

Dirve:  M
Name:  Exchange
Directories:
domainname
domainname\MBX - containing sub dir for each mail box
domainname\MBX - containing sub dir for each mail box\folder name
domainname\MBX - containing sub dir for each mail box\folder name\messages
domainname\public folders
domainname\public folders\foldername (some not all)
domainname\public folders\foldername\messages

This is definately created by Exchange.

A
0
David WilhoitSenior Consultant, ExchangeCommented:
http://support.microsoft.com/default.aspx?scid=kb;en-us;821836

Am I missing something here? The Exchange server you're on when you see this, is it Exchange 2009, or did you enable the M: drive?

Sorry about the delay, I lost track of your post, my bad :(

D
0
David WilhoitSenior Consultant, ExchangeCommented:
let me correct, EXchange 2000, not 2009 :)....


D
0
David WilhoitSenior Consultant, ExchangeCommented:
Exchange System Manager
You can use the version of Exchange System Manager that is included in Exchange Server 2003 to manage all servers in the organization.
"The improved view for queues appears when you manage Exchange 2000 servers, and if you run the forestprep command for Exchange Server 2003, the Move Mailboxes tool is available.
You cannot configure new Exchange Server 2003 features on a Exchange 2000 server. The option for that feature in Exchange System Manager is unavailable (appears dimmed) for the Exchange 2000 server.
You cannot use Exchange System Manager in Exchange Server 2003 to configure Exchange 2000 components that are not available of Exchange Server 2003. For example, you cannot configure the following Exchange 2000 components:
Key Management Server
Exchange Instant Messaging
Chat
Microsoft Exchange Connection (MS Mail), Microsoft Schedule+, and Microsoft Exchange Connector for Lotus cc:Mail
Directory synchronization
Do not use the version of Exchange System Manager that is included in Exchange 2000 to manage servers running Exchange Server 2003. When you try to do so, the options on the tabs of Exchange System Manager appear as read-only."

Just an FYI...
D
0
artyatesAuthor Commented:
Morning, the version of both email servcers is Exchange 2003.  The M drive was not enabled by me - this happened as part of the installation of the server software.  The management tools in use are also those from the exchange 2003 cd.

Regards
A
0
David WilhoitSenior Consultant, ExchangeCommented:
what server software? exchange 2003 won't do that. I hope nobody has been playing with perms, or modifying and deleting messages thru the M: drive, that could be wreaking havoc on your PFs.

Now, try to replicate the public folders from A to B, but turn up the diagnostics logging on public folder replication first. Server properties, Diagnostics Logging tab, under MSexchangeIS, Public Folders. then post some of the obvious errors here, I'll take a look.....

D
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
artyatesAuthor Commented:
Ok Server A is Windows 2000 Server Domain controller running Exchange 2003 server B is Windows 2003 Member server running Exchange 2003.

I will run the suggestion and post the results this evening.

A
0
ARIAITGCommented:
Try to use Exchange system manager on Server 2003,
Make a replica for a public folder,
Right click on Public Folders then click on Send Hierarchy,
Then chose from exchange 2003 to exchange 2000, and enter days of change you want to be sent,

Wait for couple of minutes and see if it works,

Good Luck,
0
bgagnonCommented:
I ran in to the same problem.  I opened a case with MS and here is what they told me:

Here is a portion of the article I described. It has not yet been published so I can't send you the complete article.  I don't believe that it's necessary to reboot the server after making this change.

CAUSE
=====
This issue occurs because all public folder replication that uses Simple Mail Transfer Protocol (SMTP) must originate from an authenticated source or from a server that has  been granted Send As permissions.

WORKAROUND
==========
To work around this issue, edit the registry on your Exchange 2003 computer,  and add a new  key to the MSExchangeTransport  key.

Note After you add this registry key, your Exchange 2003 server can process system messages and public folder messages from unauthenticated sources.

To edit the registry and add a new  key to the MSExchangeTransport  key, follow these steps: 1. Click "Start", click "Run", type "regedit" (without the quotation marks), and then click "OK".

2. Expand the following registry key:
HKey_Local_Machine\System\CurrentControlSet\Services\MSExchangeTransport

3. Right-click MSExchangeTransport, point to "New", and then click "Key".

4. Type "Parameters" (without the quotation marks), and then press ENTER to name the new key.

5. Right-click Parameters, point to "New", and then click "DWORD value".

6. Type "SkipPublicMDBRestriction" (without the quotation marks), and then press ENTER to name the value.

7. Double-click SkipPublicMDBRestriction.

8. In the "Value data" box, type "1" (without the quotation marks), and then click "OK".

9. Close Registry Editor.

Hope this help

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.