Solved

cannot see my app using IP address but can see it using localhost

Posted on 2003-10-27
16
405 Views
Last Modified: 2013-12-24
http://192.254.27.2:8500/mrweb/mr.cfm

What is wrong with the above URL? why cant i see the site? i can see it doing this

http://localhost:8500/mrweb/mr.cfm
0
Comment
Question by:finnstone
  • 5
  • 5
  • 2
  • +3
16 Comments
 
LVL 4

Expert Comment

by:procept
Comment Utility
Hi,

what error msg. are you getting?

Chris
0
 

Author Comment

by:finnstone
Comment Utility
The page cannot be displayed
The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.
0
 
LVL 1

Expert Comment

by:kjuliff
Comment Utility
It is a 192 address so it looks like it is on a LAN. In that case it is  your browser that is set the wrong way. It is looking OUTSIDE your Local Area Network fot the location of 192.254.27.2:8500 and cannot find it.

This sounds like you have an intranet. Go into your browser - if IE go to tools -  internet options - connections - lan settings and then bypass proxy server for local addresses. It depends upon the IE version you have but essentially you have to tell it to look on the LAN not the internet.
0
 
LVL 1

Expert Comment

by:rstorey2079
Comment Utility
If you are using the Developer Edition of ColdFusion, you are restricted to only "seeing" your CF server from one IP address.

You can find out what IP address that is by going to your CF Administrator and going to Debugging IP Addresses.  There you can manage the list of IP addresses that are allowed to connect to your CF server.
0
 

Author Comment

by:finnstone
Comment Utility
i have professional..i added my ip and that did not solve the problem. i also am on a LAN and did change to byprass the proxy...that did not work either!

i know we have not solved me seeing it, but i also want to solve how can i make it so people outside my intranet can see it?
0
 
LVL 1

Expert Comment

by:rstorey2079
Comment Utility
You would have to have your firewall administrator forward port 8500 to your private IP address.  
0
 

Author Comment

by:finnstone
Comment Utility
what?
0
 
LVL 1

Expert Comment

by:kjuliff
Comment Utility
To have people outside seeing it, you will need another network card in your computer unless to get the network administrator to set up a mapping.

 Outside can only see the machine with the proxy server on it.  So the person who looks after that machine would need to make some config changes.

To see it inside - I am sure  it is your browser problem. But depending upon WHICH browser inc version, I can't help you to configure it to  work completely. Howvever it should see the site if you configure to ignore the proxy for internal addresses. Try turning the proxy off to check this.

0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 

Author Comment

by:finnstone
Comment Utility
what if i use my home computer ..i am using cable modem from starpower. can people see my app from outside my computer  ... also it is not a static ip. does that mean it changes every day, or does that mean i cannot let people see period?
0
 
LVL 1

Assisted Solution

by:kjuliff
kjuliff earned 240 total points
Comment Utility
You can get a service that will allow you to do this from home. See
http://noip.com/

You register there and even if you do not have a static IP - yes it'll change every day, this service checks your PC and assigns a permanent IP address. You can even get your own domain name. Check it out. I have used it and was quite happy with it. It  is free if you don't opt for the extras.

0
 
LVL 5

Accepted Solution

by:
dc197 earned 160 total points
Comment Utility
What is your web server software?  Apache, IIS?
It may be a Virtual Host problem.


And remember that LocalHost resolves to a different IP address to the one you gave (it resolves to 127.0.0.1) and so you could be talking about different webservers.
Local host refers ONLY to your current (development?) machine, the 192.254 host might not be available to you due to firewall or other issues.

kjuliff ::
>It is a 192 address so it looks like it is on a LAN
Not all 192 address are on LANs!
Only 192.168 and 192.169 are reserved for this.
192.254.27.2 is registered to GTSI, according to ARIN (http://www.samspade.org/t/ipwhois?a=192.254.27.2)
0
 

Author Comment

by:finnstone
Comment Utility
i dont have web server software. i am trying to just use cfmx! is that a problem?
0
 
LVL 5

Assisted Solution

by:dc197
dc197 earned 160 total points
Comment Utility
You DO have a webserver otherwise coldfusion is no good on its own.

The reason you are seeing different results when you use LOCALHOST vs the IP address is because they probably point to different addresses.

Do this:

Start > Run > type COMMAND > press ok
In  the black window type   IPCONFIG /ALL    and press enter
Paste the result here.
0
 
LVL 1

Expert Comment

by:kjuliff
Comment Utility
He's using the Cold Fusion webserver. Hence the :8500
He thinks the 192.254.27.2 number is the IP address of his computer at work.
He is using a proxy server

So it seems as if it is because he is on a LAN that he can't see the site using the IP address.

He wants to make his site public and is prepared to do it at home. So all he has to do is to join noip.com and he's set.

And yes I know that not all 192 addresses are lans. But I guessed right that he was going through a lan.
0
 
LVL 1

Assisted Solution

by:Peter1985
Peter1985 earned 100 total points
Comment Utility
this may be a silly thing but have you assigned the ip address to your web site in Internet Services Manager.

In administrative tools click on Internet Services Manager and click on your server in the window pane.  you should see an IIS in the list, if it says unassigned then right click and choose properties, under one of the tabs you can assign your IIS an ip address.  Once this is enabled other pcs will be able to see you sites by typing the ip address.

hope this helps
0
 
LVL 1

Expert Comment

by:kjuliff
Comment Utility
From the URL he gives it looks like he's not using IIS.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Join & Write a Comment

Most ColdFusion developers get confused between the CFSet, Duplicate, and Structcopy methods of copying a Structure, especially which one to use when. This Article will explain the differences in the approaches with examples; therefore, after readin…
When it comes to showing a 404 error page to your visitors, you do not want that generic page to show, and you especially do not want your hosting provider’s ad error page to show either. In this article, I will show you how to enable the custom 40…
When you create an app prototype with Adobe XD, you can insert system screens -- sharing or Control Center, for example -- with just a few clicks. This video shows you how. You can take the full course on Experts Exchange at http://bit.ly/XDcourse.
This video explains how to create simple products associated to Magento configurable product and offers fast way of their generation with Store Manager for Magento tool.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now