Out of Office Modification.

Hey, when you setup the out of office message it automatically puts...

I will be out of the office from X date and will not be returning until X date, then it puts your custom message that you type in.

How can i have it not say the "I will be out of the office..." part and just put my custom message.
Basically a auto responding agent.

Regards,
Jason Incarnato
unknown45Asked:
Who is Participating?
 
qwaleteeCommented:
That value is automatically calculated when yuo fill out the Out Of Office profile.  The only two ways to drop it are to either prevent that value from going on the profile, or to prevent the agent from using it when responding.

Try this, after you have set up your Out Of Office profile (you need to do this each time you edit the profile):

Execute the following LotusScript...
Dim db as new notesDatabase("" , "" )
db.openMail
Dim doc as notesDocument
Set doc = db.getProfileDocument("OutOfOfficeProfile")
doc.removeItem("DaysOut")
doc.save true,true

That will remove teh calculated value, so that the message sending script has no text to prepend to your message.
0
 
HemanthaKumarCommented:
Or simply comment this line in OutOfOffice Agent.

Open the agent and select Declarations section, search for the lines and comment it out

Me.m_vFieldData = Me.m_profileOffice.GetItemValue ( "DaysOut")(0)
Me.m_strMsg = Me.m_vFieldData & Chr(10) & Chr(10)

PS: Inorder to avoid design refresh , just flag the agent's "Prohibit design refresh or replace" setting.

~Hemanth
0
 
unknown45Author Commented:
Thanks qwaletee, I didn't want to make the changes permanent so I chose yours as the main answer, but hermanthas also works and he gave me the hit about design refresh, so I gave him a few points.

Regards,
Jason Incarnato
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.