You do not have permission to change your password

Whenever my users was prompted to change an expiring password they got the error message 'You do not have permission to change your password'. My Domain is running in NT4 SP6a Domain and my client is in mixmode of NT4 Workstation, Win2kPro and Win98. I have been plague with this problems for the last 3 weeks. I have checked all informations in Microsoft website but there seems to be no better solutions or answer. I have also an up-to-date Anti-virus software installed across all servers and clients. Apreciate if you can guide me how to troubleshoot this problems. Thanks.
Din61Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ahmedbahgatCommented:
view each nt user propeties using user manager for domain, then make sure to uncheck the box user can not change password

cheers

0
Din61Author Commented:
Thanks for replying. I have checked that in the user properties for all my users. The check box for user cannot change password in the user manager for Domain is empty and was not tampered with. Might probably causes by Net time server not synchronizing or any new threat of attacks from hackers to my server registry or could be Licensing issues or something else I assume.
 
0
lacamsCommented:
you can check that :

logon server => echo %LOGONSERVER% on the pc whic has the pb.

if it's the same server as PDC.
Else there is a synchronize pb between the PDC and the BDC

Have you try to create a new account and try to connect on the pc which has the Pb ?

christophe
0
Cloud Class® Course: Microsoft Office 2010

This course will introduce you to the interfaces and features of Microsoft Office 2010 Word, Excel, PowerPoint, Outlook, and Access. You will learn about the features that are shared between all products in the Office suite, as well as the new features that are product specific.

ahmedbahgatCommented:
you can clarify if it is a license issue by checking the event viewer, or even by running license manager, you will see a yellow mark next to the server if there is a license issue

also you may check the Account properties under user manager for domains, all the settings there are password related, possibly it was tampered with

cheers
0
ahmedbahgatCommented:
you may check the following link as it is related to my last comment

http://support.microsoft.com/default.aspx?scid=kb;en-us;160900&Product=nts40

cheers
0
ahmedbahgatCommented:
another useful article if you have not seen it already

http://support.microsoft.com/default.aspx?scid=kb;en-us;198941&Product=nts40

cheers
0
techyboyCommented:
do you have a windows 2000 domain controller

also check fully the DNS server and WINS server are all okay

microsoft have put out fixes but they don't seem to cover this as they are looking at authentication timeouts etc

the problem relates to the DNS and Wins not talking correctly and the machines not being registered correclty

especially if you have a windows 2000 domain controller or windows 2000 DNS and the NT4 accounts can change passwords with the error you mention


we fixed it by setting a 2000 DNS server as primary and win nt 4 DNS and wins as secondaries and ensuring that everything is registered fully

check out microsoft whitepapers on this as its complex but very important
0
FreekHendriksCommented:
Is there an policy active?

0
Din61Author Commented:
Sorry guys, I did not respond to your comments promptly as I have been busy. I am not sure this problem have been resolved or not. What happen is that the first time I look into this problem I have been playing with various settings in the Accounts Policy of the User Manager. One of the options I did the test is the 'Users must log on in order to change password'. I turn off the check mark for this options. I tried to change password the problem still remain. I put it back the checked mark in the box for this options as originally it has the checked mark in this box. But strange things happen. When my boss came back from her vacation she had the same options turn off. And when we did the test again, I can change my password without any problem. Its just not my luck to have this problem resolved although the solutions was the same. Anyway it is just to soon to say if this problems really solve until the next user had their expiring password change. I will see how it goes. Thanks for all of your comments. Its really ease my mind when somebody did really respond in this expert-exchange forum. And by the way my Domain are still in NT4 with client in mix-mode.

Regards,
Din61
0
Computer101Commented:
PAQed, with points refunded (125)

Computer101
E-E Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.