• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 655
  • Last Modified:

Problems with

I am currently attempting to look after a server for a transport company, when i went in it was  mess so decided the best way to sort it out was to backup the data and reinstall, everything went perfectly, the server started without an error (an achievement in itself...) however ive ran windows update remotely did all the security upgrades e.t.c, today they have come in and the server was messing about so they rebooted only to be confronted with total melt down....

In the event viewer, system log im getting
"The DNS Server service hung on starting."

In the dns server logs im getting
"The DNS server timed out attempting an Active Directory service operation on ---.  Check Active Directory to see that it is functioning properly. The event data contains the error. "

When i try and open active directory im getting...

"Naming information cannot be located because:
The specified domain either does not exist or could not be contacted.
Contact your system administrator to verify that your domain is properly configured and that it is currently online"

The domain should be fine, was setup and working perfectly yesterday....

I then get the Active Directory Users and Computers screen but a red cross on the left had column.

Help this really is urgent...

0
dmcinternet
Asked:
dmcinternet
1 Solution
 
VinnnnieCommented:
When windows starts, Press F8 when the Starting Windows 200X appears. Go to Last Known Good Configuration. This is a real time saver! If that still doesn't work, I would go into safe modem and uninstall DNS and reboot and see if you can get into windows. You need to do this so you can get access to your CDROM Drive. It should allow you to boot into regular windows mode with a lot of different errors. Hopefully you created a local login. When in windows, reinstall DNS and see how it goes.
0
 
dmcinternetAuthor Commented:
how far back does last known good configuration go? thing is...the server will run even one of their programs will sort of talk to the server, they have an SQL database that is being updated every couple of minutes, if I go to last known good config then will they loose these updates?

im not sure whether DNS is the problem, DNS wont start because Active Directory hasnt started...


Carl.
0
 
VinnnnieCommented:
Hi,

Last known good configuration stores the data from the last time the PC was booted up successfully. If you have servers apps, that really should not matter. That should not be affected.
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
dmcinternetAuthor Commented:
The server is booting up fine.... and you can login e.t.c. it just states that services failed during startup and DNS refuses to start because Active Directory isnt running properly.

Carl.
0
 
VinnnnieCommented:
Hi, How many users are there?
0
 
graemeboroCommented:
To try fixing the active directory problem I would go to start-run and enter dcpromo.  Dcpromo will unistall active directory from this machine as it will no longer be a domain controller.  You can then run Dcpromo again to in effect re-install AD.  The only question I would ask before taking this action is do you have another domain controller to which Active directory has replicated.  If so this should sort the problem.  

If not can you restore the system state data from the time before the machine was rebooted and damaged?
0
 
dmcinternetAuthor Commented:
Hi there,

This is most perculiar, to try and resolve the problem I went into the DNS server and added a record that was not intergrated into Active Directory (the reason dns was previously moaning was that it couldnt get the details from AD and AD was moaning it couldnt resolve the hostname because dns wasnt running catch 22) once I had added the DNS record I restarted the computer and it has again restarted as before without a single error message in the event log, dns running fine as is AD...

Any chance of a job on here ;)

Carl.
0
 
Rob StoneCommented:
Also, LKGK wouldn't have worked here because it stores a Previous Control Set before logging on, so once logged on it copies over the previous LKGK.

Email a EE mod and ask for the points to be refunded.
0
 
DejunaiCommented:
You know... This is starting to spook me...
Up until last week I had never heard of this...
It happened locally on my servers, then on my client's servers...
It's either a bad patch from M$, or an ( uptilnow ) unknown virus...

The EASY fix is to just REPAIR the install, not a full wipe and load,
But boot to the CD, when it offers a REPAIR CONSOLE...
Skip that and head for the install, it will detect the previous installation,
and Again offer to REPAIR, let it... Only thing I lost was the WinUpdates...

The other fix, is to DCPROMO -demote the Server ( losing Active Directory ),
and the -promote it back... Depending on the number of accounts this option is viable...

Seriously try the Boot CD REPAIR...
It worked perfectly for me...

-Dej
0
 
dmcinternetAuthor Commented:
its weird, i did a service pack 4 update (from a fresh install) and the multiple updates you have to do when you have a new install... only then did this occur, seems fine now, returned to its old self and is working finally.... i just re did the dns records and config...

Carl.
0
 
dmcinternetAuthor Commented:
It seems this didnt help in the end, it worked on that particular reboot but once rebooted it lost the config. Ended up doing a install over the top.

Seems service pack 4 just isnt good for some machines, this is a perfect example of that...


Carl.
0
 
PashaModCommented:
PAQed, with points refunded (500)

PashaMod
Community Support Moderator
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now