My CRViewer on my form is a blank box

I am using CR 8.5 and VB 6.0.  I have been writing an application for the last 7 months.  About 3 months ago I put otgether the reporting section and all was happy.  It has worked up until today.  I sent the latest update to my boss and he said all the reports returned a gray screen.  I tested it on mine and I got the same result.  

I checked out the form where my CRviewer object resides and it was gone.  Well, not gone, the CRviewer object is still there, it is just a blank box, kinda like a picture box.  if I draw something over it, then delete that something the image remains, like when a window is busy and doesn't refresh.  

Where did my CRViewer go?  I haven't touched any references or components related to Crystal reports in a long time.  I readded the crviewer.dll component to the project, but still get the same blank box.  I even made a new project, but the CRViewer is a blank box there too.

Has anyone seen this before?  I checked out the CR web site, but couldn't find anythig in the knowledge base.  Any suggestions would be appreciated.

/<evin
kkonkleAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ladylinetCommented:
Looks like some dlls are missing, or permissions.

Lady Linet
0
mlmccCommented:
Have you made changes to the database?  If so you may want to verify the reports still work from Crystal

Open each report
Click DATABASE --> VERIFY DATABASE
If it says the database has changed Click YES
You may need to manually map fields
Preview the report then save it.

Have passwords changed?

Look at
http://support.crystaldecisions.com/library/kbase/articles/c2008905.asp

mlmcc
0
kkonkleAuthor Commented:
It isn't the reports themselves, one of my reports doesn't even tie to a database, it is just a bunch of parameter fields that I fill in at run time, and that one just displays a blank, gray screen.  The problem is with the crviewer object.  Here is a screen shot of my Visual Basic development environment.

http://www.sammonssecurities.com/kevin/CRViewer.jpg

See those lines around the edge of the form, that is the outline of my crviewer object.  If I remember correctly it used to look like something on the form during development, but it doesn't work any more.  Do I need to reinstall Crystal Reports?  Are my dll's corrupted or something?

/<evin
0
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

ladylinetCommented:
Can you still call Crystal Report alone properly? Try creating simple report that just reads author table from publisher database. That can help in determining problem..
 
Lady Linet
0
mlmccCommented:
You could uninstall CR then reinstall it.

mlmcc
0
kkonkleAuthor Commented:
Yeah, I was planning on trying this at some point, I just hoped there would be something else I could do before it came to that.  I will try it this morning and let you now if it worked out or not.

/<evin
0
kkonkleAuthor Commented:
I've uninstalled and reinstalled CR 8.5 twice now.  I removed everything from my VB project that referred to CR, uninstalled CR, renamed any folders it used that were left over, rebooted the machine, and reinstalled the program.  

Sadly, I still get the same non-functional CRViewer control on my VB form.  I really thought reinstalling would fix the issue, but now that it hasn't I am a little worried.  Does anyone have any other suggestions?  Please, ask any questions you need to if you are still unclear about what is happening here.

/<evin
0
kkonkleAuthor Commented:
On other piece of information that might be useful:

I am able to print the report, and export the report and the correct report is displayed, it is only when I try to preview the report with the CRViewer that I get a blank screen.

/<evin
0
mlmccCommented:
This may sound silly but which edition of Crystal do you have?

mlmcc
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kkonkleAuthor Commented:
I was using CR 8.5 professional.  I tried talking with CR support but apparently that version isn't licensed to be ditributed to people.  We went ahead and bought version 9 Developer and once I upgraded to that everything was happy again.  Thank you for your help and suggestions.

/<evin
0
mlmccCommented:
That is wh I finally asked that question.  Generally I ask that up front but for some reason I forgot.

Glad you got it solved.

mlmcc
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.