Network and Windows Login

I have a Windows 98 computer which  logs in to Windows when it is booted or restarted.   It comes up to my desktop without requesting a login.  After it's up,  I can logoff, and then it comes up to my network login screen.  It happens this way every time.  I have Microsoft Client for Network installed, and  properties are set up to log in to a Windows NT domain.  I want to set it up so that it comes up to a network login each time.   Can someone give me some direction?
Thanks.
William
bwarfelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

owensleftfootCommented:
Right click on networkneigbourhood, choose properties and make sure client for  microsoft networks is selected as the primary login.
0
LuxanaCommented:
Hallo bwarfel

Right click NEtwork Neigborhood, properites, TAB configuration and in box Primary Network logon instead Windows logon choose Client for Microsoft Networks..
0
stevenlewisCommented:
want net work logon make sure you are using client for microsoft networks as your primary logon, and also find *.pwl files and delete them (they may be corrupt) reboot and you should be prompted for a logon
Open the Passwords control panel, then switch to the User Profiles tab. Enable the option for users to customize their preferences. Additional profile settings are not recommended.
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

stevenlewisCommented:
also check to see if you have tweakui installed (check in the control panel)
if so check the network tab
0
Huseyin1Commented:
Hi

Whats wrong with you people, the Questioner said he/she has "Microsoft Client for Network installed". .........and what happens........you all tell him/her to enable it, ITIS.

bwarfel I think you need to go over your network setup:

Make sure the domain name is correct

Make sure all IP settings are correct and DNS/WINS etc.

make sure the workgroup name is correct.

I would remove everything from the network list (card protocols and all) and reinstall from scratch, but thats up to you.

good luck

H
0
bwarfelAuthor Commented:
I have removed the .pwl files, all network components,  and I have reinstalled the NIC driver.   I  have verified that all network settings (domain, DNS, etc) are  correct.  I have also checked the WINLOGON value in the registry and verified there's no auto logons.   As near as I can tell, everything is exactly as it should be.   However, when I reboot or restart, I come to a Windows desktop without getting a logon prompt.  Then I can logoff, and then I get the network login.    I did not originally set up this computer, so someone else may have done something I don't know about.

I'll also add then after I restart (no network login prompt) if I try to map a drive I get a message that I'm not logged in.  Also, I do have an Internet connection, so I've got connectivity.

It seems to me there must be something set to enable an automatic login to Windows.  Do you have an idea as to how this might be, or any other ideas I might try?
Thanks.
0
LuxanaCommented:
No Windows or Network logon dialog box
When you start Windows 98 you may not receive a Windows or Network logon dialog box. You may also receive one of the following error messages:

No network provider accepted the given network path
The operation being requested was not performed because the user has not logged on to the network. The specified service does not exist
In addition, the Change Passwords tab may be missing from the Passwords Properties dialog box.

This behavior can occur if the AutoLogon entry appears in the following registry key:

HKEY_LOCAL_MACHINE \ Software \ Microsoft \ Windows \ CurrentVersion \ Network \ Real Mode Net


AutoLogon=<x>
where <x> is a number.

To remove the AutoLogon entry from the registry:

Select autolog.inf found in the \tools\mtsutil folder on your Windows 98 CD
Right-click autolog.inf, and choose Install from the menu

http://www.windows-help.net/windows98/troub-332.shtml
0
LuxanaCommented:
0
LuxanaCommented:
In other words only what you have to do is remove AutoLogon=00 value from registry in :

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Network\Real Mode Net

good luck
0
LuxanaCommented:
or change the value from 0 to 1 is up tu you......

try
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LuxanaCommented:
and I forgot :

If you do not know how to change registry key just press start > run and type regedit > ok and you are in.
0
bwarfelAuthor Commented:
Thanks Luxana, I looked at this entry yesterday, but for some reason thought the value of 0 probably indicated no auto login.  Anyway, changing to 1 solved the problem.
William
0
LuxanaCommented:
No worries...

have you read this stuff above....?

Yes it sounds strange but with value 0 autologon is ON. You can remove it if you want it will still work......


LUXANA
0
stevegw62Commented:
I had the exact same problem on a network with 12 98 machines. I will be trying Luxanas tip.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.