Go Premium for a chance to win a PS4. Enter to Win


ORA: 12560 TNS protocol adapter error Oracle 9i database and developer suite

Posted on 2003-10-29
Medium Priority
Last Modified: 2008-02-20
System Description: IBM Aptiva, 128 MB RAM , P2 processor

First I installed the Oracle Personal database 9i release 2 ( complete version(1.80 GB0) in the system. I followed the instructions provided at the following link
After the installation was complete, the above instructions asked me to create a account called "dbuser/oracle " using the database configuration assistant. This also went thru fine. However when i try to connect to the databse using SQL plus i can only login using the "dbuser/oracle " login account. I cant login using the "system/manager" account. However with the "dbuser/oracle" a/c i am able to create , and retrieve tables from  the database.

After this I installed the oracle Developer Suite 9i release 2 on the system again following the instructions provided at the above link. The installation was successful. For the first time I tried to run a form based developer application. The system asked me if i wanted to log on to the database. I logged on the the database using the "dbuser/oracle". After this the Java Initiator process was also successful. But after this , when the browser was beginning to load the applet, a database connect dialog Box appears with the error message " ORA: 12560 TNS protocol adapter error". Ths connect dialog box shoe text string "DBUSER" in the name field. If i try to enter the "oracle"  password , it again gives the same error message.
I know the minimum memory requirements r 256 MB and i am soon upgrading to 256 MB of RAM. Also let me know if I need to re install oracle database and DS after memory upgrade.
I am teaching assistant and prompt help ll be sincerely apreciated.
Question by:sachin_kn
  • 3
  • 3
LVL 48

Accepted Solution

schwertner earned 800 total points
ID: 9641086
About the users. DBCA normally asks for the passwords of SYS and SYSTEM users. If you can connect as sysdba via dbuser unlock that users and give them passwords.

Oracle Personal editions are not provided with a Listener. the connection is made using bequiet protocol (a protocol for local DB connections). So when you use Net CA you should use this protocol. When you install new product you should use the Net CA of THAT product (not the server) to create an entry in the local tnsnames.ora file.

Author Comment

ID: 9644374
Hi this is sachin_kn (I posted the question). Can some one please give me the specific steps of fix for this problem
LVL 48

Expert Comment

ID: 9648208
Get oriented in yor users so:
Can you log on as sysdba?
Connect as sysdba. Show if sys and system exist. Are they open or locked?

SQL> descr dba_users
 Name                                      Null?    Type
 ----------------------------------------- -------- ------
 USERNAME                                  NOT NULL VARCHA
 USER_ID                                   NOT NULL NUMBER
 PASSWORD                                           VARCHA
 ACCOUNT_STATUS                            NOT NULL VARCHA
 LOCK_DATE                                          DATE
 EXPIRY_DATE                                        DATE
 CREATED                                   NOT NULL DATE
 PROFILE                                   NOT NULL VARCHA
 EXTERNAL_NAME                                      VARCHA

SQL> select username, account_status from dba_users;

USERNAME                       ACCOUNT_STATUS
------------------------------ ---------------------------
SYS                            OPEN
SYSTEM                         OPEN
OLAPSYS                        OPEN
SCOTT                          OPEN
DBSNMP                         OPEN
ICWUSER                        OPEN
LSCONTACTS                     OPEN
LSIDMAP                        OPEN
LSSYSTEM                       OPEN
LSU17                          OPEN
S17                            OPEN

USERNAME                       ACCOUNT_STATUS
------------------------------ ---------------------------
M17                            OPEN
I17                            OPEN
D17                            OPEN
LSUSER                         OPEN
C17                            OPEN
T17                            OPEN
LSMEDICAL                      OPEN
LSDOCUMENTS                    OPEN
LSCONTAINER                    OPEN
OUTLN                          EXPIRED & LOCKED
WMSYS                          EXPIRED & LOCKED

Look which user has DBA role.
SQL> select * from v$pwfile_users;

USERNAME                       SYSDB SYSOP
------------------------------ ----- -----
SYS                            TRUE  TRUE
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.


Author Comment

ID: 9648358
Hi everybody,
This is sachin_kn ( i am the one who posted the question). The database personal edition is now working fine after i reinstalled it (after clean windows install). But the developer part is still not working. I mean whenever I run a fron form application i still get the same error
ora:12560 TNS protocol adapter error

Please provide with specific steps to fix this problem

Expert Comment

ID: 9648584
I do not have the solution for that but I have the same problem in another context, with Oracle 8i, and maybe my problem has the same reason as your.
I get exactly the same message since a few days on a test server where I installed Oracle 8i, with the svrmgrl command-line utility . As soon as I launch it, I get the ORA-12560 error (I could not find this error reported in Oracle documentation !) and the a prompt. This was not the case a couple of days ago but I do not remember what I did change, explicitely or implicitely to have now this problem. More, when then from svrmgrl I issue the connection command 'connect internal as sysdba', I am prompted for a password, which was not the case previously !
LVL 48

Expert Comment

ID: 9649305
Oracle developer suite do not include Application Server to establish 3 tier archtecture. You have to read the manuals to understand how to establish the environment.

Author Comment

ID: 9725745
I want to close this question

Featured Post


Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to Unravel a Tricky Query Introduction If you browse through the Oracle zones or any of the other database-related zones you'll come across some complicated solutions and sometimes you'll just have to wonder how anyone came up with them.  …
From implementing a password expiration date, to datatype conversions and file export options, these are some useful settings I've found in Jasper Server.
This video shows how to Export data from an Oracle database using the Original Export Utility.  The corresponding Import utility, which works the same way is referenced, but not demonstrated.
Via a live example, show how to restore a database from backup after a simulated disk failure using RMAN.
Suggested Courses

877 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question