telnet server01 to router and everything I type is echoed twice!

on w2k server01 I open cmd prompt and type telnet 192.168.254.254. I am greeted with
 
  Efficient 5861 DMT Router (5861-005) v5.3.20 Ready
  Login:

I type my password and as I type, this is what I see  (yes, anybody seeing this could figure out my password)

m*y*p*a*s*s*w*o*r*d*

It logs me on, but everthing I type looks like
tthhiiss.

If server01 telnets to a different computer, everything is fine.

if a different computer telnets to the router, everything is fine.
LVL 5
rberkeConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PsiCopCommented:
You have local echo turned on.

At the "Microsoft telnet>" prompt, type "unset local_echo" to turn it off on a per-session basis.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
td_milesCommented:
PsiCop is correct in the solution to this problem. To further explain it, what is happening is that your computer & the remote device you are connecting to are both echoing the characters. This is why turning off "local_echo" will work. This will mean that you PC will NOT echo the characters as well, so that you will only see everything echo'ed once (from the router echo).

You will find that some devices have cho enabled by default and some have it disabled.
0
rberkeConsultantAuthor Commented:
That was it.  

By the way, it is NOT on a per-session basis.  I turn it off once and it stays off.

A few points for td_miles comments also.
0
KA9FOXCommented:
I stumbled upon this thread via google.com and just wanted to thank you for the answer also... had the same problem.  I had turned it on months ago, and then couldn't remember how to turn it off!
0
PsiCopCommented:
Google is your friend.

I think the per-session vs. permanent control of that setting is variant based on the version of Windoze.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.