OWA errors out with HTTP/1.1 503 Service Unavailable

Here is a little background on this.

Several weeks ago a 5.5 server was transitioned to a new machine running Win2K and Exchange 2000.  From what I am told the install did not go well, but eventually everything worked with the exception of OWA.  When I got there, if you tried to access OWA you were prompted for credentials.  You then received "error: Access is denied".  Followed MS KB 317471 for resetting permissions.  Now the error is "HTTP/1.1 503 Service Unavailable" after supplying credentials.  Incidentally, once I try to log on after closing my browser I no longer get prompted for credentials and just get the 503 service unavailable message.  

I then started going through KB 305030 and was stopped when I tried to re-register the dll's.  For some reason I regsvr32 would not allow me to register them again.  Unfortunately, I didn't  writed down the exact error message.  Does anyone have a suggestion?

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

David WilhoitSenior Consultant, ExchangeCommented:
This looks like a permissions error. Are users able to contact the mailbox with Outlook? If not, have you checked to see that the stores are mounted?

Check the permissions on the information store, ensure that these permissions are present:

Administrators: Full Control
Authenticated Users: Read and Execute, List Folder Contents, Read
Creator Owner: None
Server Operators: All except Full Control
System: Full Control

Hi Pete23,

Here is the offical link for this problem

you can download a troubleshooting white paper here

Pete23Author Commented:
Apparently I have walked in to a train wreck.  Things just keep getting more interesting...checked the permissions per Kidego's post without any noticeable change (except that the users/groups were not there).  I then tried Tbird008's suggestion of KB article 282230 (which I had mistakenly rejected last night).  What I saw in IIS was that the configuration was incomplete.  I haven't done much with Exchange or IIS in a long while, so I didn't pick up on it right away.  The Exchange website still showed as a folder with globe rather than the open box.  I clicked "create" from within Virtual Directory properties.  I then removed the davex entry and tried the site.  

Things are better, but they are also worse.  I can now log in, but now I see a directory listing of all the mailboxes which I can click through until I get to an actual message.  When I click the message in the FTP-like view I get a file not found.

For some reason, the guy that set up the server reset permissions on C:\ to everyone-full control.  Is it me or do I see a rebuild coming?
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

Hi Pete23,

Not to worry about it c:\ root is by default security permissions is allow full access to everyone.
Can you specify on the problem about what you trying to accomplish and the problem it produce.
I'll check back a bit later go to finish my project here : )

David WilhoitSenior Consultant, ExchangeCommented:
you can always reinstall Exchange to reset the default permissions, and of course reapply your service pack. You don't have to remove it. The default IIS perms for Exchange should get reset as well.


Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Pete23Author Commented:
Alright, not looking forward to reinstalling Exchange/IIS.  I am encouraged that I see an FTP-like listing of the mailboxes (not sure why I am seeing all of them when I log on as a user, but user has administrative privs).

Can you tell me which virtual directories are supposed to be published?  When I started, Exchange was the only published virtual directory.  After publishing Exchweb I get the FTP-like listing of mailboxes.  

If it do have to reinstall Exchange/IIS can you give me an idea of how long the backup/reintall/restore would take with a 3 gig IS on a brand new machine?  Will I have to do a restore?

Thanks for the help.
David WilhoitSenior Consultant, ExchangeCommented:
reinstall does NOT entail removing Exchange or the databases. Only reinstall and reapply the service packs.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.