Help! Cannot bypass novell client logon!

Hi,
I hope this is an easy question I just cannot find the answer to...

I have a machine with a bad NIC.... but I cannot get around the client logon to login into windows NT to uninstall the client, the current NIC, etc and replace!

The machine is running NT4 WS SP6 and there is no "workstation only" checkbox on NT{?}.....  

the nw client is 4.90

what to do?
I'll give you all 135 points I have left! [I wish it were more...]

- or - if this is a possibility -
Apparently according to a vague doc on novells site you can rename the NWGINA*.dll's, but I have not been able to successfully boot to a bootdisk in order to do so because I'm not sure how to do this in NT WS.... [I assume there is a way in boot.ini to specify the a: and not xfer boot control to the OS on c: after ntldr has loaded on the a: etc???]
LVL 1
BrianBaleyAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BrianBaleyAuthor Commented:
OK!

I bucked up and increased the points!
Please hep if possible.... I have to go back tommorrow!
0
learathCommented:
There should be a "worksataion only" checkbox.  It is in the lower left hand corner of the 4.9 netware client on a windows 2000 box.  If that does not work unplug the network cable and the client will eventually time out and ask if you'd like to try to log into windows instead.  
0
PsiCopCommented:
Go to bootdisk.com and find an NT bootdisk with NTFS drivers. This will enable you to boot on A: and see C: to go in and do the things the Novell TID suggests. Note that booting from A: still has to be enabled in the machine's BIOS. If it isn't enabled, you won't be able to boot from there.

learath's idea of unplugging the network cable and waiting for a timeout is a good one to try, assuming the machine isn't crashing somewhere in that process.

Also, have you tried booting into Safe Mode and uninstalling the client?
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

BrianBaleyAuthor Commented:
learath;

in my post I noted that;

a) the machine is running NT 4 WS and not W2000 and therefore does not have the mentioned "workstation only" checkbox

and that;

b) the NIC is bad. dead. Unplugging the cable has no effect.

Also, after timing out, the cursor simply goes back to normal and the login dialog box receives focus again, with no query as to whether to log onto windows instead...

0
BrianBaleyAuthor Commented:
PsiCop:

NT does not have a safe mode.

I am going back to try a new bootdisk and rename the dll's I guess

the timeout idea does not seem valid for NT and 4.90 [at least on this install] as it never asks for a win logon in lieu of NW.
0
ShineOnCommented:
Odd...

With NetWare client for WinNT/2K/XP, when the network times out, it always, in my experience, presents the local workstation login.  You say you aren't getting that?  

Have you tried removing the bad NIC before booting up?
0
learathCommented:
Great idea shineon, usually netware client will not start if there is no network available...
0
BrianBaleyAuthor Commented:
ShineOn:

correct, after timing out, nothing but cursor goes back to normal, and dialog gets focus again [although I vaguely remember a "ding" - I'll have to check]

But there could be probs too, the user continuously reset/rebooted his machine [because it wouldnt log on] and consequently I had to chkdsk /F etc. to fix so could be some corruped files etc...

0
BrianBaleyAuthor Commented:
also, I did remove the NIC and try to boot.... but the client logon DID load....
0
BrianBaleyAuthor Commented:
well... I'll go back there tonight and see if I can glean anything about the timeout not acting correctly and/or the fact that it's still loading... short of that I'll boot and rename dll's...

I'll check back here when I get there and see if there were anymore ideas.... then I guess split up the points....

I appreciate your help...   I haven't worked with netware since 3.12 was shiny and new ;-)

Brian
0
ShineOnCommented:
Can you do a recovery from an install CD to fix whatever the user hosed with the multiple reboots?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
BrianBaleyAuthor Commented:
Hi, sorry I didnt get back for a while...

ShineOn:
Yes, I was able to finally do the following;

1. boot from a windows 2000 cd [make sure you don't take an upgrade disk if it's NT your trying to get to a recovery console <g>]

1a. There is NO boot disk in the world that I can find that includes NTFS WRITE unless you purchase winternals full version of NTFSDOS or use a full version of Win2K or XP on CD.

2. Renaming c:\winnt\system32\NWGINA.DLL to NWGINA.OLD simply caused an exception in win32k.sys....

3. Copy MSGINA.DLL to NWGINA.DLL - this worked.

4. boot into NT [VGA] mode

5. remove the NIC

6. remove Novel Client

Oh, btw - as far as the timeout issue, it went back to working perfectly after reinstalling the novell client back to 4.8.3 instead of 4.9.00.... maybe theres a mismatch of dll's or something ?
0
PsiCopCommented:
That's why we call Windoze "DLL Hell".
0
sverreCommented:
Do a parallel installation of Nt4 with the setup cd.
Be sure to point out a other windows directory, for example win_new.
Then you will be able to choose which version of nt to start in the bootmenu.
0
ShineOnCommented:
I think BrianBaley came up with a solution that works for him.  He just has to close this question, one way or another.
0
DSPooleCommented:
you know, I could have sworn that I've said the 4.90 client was buggy ;)
0
PsiCopCommented:
But you're invisible...
0
ShineOnCommented:
So are you, and so am I... ;)
0
DSPooleCommented:
not invisible, just really really really busy!
0
ShineOnCommented:
But what all three of us has said, over and over in PAQ's, still comes up over and over in new questions, in this TA and others...
0
DSPooleCommented:
we should really go into business together ;)
0
ShineOnCommented:
You're on the northwest coast, I'm in the midwest ... where is PsiCop?  Maybe we can cover the whole dang USA...  hehe...
0
PsiCopCommented:
I'm on the East Coast, so yeah, between the 3 of us, we have the entire country covered.
0
LarryWellsCommented:

Boot the Problem machine to the loging prompt, but do not login.  

Go to a different machine (win 2000 or XP), start regedit, go to: Registry, Connect Network Registry, and connect to the Problem machine.

Browse to this key:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\Winlogon\GinaDLL

Change the value from: NWGINA.DLL to: MSGINA.DLL

Exit from regedit.

Go back to the Problem machine, and reboot from the login window.  It will come back to a standard Windows login window where you can login using any valid windows account for this machine.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Novell Netware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.