Windows 2000 lost 2nd drive

I have recently installed Windows 2000 and now my second harddrive has dissapeared.
I am using an Abit KX7-333-RAID with two IBM Deskstar 60 GB drives spanned on the RAID.  My secondary harddrive is a Seagate Barracuda ST3120026A 120GB connected through IDE channel 1.
Windows is installed on the RAID and functions as normal except the secondary Seagate drive nolonger apears in Explorer or the Disk Management tool.
Within the device manager Windows can see the drive and claims it is working fine and reports 'no conflicts' on all hard ware.
The BIOS detects the drive correctly.
I am running service pk4 and have all uptodate microsoft critical patches.
I have used a floppy with an ibm disk repair tool that recognises the drive and reports its media integrity and mechanics as good.  The seagate drive was working fine until I setup the RAID. It was NTFS with two partitions and was used as a backup device and holds valuable data.
Please, can anyone help me?
futureshockAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rob StoneCommented:
Run SFC /SCANNOW to see if that helps.

Its a strange one.  Have you tried removing it from device manager and letting it redetect?

I presume the BIOS recognises it OK?  Is it possible to undo what you did with the RAID to see if it works again?
0
RazwerCommented:
i dont know this mainboard but did you configure it in the raid controller?
some raidcontrollers you also need to configure the disk even though its a standalone one
so for example you have youre 2 deskstar disks setup as raid 0 which windows will see as one disk (c:\) but you also need to tell the raid controller there is another disk and configure it, depends on the raid controller on how to config it, some got standalone option, some you config it as raid 0
hope this will help you.
0
futureshockAuthor Commented:
Tried removing device from device manager and it redetects the drive fine.

The BIOS detects the Seagate drive correctly.

I have tried the Seagate online drive test and it indicates the disk is fine.
The drive is on the primary ide channel with the jumper set to master.

As far as the RAID goes everything is fine Windows boots from the RAID correctly.

I have tried the windows file checker but nothing was reported
0
Cloud Class® Course: SQL Server Core 2016

This course will introduce you to SQL Server Core 2016, as well as teach you about SSMS, data tools, installation, server configuration, using Management Studio, and writing and executing queries.

RazwerCommented:
no but you have to create a drive set on the raid for the additional drive i think
0
futureshockAuthor Commented:

The additional drive is not connected through the RAID connectors and therefore is not seen by the RAID controller.  

It is connected through the regular IDE connectoras a master drive not being used as part of the RAID.  

 
0
RazwerCommented:
but i still think its a setting on the raid controller, 90% sure of it.
0
futureshockAuthor Commented:
The RAID controller on the KX7 board is the Highpoint 372
I have tried disabling the RAID in the BIOS and using a floppy disc with READNTFS program
READNTFS still does not detect the Seagate drive.
The windows device manager indicates the RAID driver are correct and they are upto date.
The only other BIOS settings for the RAID are create or delete a stripe.

I was wondering if it would be possible to try and read the Seagate NTFS disk from a LINUX installation.

Any Ideas would be a great help!
0
RazwerCommented:
you are looking on partition level now, but its beyond that, if a disk manager doesn't read the disk you should look into the controller, either the raid, or the IDE (or in the bios etc). a disk manager doesnt care what partitions are on a disk, wheiter its linux, ntfs, fat, or whatever. simple msdos fdisk should be able to see the disk no matter whats on it. no need to play with ntfs readers or anything like that.
0
futureshockAuthor Commented:
Well this is a strange thing because the harddisk diagnostic program from Seagate Tests the disk fine.  I also tried the IBM diagnostic tool and that Tests the disk successfully.

0
futureshockAuthor Commented:
I have tried the drive on a new cable and on the other IDE channel but still the same.
0
RazwerCommented:
try booting msdos from a floppy and run fdisk and check what it says at disk information (option 4)
0
futureshockAuthor Commented:
Ok There was nothing visible with fdisk
Next I tried a program get-data-back-ntfs.  
It recognised the drive and said the drive was now a SFS (Secure File System) with the Peter Gutman algorithim.  This explains why it cannot be seen.  The question is now how did it become a secure file system.  I know that I did not cause this to happen.  Therefore I suspect that I have been a victim of some sort of crypto virus.  Has anyone heard of this sort of thing?
I have now reteived the encrypted data using the get-data-back program.
Thanks for the help.
0
futureshockAuthor Commented:
I Guess I solved this one myself so it would be good to have the points refunded.

Thanks to the people that tried to help.
0
PashaModCommented:
PAQed, with points refunded (140)

PashaMod
Community Support Moderator
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.