Solved

Need Help With An Event Log Error

Posted on 2003-10-29
12
290 Views
Last Modified: 2010-04-13
I am running Windows 2000 with SP4 installed and all software (security patches) up to date. The error that is appearing in the event logs, ID 2019 "The server was unable to allocate from the system non-paged pool because the pool was empty." I have been looking around for solutions all day; I found a couple from Microsoft however none of them apply to me... As follows:

A) I am running SP4 (Which is says to upgrade too)
B) I am not running any Anti-Virus Software (Another suggestion that might be causing the issue)
C) I am using a "Broadcom NetXtreme Gigabit Ethernet" Ethernet Card, not an Intel or 3COM Ethernet Card.

The server is used to run some sophisticated e-mail server software. As the program is running, I can see the Non-Paged data shown under the Windows Task Manager increase. It gets up to the point of about 120,000 after about 2 hours since the program has been running and then the server just about crashes completely (have to reboot). I have tried every solution out there however I cannot figure it out. I doubt it's the software itself because I have it running on another server with an identical configuration (Software/Hardware wise) and it runs fine.

Thanks
0
Comment
Question by:m324
  • 5
  • 4
  • 2
  • +1
12 Comments
 
LVL 49

Accepted Solution

by:
sunray_2003 earned 500 total points
ID: 9647629
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 9647632
Also check the discussion here

http://www.eventid.net/display.asp?eventid=2019&eventno=661

Sunray
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 9647637
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 

Author Comment

by:m324
ID: 9647724
Nope, seen all of those and tried them; none of them worked. I even tried reinstalling SP4 and that didn't help either.
0
 
LVL 49

Expert Comment

by:sunray_2003
ID: 9647846
0
 

Author Comment

by:m324
ID: 9648041
I don't understand how the 2nd article is going to assist me because it is just discussing finding the program leaking the memory. Any program running is leaking memory. As for SP4 being an issue, I have SP4 installed on my other server where the program runs fine; I cannot understand what the difference is.
0
 
LVL 5

Expert Comment

by:juliancrawford
ID: 9648460
Not an answer to why its happening, but maybe try a free ram refresher as a quick fix - schedule it to run as needed.
Check out this link, there are heaps available...
http://download.com.com/3120-20-0.html?qt=ram&tg=dl-20
:)
0
 

Author Comment

by:m324
ID: 9651867
Anything specific program you suggest? I don't mind paying; I don't want some free spyware program.
0
 
LVL 2

Expert Comment

by:Bigjohn-s
ID: 9657474
To look into your system configuration more deeply you might try AIDA 32.  It gives great detailed information.

You might also examine task manager's process list and see what processes are eating most memory and CPU time.

Are you getting ANY event log errors other than the one above that might coincide time-wise ? i.e. a minute or two before this error you get another error?

What all do you have running on that machine?

John
0
 

Author Comment

by:m324
ID: 9659007
Well, I found the source of the problem; it’s not Windows itself as I thought. It's a driver I upgraded for a custom made application on the server that was leaking memory. I am waiting for the manufacturer to send me a new driver however in the meantime, is there such a program that will clear the non-paged memory (that is not in use - memory leaks) while the program (causing the issue) is running?

I appreciate everyone that has helped me on this issue.

Thanks
0
 
LVL 5

Expert Comment

by:juliancrawford
ID: 9660810
I did use the RAM Idle Professional 3.3 on my old PC, as it seemed to be the most popular and had a trial period to test it out on.
But once I got my new P4 I have RAM to burn ..lol.
0
 

Author Comment

by:m324
ID: 9801705
I Figured it out, it was a faulty program. Thanks for everyone's help.
0

Featured Post

Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
There’s a good reason for why it’s called a homepage – it closely resembles that of a physical house and the only real difference is that it’s online. Your website’s homepage is where people come to visit you. It’s the family room of your website wh…
This Micro Tutorial will give you a basic overview how to record your screen with Microsoft Expression Encoder. This program is still free and open for the public to download. This will be demonstrated using Microsoft Expression Encoder 4.
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

773 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question