Solved

Sendmail in RH9

Posted on 2003-10-29
5
373 Views
Last Modified: 2013-12-15
Hi there experts!

I have this problem. I have installed a new PC with RH9. Installation went thru well with no problems at all.  After the installation, I checked that the following services and running( HTTP/FTP/EMAIL(SMTP & POP3).

Now here is the problem..

I can check email from my network and outside (POP3 is working) but I can't send mail (SMTP).  When I go the the RH9 pc and telnet localhost 25. it is working. But when I telnet 192.168.x.x 25 this gives me no response.

I have turned of ipchains & iptables cause i suspect that this is a firewall issue but still I can't access the SMTP.

Finally, I checked the /var/log/maillog and it seems that only the POP3s are logged.

 In my last distributions, sendmail is working out from the box. Is there something I missed?
0
Comment
Question by:Sandy Kalugdan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 12

Expert Comment

by:paullamhkg
ID: 9648005
Try in the /etc/hosts.allow add 'sendmail:ALL', save it than restart the xinetd and sendmail service or even restart your server.

Hope this can help.
0
 
LVL 4

Accepted Solution

by:
victorbx earned 100 total points
ID: 9651176
you need to edit the file /etc/mail/sendmail.cf

there you need to search the line :
O DaemonPortOptions=Port=smtp,Addr=127.0.0.1, Name=MTA

you need to replace 127.0.0.1 to 0.0.0.0

and if this is not working ( rare )

you need to change the line to be like this
O DaemonPortOptions=Port=smtp, Name=MTA

(remove "Addr=127.0.0.1,")

victor
0
 
LVL 40

Expert Comment

by:jlevie
ID: 9654206
Close... This is covered in the Release notes for RedHat (on CD #1). The correct procedure for enabling Sendmail to accept external connections is to comment out the line in /etc/mail/sendmail.mc that begins with O DaemonPortOptions=Port=smtp, build a new sendmail.cf, and restart sendmail.
0
 
LVL 3

Author Comment

by:Sandy Kalugdan
ID: 9654867
@victor,

after several research, i have been able to finally get my server to accept users outside the 127.0.0.1.  I'm surprised that your comment is exactly how I did it.

Nevertheless, you deserve to win the points for your efforts.
0
 
LVL 4

Expert Comment

by:victorbx
ID: 9655147
thank you SandyKalugdan

but why C grade if the answer was exactly the correct answer ?


:-)

victor
0

Featured Post

How To Reduce Deployment Times With Pre-Baked AMIs

Even if we can't include all the files in the base image, we can sometimes include some of the larger files that we would otherwise have to download, and we can also sometimes remove the most time-consuming steps. This can help a lot with reducing deployment times.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up Secure Ubuntu server on VMware 1.      Insert the Ubuntu Server distribution CD or attach the ISO of the CD which is in the “Datastore”. Note that it is important to install the x64 edition on servers, not the X86 editions. 2.      Power on th…
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn several ways to interact with files and get file information from the bash shell. ls lists the contents of a directory: Using the -a flag displays hidden files: Using the -l flag formats the output in a long list: The file command gives us mor…
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

630 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question