"one or more breakpoints cannot be set and have been"

im not sure if im right here now,

but i'm developing a c-dll with visual c++ 6 using the lotus notes api.

compiling and debugging worked fine till yesterday.

when i set a breakpoint i allways get this message
"one or more breakpoints cannot be set and have been ..."

but i havet to debug because the notes-api documentation is crap.
hope someone can help me.

im using a vb application do test the dll.

thanx in advance
LVL 3
ragerinoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

a_pravarakhyaCommented:
You have put a break point at line where the control doesnt go there. check if you have put the break point in right place.


Regards,
Pravarakhya
0
GloomyFriarCommented:
Check that the destination folder for the dll is the same that is used when the programm is started.
0
ragerinoAuthor Commented:
yes i did
debugging worked last time. from one moment to the other it doesn't.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

dennis_georgeCommented:
Do check the current Build setting (Active Configuration) .... Build --> Configurations.....
It should be set to DEBUG.. Normally if its set to release mode you can't able to set the break points......

Dennis
0
ragerinoAuthor Commented:
it disables all of my breakpoints
0
ragerinoAuthor Commented:
it is set to debug.
and in the debugsettings there is the testapp.exe which uses the dll.
the testapp is placed in the same folder like the compiled dll.
0
ragerinoAuthor Commented:
Settings of the active Configuration

GENERAL
Build command line: NMAKE /f busytime2.mak
Rebuild all options: /a
Output file name: busytime.dll
Browse info file name: busytime.bsc

DEBUG (Category General, no additonal DLL's)
Executable for debug session: bt_test.exe
Workin directory:c:\busytime_txt
Program arguments:
Remote executable path and file name:

Active Configuration is for busytime2.dll - WIN32 Debug
0
ragerinoAuthor Commented:
maybe i have to activate a service or something outside visual c++ (maybe in vb when making the exe ???)

it would be very fine to post screenshots in here
0
tinchosCommented:
Hi ragerino......

I'm not sure if what I'm about to tell you will work on your case.

I'd try cleaning your projects and rebuilding them again.

It happended to me that I got that error when the dll's trying to debug were kind of corrupt and it was solved using what I told you.

Tincho
0
ragerinoAuthor Commented:
how do you mean  "clean the projects"  ???
what i have to do ???
0
a_pravarakhyaCommented:
just "rebuild all" and try. This will "clean the projects". I suggest to debug in this way: Just press F11 and see where the control is actually going.
0
ragerinoAuthor Commented:
im doing allways a rebuild all and when starting to debug it deactivates all of my breakpoints :(

btw. is it ok when the release- and the debug-folder is empty ???
0
ragerinoAuthor Commented:
Deleting intermediate files and output files for project 'busytime2 - Win32 Debug'.
--------------------Configuration: busytime2 - Win32 Debug--------------------
Microsoft (R) Program Maintenance Utility   Version 6.00.8168.0
Copyright (C) Microsoft Corp 1988-1998. All rights reserved.
 cl -Z7 -Od -c -W3 -DCRTAPI1=_cdecl -DCRTAPI2=_cdecl -nologo -D_X86_=1 -D_WINNT -D_WIN32_WINNT=0x0400 -D_WIN32_IE=0x0300 -DWINVER=0x0400 /Zp -Ow -DW32 -DWIN32  -D_WIN32 -Fobusytime2.obj busytime2.c
busytime2.c
 link -debug:full -debugtype:cv -base:0x1C000000  -dll -entry:_DllMainCRTStartup@12  -out:busytime.dll  busytime2.obj  libc.lib oldnames.lib kernel32.lib  ws2_32.lib mswsock.lib advapi32.lib libc.lib oldnames.lib kernel32.lib  ws2_32.lib mswsock.lib
 advapi32.lib user32.lib gdi32.lib comdlg32.lib winspool.lib notes.lib
Microsoft (R) Incremental Linker Version 6.00.8168
Copyright (C) Microsoft Corp 1992-1998. All rights reserved.

busytime2.dll - 0 error(s), 0 warning(s)
0
tinchosCommented:
Exactly

Either choose the Clean option in the build menu or choose the rebuild option directly

Tincho
0
a_pravarakhyaCommented:
I suggest to debug in this way: Just press F11 and see where the control is actually going.
0
ragerinoAuthor Commented:
just assembler code.
and i think that i have very often to press f11 to get to the lines i want to set my breakpoint.
0
a_pravarakhyaCommented:
try this: press f5 and select debug>break. now see where did the control stop. if you see the assembler code, see call stack (alt+7) and try to get where exactly the control is going.
0
ragerinoAuthor Commented:
now im trying to dl the newest service-pack for visual-studio6
0
dennis_georgeCommented:
hi

Just go to

project --> setting --> Link

Is the generate debug info checked or not ????

Dennis
0
ragerinoAuthor Commented:
hi dennis,

project --> setting --> there is nothing like link

im using visual c++ 6.
maybe you use a different version.
0
dennis_georgeCommented:
hi

when you click on project --> setting then it will open a dialog box (property sheet  / tab strip)

In this there will be a tab named Link.....  Click on that

And I am also talking about Visual C++ 6

Dennis
0
himchCommented:
Hi

The problem could be with the settings in  Tools -> Options -> Directories.
 Just check if you have the correct directories added to "Include" and "Library".

Because, if wrong directories are added, then the files you are opening are not the ones you have included in the project, and hence you can not set break points in them.
You can also check the name and path of the files you are trying to put the breakpoints in by checking its properties, to ensure if they are the correct files.


Hope it helps.

Himanshu
0
dennis_georgeCommented:
One more probability is that the place where you are trying to put the break point may not be the part of the current compilation....

suppose the constant EDITOR is not defined in my project and some part of code is like.....

#ifdef EDITOR

int i = 0 ;  // Here I can't put a break point .. because this code will not be included in the currrent
              // compilation.... because EDITOR is not define anywhere....
.....

#endif


Dennis
0
dennis_georgeCommented:
and more over you can't put a break point on the code where you are only declaring an object or data type ... i.e where no operations are taking place...

like you can't put break point at

int i ;

Dennis
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ragerinoAuthor Commented:
hehe i found that f***ing error.

the .c .mak and .h file is called busytime2.*

but in the .mak file i called the ouputfilename busytime.dll (because of compatibility issues).

seems that visual c++6 is too stupid to recognize this.

dennis_george and a_pravarakhya have been the most active posters so im splitting the points to them.
0
GloomyFriarCommented:
>dennis_george and a_pravarakhya have been the most active posters so im splitting the points to them.

If you were closely attentive to my comment, you have found out a problem much earlier.
But if you consider, that I have not earned any points, so let it be so. ;-(
0
ragerinoAuthor Commented:
but i was using the right dll in the testapp and the tesapp worked. but i had to change the outfilename in the mak-file to the same name in the .h .c and .mak files.
the problem wasn't that i didn't find the compiled dll, the problem was that i wasn't able to debug using brakepoints.

btw. the dll is working now perfectly.
but anyway, thanks for your and the others users help.

wish you all a scary halloween :)
greets ragerino
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C++

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.