Caching Nightmare on Apache

I have been trying to get to the bottom of this for several days now. Basically we have this webserver running Apache2 and I dont know why but it just caches the living daylights out of everything. So much that, if I ftp over an shtml file over to the server, I will not see any changes when  I refresh my browser window. The changes show up after several hours.

Even worse , if I delete the file and refresh the page, it still displays in the browser window. Now I have tried emptying cache+files to see if its the browser but its not. The only way for me to see changes is that I have to go to Apache Manager (web interface) and stop+start the server. I believe this totally empties the cache on the server or something.

I have also tried to enable mod_cache and change the default settings in there, but that didnt help.

Please advise.
LVL 1
psYconAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kalosiCommented:
I am not really sure weaher the apache is the problem here. It could by your browsers cache. Are you 100% sure that it is tha apache not the browser?

david
0
psYconAuthor Commented:
>>>It could by your browsers cache. Are you 100% sure that it is tha apache not the browser?

Positive. I have tested it on different computers. I have scoured all the documentation online relating to mod_expires, mod_cache and what not. So far I havent been able to find out any straightforward solution. As I said before, the only way to refresh is to stop+start the server. One more thing... the box is running Novell Netware 6.5
0
PsiCopCommented:
Hrm. That'd odd. I'm using Apache 2 on NetWare v6.5 right now and I'm not seeing this.

Are you sure there's no Proxy server sitting between you and the webserver? BorderManager is not running on that server, is it?
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

ShineOnCommented:
Do you have anything between the server and the browser, like FastCache or BorderManager, or some other cache product that could be delaying the updates?
0
psYconAuthor Commented:
Yes ! Bordermanager is running. However I have set it up in my Internet Explorer to directly access the internet instead of via a proxy. Do you think it has a role to play in caching even if I am directly connecting to this Web server? Also this webserver is within our company domain and not accessible to the outside world.
0
PsiCopCommented:
Depends on how BorderManager is configured. If it is caching outgoing requests, then yes, its probably the source of issues.
0
ShineOnCommented:
Yes, to expand on that - if you are doing "reverse proxy" - also known as website accelleration, you are caching outbound traffic from the Apache web server.  

Are you accessing the web server from the internal network or through the Internet?  Is the Apache web server "behind" the BorderManager server?  Is it being cached using the forward-proxy capabilities of BorderManager?  Is the Apache server using a private IP and NATting or proxying through BorderManager to present its public IP to the Internet?

Is there any way you can diagram your network as relates to the Apache server, the BorderManager server, the Internet and the browser you are using to access the Apache server - masking public IP's of course - using text in the posting window?  Or at least give some indication of how the data flow is configured, including proxy, nat, etc...?
0
psYconAuthor Commented:
>>>Are you accessing the web server from the internal network or through the Internet?  Is the Apache web server "behind" the BorderManager server?

I am accessing it from the internal network. I also found out that we have a software called the Volera Excelerator which is enables web-caching :P

http://www.novell.com/documentation/volera/english/ex22sp2/

Do you suppose , disabling that might help? I have asked our sysadmin to try that. Will keep you posted. Thanks.
0
PsiCopCommented:
Yep, that's probably the source of the issue. Your browser is hitting the Volera cache and not the documents you just updated. I'm not sure how yoiu have your Volera configured - you may not be able to disable it easily depending on what else is going on.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ShineOnCommented:
Yep, to echo PsiCop.  The Volera Excelerator project was an offshoot of BorderManager "fast cache."  If there is some way the excelerator is between your browser and your web server, that is very likely the cause.

Have you checked the Novell knowledgebase at http://support.novell.com to see if this is a known issue with excelerator?
0
niggCommented:
Try to add a

Header append Cache-Control: "must-revalidate"

to your Apache config file.

If there is any proxy caching and adheres to proxy and caching standards, than this should help!
0
ShineOnCommented:
Regarding Volera and your browser - is your network set up so your browser looks first at the Volera cache before going anywhere else for Web data?  

If so, try setting the address of your web server in the "bypass proxy" settings of your browser.
0
psYconAuthor Commented:
Hi Folks, guess what, my Network admin fixed the problem on the server end. According to him it was something to do with the OS of the server that the webserver was running on. Something low level, like the filesystem protocol or something. It sounded pretty technical to me. Anyways I have decided that I will split points between ShineOn and PsiCop for their efforts. Thank you all.
0
ShineOnCommented:
Thanks for the points.  Any chance you could get your netadmin to post what the problem and fix was, to make this a good PAQ?
0
psYconAuthor Commented:
sure. I'll hope to catch him tomorrow and ask him about it in detail.
0
PsiCopCommented:
Thanks, and I'm also curious to know exactly what the problem was. Always something to learn.
0
psYconAuthor Commented:
This is the email that I received from our network admin..


>>>I did two different things which may have resolved the problem.  Technically, I should have tried one and then the other to determine which it was.  

I applied a patch for NSS (Novell Storage Services - the new NetWare file system)  which addressed some issues and then commented out two startup settings this patch added.

SET LEVEL 2 OPLOCKS ENABLED = OFF
SET CLIENT FILE CACHING ENABLED = OFF

The second setting may have affected the problem.  However, I must mention that we were having the issue prior to applying the patch or commenting out these settings that were added to startup, so I don't know if this had anything to do with it.   I also don't think they were enabled by default.

When I setup the webserver, I installed an option to use NFAP (Native File Access Pack)  It basically makes the NetWare 6.5 server appear as a native server to a workstation running an O/S without a Novell client.  

Windows workstations communicate with NetWare servers using their native Common Internet File System (CIFS) protocol.   Macintosh clients communicate with NetWare servers using their native AppleTalk Filing Protocol (AFP)    Linux/Unix clients communicate with NetWare servers using thier native Network Filing System (NFS)   Browsers communicate with NetWare servers using standard HTTP.

After I commented out the loading of these NFAP NLMS (NetWare Loadable Modules - like programs on a NetWare server)  we were able to see changes to content instantaneously.   While I can't specifically explain why this fixed our problem, I have a feeling that your workstations were using some different access method which may have caused the problem.    

I am not sure if our problem was so much a cache problem as a communication problem.    I was able to make changes dynamically to the original uploaded content on my workstation prior to making these changes and it displayed fine.   Even deleting shtml pages caused them not to show up.   That was what I wanted you guys to see....

<<<<

I am sure it had something to do with commenting out those lines. What do you guys think?
0
ShineOnCommented:
I think it was commenting out NFAP, personally.  I would recommend uncommenting the SET CLIENT FILE CACHING ENABLED=OFF.

What do you think, PsiCop?

0
PsiCopCommented:
I agree with restoring the SET CLIENT FILE CACHING ENABLED=OFF setting.

I really can't see how, in any rational setup, that NFAP could be the culprit. However, if he's right that the workstations were using some different access method, then that could be the problem. To reconcile that with my first sentence, I don't think such an arrangement is rational.
0
RematronCommented:
We've had the same problem here and the solution is much simpler.  The problem is coming from the PSA (Posix Symantec Agent). Just comment it out in the autoexec.ncf file, restard your server and then everything should be fine.

http://support.novell.com/cgi-bin/search/searchtid.cgi?/10089119.htm

Rem
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.