cannot connect to terminal server

I am running small business server 2000 (also used as terminal server) and windows 2000 server, with a firewall vpn between both servers. I am able to connect with terminal server, using internal IP addressing from the workstations on the Windows server 2000 side, however when I try to connect from outside the  vpn network, over the internet, using the server's outside IP address I receive the error,

 "client could not connect to the remote computer.
Remote connections might not be enabled or the computer might be to busy to accept new connections."

I have enabled port 3389 on the firewall.

Does anyone have any ideas?

Thanks,
Diane
dboyle53169Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

sunray_2003Commented:
Diane,

Try checking this going to command prompt

netstat -a and you should see port 3389 listening

S
0
sunray_2003Commented:
You have already enabled the port ... But just check this to see if you get any idea

http://www.experts-exchange.com/Operating_Systems/Win2000/Q_20645133.html

S
0
dboyle53169Author Commented:
It show port 3389 listening, I read that post, however I'm not sure exactly what it is I'm supposed to do.

Diane
0
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

svenkarlsenCommented:
please clarify: do you actually want to connect to the server from a connection via internet, NOT using VPN ?

Furthermore, do you have some sort of port-mapping on your firewall?
It cannot guess which server is supposed to receive the connection, - you must either have public IP-address on the terminal server or have the firewall configured to route the incoming connection to the appropriate address.
0
dboyle53169Author Commented:
Using the internet Not over the VPN, Yes I have a port mapping on the firewall, I have a service setup for port 3389, mapped to the internal IP address of this server. I am using a SOHO3 Sonicwall. I've set these firewall's up many times and usually it's very easy and works perfectly. Possibly this has to do with some configuration in the server?

Diane
0
KingHollisCommented:
You mentioned that you are running SBS 2000 which comes with ISA. Are you running ISA on that box as well? You may need to create a packet filter for services hosted on the ISA server for the external NIC.
Try this:
http://support.microsoft.com/default.aspx?kbid=275210
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
svenkarlsenCommented:
Just to check the route through the firewall: could you enable ICMP and port-map it to the server, - then ping it from outside ?

That would give a clou to where the problem is (i.e. at firewall or server)

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 2000

From novice to tech pro — start learning today.