• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2890
  • Last Modified:

IGMP 239.255.255.254 packets flooding my network

We currently use all Asante IntraCore Switchs. My network has become very slow. We have all IMACS using apple talk on the network.

Checking with a packet analyer I saw millions of packets on my network going to the ip address 239.255.255.254 with a type IGMP.

Thinking I had a couple of bad machines today I unplugged the machines that were sending the packets. When I unplugged a machine that causing the packets it would take 10 minutes and the network would go back to normal.

Then another machine would start to flood the network. It only happened when the machines booted up. If a machine didn't cause the problem on boot it would work fine.

I look some stuff up and it says that I should enable Enable IGMP snooping and  Enable L3 Query device.

First what is l3 query device and will this stop my switches from get flooded.

Also Asante has me disable spanning tree because it doesn't work with well with Apple Talk.

HELP PLEASE

.
0
MSGROVE
Asked:
MSGROVE
1 Solution
 
NicBreyCommented:
IGMP packets are IP multicast packets. Multicast is handled by routers on a network. IGMP snooping is just what helps the switches get multicast address and group information from the routers. It will not help you in this case. Enabling layer 3 on your switches will also not really help unless you redisgn your nework with VLANs.
 
Looks like you have applications on your MACs that look for multicast hosts to join in a group with at startup. I recon that your easiest bet is to try and find the application that want to join multicast groups and to disable it if you don't use them. You say the MACs communicate with appletalk, is TCP/IP installed or configured on them??  
0
 
ShineOnCommented:
Why are you using appletalk on your network?  I thought iMac systems could handle "pure" IP?  

Appletalk is very chatty.  

I would recommend reconfiguring it all to use IP exclusively, with no appletalk at all.
0
 
NicBreyCommented:
Agree with ShineOn. Change to IP if you can and remove appletalk. You will still have to find the applications that send the IGMP requests though.  Applications that use multicast is usually multimedia type applications like video conference applications and video/audio streaming applications.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
_tackCommented:
Old switches and non L3 switch will forward multicast traffic as broadcast to all segments,
new L3 switches do know Multicast traffic and will forward it only where requested, (IGMP join request needed)
introducing L3 policies will just limit the traffic to some segments, but will not solve your problem

0
 
MSGROVEAuthor Commented:
Thanks for your help everyone but I beleive I solved my problem.


Our switches were running on L2 and were treating multicast as broadcast. We inable igmp sniffing on the routers and it has slow down the packets. Also talking with Asante again today they had a firmware update that helped with this.

0
 
GhostModCommented:
PAQed, with points refunded (500)

GhostMod
Community Support Moderator
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now