Tomcat Issues;JVM_Bind:8080

SOS....

i am having big problem.

I have done something stupid, install and reinstall the tomcat 4.1.2 and 5.12 again and again because i am having problem withthis exception (but only notice after i read the log).

Bootstrap: Create Catalina server
Catalina.start: LifecycleException:  Protocol handler initialization failed: java.net.BindException: Address already in use: JVM_Bind:8080
LifecycleException:  Protocol handler initialization failed: java.net.BindException: Address already in use: JVM_Bind:8080
      at org.apache.coyote.tomcat4.CoyoteConnector.initialize(CoyoteConnector.java:1158)
      at org.apache.catalina.core.StandardService.initialize(StandardService.java:579)
      at org.apache.catalina.core.StandardServer.initialize(StandardServer.java:2246)
      at org.apache.catalina.startup.CatalinaService.load(CatalinaService.java:236)
      at org.apache.catalina.startup.CatalinaService.load(CatalinaService.java:258)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.catalina.startup.BootstrapService.init(BootstrapService.java:231)
      at org.apache.catalina.startup.BootstrapService.main(BootstrapService.java:297)
Bootstrap: Starting service
Starting service Tomcat-Standalone
Apache Tomcat/4.1.27
Catalina.start: LifecycleException:  Protocol handler start failed: java.lang.NullPointerException
LifecycleException:  Protocol handler start failed: java.lang.NullPointerException
      at org.apache.coyote.tomcat4.CoyoteConnector.start(CoyoteConnector.java:1182)
      at org.apache.catalina.core.StandardService.start(StandardService.java:506)
      at org.apache.catalina.core.StandardServer.start(StandardServer.java:2190)
      at org.apache.catalina.startup.CatalinaService.start(CatalinaService.java:273)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.catalina.startup.BootstrapService.start(BootstrapService.java:245)
      at org.apache.catalina.startup.BootstrapService.main(BootstrapService.java:307)
Bootstrap: Service started

****

How can i get this things fixed??

opps, forget to mention, i can call the home page of the tomcat.
    http://localhost:8080/index.jsp
and also the tomcat administration page and the manager page.

But the small dos-promtp window didnt stay there after I have start the applciation server......
please help.

miri5698Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Ryan ChongCommented:
You may NOT uninstall your Tomcat clearly, your Tomcat may has been started as a service. try go to your Service Console, see if the tomcat is already running or not. When in your installation, do NOT check it as a service, you can run your Tomcat server manually.
0
miri5698Author Commented:
yeah... no wonder....

ryancys, do you have experience in Eclipse??

I am having problem on setting up the tomcat with it...

I manage to plug the tomcat pug-in into the eclipse, but when i start the tomcat, it;s tell me
"Timeout while waiting for VM to connect. Retry?"

Any ideas what is going on?

I also go to the Windows-Preferences to change the configuration setting for the tomcat.
Tomcat Home:C:\Program Files\Apache Group\Tomcat 4.1
Configuration File :C:\Program Files\Apache Group\Tomcat 4.1\conf\server.xml

but when i click the button for starting the Tomcat...
i get the Timeout errr...
0
Ryan ChongCommented:
Just another workaround, if problem still remains unsolved, try change the default port of 8080 in the server.xml to another port, like 8079, etc.. then try restart your Tomcat server, see if your problem is solved or not.

>>Eclipse
No, not clear what is it, sorry..

regards
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

f_98Commented:
you can always uninstall the service %catalina_home%\bin\tomcat.exe -uninstall "the-tomcat-service-name"

about the eclipse plugin; its not a plugin error; it's about the VM failing to initialize in debug mode; what jdk are you using? try upgrading to 1.4 if it's older.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
f_98Commented:
also you can try to check the option "Do not run tomcat in debug mode" in windows>pref>tomcat
0
pbutronCommented:
Do any one know how to uninstall tomcat at solaris.
thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
JSP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.