Shortcut Points to Computer Where Created rather than to C:\ When Copied

I created a shortcut file (.lnk) on my PC. I copied it from my PC to a network drive. I then have a batch file that installs the shortcut - to be used for system installation by other users on the network.

The problem: Although I created the shortcut on my PC as pointing to C:\MyApp\MyApp.exe, when it is installed on a Windows XP machine it then points to \\MyPC\C$\MyApp\MyApp.exe. I want it to point to C:\MyApp\MyApp.exe - I don't want them retrieving the EXE from my machine across the network.

How do I create and install a shortcut that points to the local machine in XP from a BAT file.
benherronAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gemartiCommented:
Try this:
Map a drive to your network folder where the shortcut is to reside:
Open My Documents.
If the folder where you want to place the shortcut is not located in My Documents or its subfolders, use Search to find it. To open Search, click Start, and then click Search.

Double-click the folder where you want to place the shortcut.
On the File menu, point to New, and then click Shortcut.
Follow the instructions in the Create Shortcut Wizard.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CleanupPingCommented:
benherron:
This old question needs to be finalized -- accept an answer, split points, or get a refund.  For information on your options, please click here-> http:/help/closing.jsp#1 
EXPERTS:
Post your closing recommendations!  No comment means you don't care.
0
gemartiCommented:
Award points to gemarti.
0
benherronAuthor Commented:
OK - not a great response to this. The suggested answer by gemarti fails to address the actual question and does not work.

What I ended up doing was changing the C:\ in the path of the shortcut to %SystemDrive%\ which is an environment variable. This works well. Award the points to me - thanks :-)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.