Printing British Pound

Hello,

I am trying to print a British Pound (£) from Solaris 8 to a HPLJ5Si. My printer is defined as follows:

lpadmin –p hp5sics –v /dev/null –m netstandard –o dest=hp5sics:9100 -o protocol=tcp –T unknown –I any
enable hp5sics
accept hp5sics

I have an entry in /etc/hosts for hp5sics and I do get prints out. However, when I try to print an ascii file with a British Pound sign it comes out as a u with an accent over it.

Anyone any ideas what I can try?

Thanks in advance.
cicssjwAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

colsey79Commented:
Hi there

The problem you are getting is caused by the way the printer is interpreting the £ sign.  To explain this we need to look at the Octal/Decimal values and correlate them to the symbol tables.

In Octal, the £ is 243.  This code maps to Decimal 163 which in Extended ASCII correlates to the u with an accent.

The fact your OS recognises the £ sign as a £ and not anything else would indicate the OS is setup correctly.  What you are going to have to do is to change the symbol set on your printer itself.  If I remember correctly, you should be able to do this within the printer's menu system.  You will need to select a symbol set that contains the pound sign at Octal 243 or Decimal 163.

If you can't change the printer, the only way round this is to create a filter that changes the Octal 243 sent by the OS to Octal 234 (Decimal 156) which correlates to the £ sign in the Extended ASCII table.

Or the worst case scenario is to replace all £ signs in your documents with an escape sequence for the £ sign in Extended ASCII... which does have the side effect of not showing up as a £ in Solaris, but more likely "£"

HTH

0
cicssjwAuthor Commented:
Sorry for the delay in replying, I was on holiday :-). Thanks very much for the information and looks like my problem. I have 300+ printers with this problem and it will be impossible changing each one (if it is possible). Can you let me know how to create a filter to change Octal 243 to Octal 234?

Thanks in advance.
0
colsey79Commented:
You could try a crude little filter by adding this line to /etc/lp/interfaces/<printername>

FILTER="cat - | tr '\243' '\234'"

The other option is to see if you can remotely manipulate the printers.  That later HP printers will accept PJL commands to change settings on a printer remotely.  Check the HP website on how to do this and the necessary commands as these can be printer specific.

HTH


0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
cicssjwAuthor Commented:
This works great. Thanks for your time.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.