Solved

Troubleshooting configuring vpn on pix 506e

Posted on 2003-10-31
9
2,012 Views
Last Modified: 2013-11-16
Hi i'm configuring a pix 506e vpn client,i cant do the connection yust fine but cant ping between  networks (vpn client and local) this is my please help me i'm loosing my mine!!! when connected from firewall can ping 192.168.2.1 but it's all i can do. I think it is a real mess because of test i have made.

PIX Version 6.3(1)
interface ethernet0 auto
interface ethernet1 auto
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password .Pbrm/gcc3Yxs1Zs encrypted
passwd .Pbrm/gcc3Yxs1Zs encrypted
hostname FirewallNorm
domain-name ciscopix.com
clock timezone CST -6
clock summer-time CDT recurring 1 Sun May 2:00 last Sun Sep 2:00
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names

name 192.168.2.0 vpn
access-list acl_out permit icmp any any log
access-list 100 permit tcp any host x.x.211.115 log
access-list 100 permit icmp any any echo-reply
access-list 100 permit icmp any any time-exceeded
access-list 100 permit icmp any any unreachable
access-list 100 permit udp any host x.x.x.115
access-list 100 permit icmp any host x.x.x.115
access-list inside_access_in deny tcp 192.168.1.0 255.255.255.0 eq www any eq www
access-list inside_access_in permit tcp host alejandro any

access-list inside_access_in permit esp any any
access-list inside_access_in permit ip any any
access-list inside_outbound_nat0_acl permit ip any vpn 255.255.255.0
access-list VPNNorm_splitTunnelAcl permit ip vpn 255.255.255.0 any
access-list outside_cryptomap_dyn_20 permit ip 192.168.1.0 255.255.255.0 vpn 255.255.255.0
pager lines 24
logging on
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.116 255.255.255.240
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm

ip local pool IPVPNPool 192.168.2.1-192.168.2.254

pdm location 0.0.0.0 255.255.255.0 inside
pdm location 0.0.0.0 255.255.255.240 inside
pdm location 0.0.0.0 255.255.255.240 outside
pdm location 0.0.0.0 0.0.0.0 outside

pdm location 192.168.1.192 255.255.255.224 outside
pdm location vpn 255.255.255.0 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 x.x.x.117-148.233.211.125
global (outside) 1 x.x.x.126
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) x.x.x.115 Serv_QuickMail netmask 255.255.255.255 0 0
access-group 100 in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 x.x.x.114 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:40:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
http server enable
http 0.0.0.0 0.0.0.0 outside
http x.x.x.0 255.255.255.0 outside
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map dynmap 20 match address outside_cryptomap_dyn_20
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup VPNNorm address-pool IPVPNPool
vpngroup VPNNorm split-tunnel VPNNorm_splitTunnelAcl
vpngroup VPNNorm idle-time 1800
vpngroup VPNNorm password ********

ssh timeout 5
management-access outside
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
terminal width 80
Cryptochecksum:b3a4f2aac69fe2cae2c2afdbad29decf


0
Comment
Question by:Alejandro_Lopez
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 4
9 Comments
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
ID: 9661474
Are you perhaps trying it from a remote client that is behind a soho router (on broadband connection) where your local IP subnet is also 192.168.1.x ??

This is by far the most common issue if you can establish the connection, but can't ping across.

The second most common issue is the default gateway settings on the systems on the LAN. If it is not set to the PIX firewall's inside IP, then you have these same problems.
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9661478
>access-group inside_access_in in interface inside

remove that line, too. Your access-list inside_access_in is questionable...
0
 

Author Comment

by:Alejandro_Lopez
ID: 9662580
Yes it's true i'm behind a soho router and using same same subnet 192.168.1.x, but same thing happens when dial up connected (no lan attached), here i have additional information that can be usefull, i connect dial up (windows xp) and open a msdos windows and use ping command, the issue is even if i ping myself (the address that pix assing me) i also receive no answer. In the vpn client software on status i can view the ip assigned by pix but i see:

Connection Entry:XXXX
Client IP address: 192.168.2.1
Server IP address: X.X.X.116
Encryption: 168-bit 3-DES
Authentication: HMAC-MD5
Transparent Tunneling: Inactive
Tunnel Port: 0
Compression:None
Local LAN access: Disable
Personal Firewall: None
Firewall policy: None

but i just configure de entry with Allow Lan Access.....

the systems on the lan have pix as default gateway so that isn't a point

the access group  inside_access_in is declared to permit only few ip's to access htttp services, anyway i eliminated reload the system and it didn't work
0
Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

 
LVL 79

Expert Comment

by:lrmoore
ID: 9662753
What version client are you using? Try upgrading to the new 4.03
0
 

Author Comment

by:Alejandro_Lopez
ID: 9664842
i'm using 3.6. That's another history... a real pain to obtain vpn client because when i pusrchased the pix they offered me the software and said to me there will be no extra charge for it, but now result that i have to buy a support license (or a kind of) so expensive to use just with one box. The local dealers also don´t have mac version (the one i'm needing, i just have pc compatible one), at this point sometimes i ask myself if i took a wrong option....
0
 

Author Comment

by:Alejandro_Lopez
ID: 9690053
I Just upgrade to 4.02, but now i can connect but still can't ping across networks not even from firewall to 192.168.2.1 (vpn ip pool), but before the upgrade i could not ping myself, now i can do it

Any idea???
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 9690084
>can't ping across networks not even from firewall to 192.168.2.1 (vpn ip pool),
If you are trying to ping your client IP address, you can't because of the built-in ZoneAlarm firewall in the VPN Client.

If your local LAN ip is still 192.168.1.x, then you are always going to have trouble, or are you trying this over dialup with your local LAN interface DISABLED?

0
 

Author Comment

by:Alejandro_Lopez
ID: 9690829
yes i'm using dial up (lan diableb)

it's a litte bit funny because before changing vpn client version i could
0
 

Author Comment

by:Alejandro_Lopez
ID: 9694361
Irmoore

I just connected and ping !!!!  the vpn cliente version was not the issue, the issue was the following line:

vpngroup VPNNorm split-tunnel VPNNorm_splitTunnelAcl

I change it for :

vpngroup VPNNorm split-tunnel inside_outbound_nat0_acl

I know my configurations is not the best but when trying to fix it i added a lot of garbaje....

Anyway thanks for your help

0

Featured Post

Secure Your Active Directory - April 20, 2017

Active Directory plays a critical role in your company’s IT infrastructure and keeping it secure in today’s hacker-infested world is a must.
Microsoft published 300+ pages of guidance, but who has the time, money, and resources to implement? Register now to find an easier way.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have an ASA5510 then this sort of thing would be better handled with a CSC Module, however on an ASA5505 thats not an option, and if you want to throw in a quick solution to stop your staff going to facebook during work time, then this is the…
When speed and performance are vital to revenue, companies must have complete confidence in their cloud environment.
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question