Linksys Wireless Can't Connect to Network Using Cisco VPN Client

My OS is W2K.  I am attempting to connect to a corporate network via Cisco VPN Client using a Linksys WRT54G Router.  When I hookup my laptop (IBM Thinkpad T22) to the router with a hardwire I can log onto my corporate network with no problem.  But when I connect to the router using the Linksys WPC54G Notebook Adapter and attempt to log onto the network, the connection times out.  The very first time that I used the hardware configuration the log-in was successful, but it has never worked since that first logon.

Thank you for your assistance.
PJS213Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PJS213Author Commented:
One other point, I am using a DSL connection.
PJS213Author Commented:
And one more point (sorry) - there is no problem connecting to the internet itself when I am using the wireless adapter.  The problem arises when I try to connect to the corporate network over the internet using the wireless adapter.
svenkarlsenCommented:
have you checked thatthe "Deterministic Network Enhancer" is present and selected in the properties of your wireless adapter?

Otherwise (or perhaps: anyhow ;-) try reinstalling the VPN client while your Linksys card is installed.

You may be required to deativate the hardwired LAN adapter wwhen using the wireless.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

PJS213Author Commented:
Where would I check to see if the "Deterministic Network Enhancer" is present and selected in the properties of the wireless adapter?
svenkarlsenCommented:
Hi PJS,

Desktop > my network places > properties > dbl-click the wi-fi adapter. > click properties

This will bring up a window with the adapter properties, showing which components are installed for your adapter.

Compare with your hardwired LAN-adapter to see the difference...

Sven
PJS213Author Commented:
I checked the properties and I do not see "Deterministic Network Enhancer" nor do I see the opportunity to select it as a property.
svenkarlsenCommented:
Try reinstalling the VPN client with your Linksys card in place.
svenkarlsenCommented:
What Cisco VPN client version are you using ?
lrmooreCommented:
Try using the SetMTU utility that loads with the Cisco VPN client to set the MTu at 1300, reboot and try again.
I had much the same issue with older Linksys BEFW11S4 wireless router. Never could connect using wireless, but same laptop could connect all day any day wired. Using a Cisco wireless AP in place of the Linksys also worked just fine.  Upgrading the firmware on the Linksys fixed it. Unfortunately, the fixed version was not released for several months...
svenkarlsenCommented:
Pjs, -just for my records: do you use same login now, as with the first login that worked ? I've had another case with a Linksys wi-fi where everything worked fine with administrator, but normal user accounts didn't work ? (I'm getting suspicious, -but don't know where to point it ;-)
PJS213Author Commented:
Same log-in.
PJS213Author Commented:
Reloaded the Cisco VPN Client but to no avail -
PJS213Author Commented:
The Cisco VPN Client version is 1.99
svenkarlsenCommented:
You should try updating your VPN client, - current version is 4.x. Contact your network admin on the target network to check for available update.
lrmooreCommented:
svenkarlsen, that was my first instinct, too, and even had that all typed up. Then I re-read the issue and since he can connect and work just fine while wired, that is not a recommended solution. It has to be something in the wireless. The wireless transmission adds overhead to the normal 1500 byte MTU packets and could be causing packet fragmentation and IPSEC does not like to see fragmented packets. Changing the MTU size on the client could be a fix, getting updated firmware for the AP/router could be a fix.
PJS213Author Commented:
I've already updated the router with the latest firmware.
svenkarlsenCommented:
lrmoore,

(in all respect...) I am aware of that, - problem with VPN is that it relates to the NIC on a lower level. As far as I know, Cisco VPN will not run on a Token-Ring adapter or PPPoe, and I'm not 100% convinced that the solution with VPN over wireless is generally a problemfree solution, - I'm currently seing many questions on this config, and several unresolved with Linksys Wi-fi involved.

Anyhow, - you're the expert on this: could it have anything to do with the fact that two NIC's are active and the active state of split-tunneling at the server ? (I don't believe the client in question has any config for this feature).

PJS,
unless lrmoore advice against it, I suggest you try disabling the fixed-wire network connection to see if that makes any difference.
PJS213Author Commented:
There is no fixed-wire network connection when I am attempting to connect wirelessly.
lrmooreCommented:
This has been a problem with Linksys wireless for several iterations of the Cisco VPN client...
Ref bug ID CSCdz52156, and earlier bug CSCdu36784, CSCec46291, CSCdz61359
The first two, an upgrade to the Linksys firmware fixed it. The other two are wireless NIC specific (linksys and SMC, respectively), and perhaps require a driver update, or client update. One was actually addresses in a client update, but that was a 3.0 client...
If we're talking an old 1.x client, all bets are off....
In this case, svenkarlsen may be on the right track that the issue is at the lower levels between the NIC driver and the old client... If you can't upgrade to a newer client, you may be out of luck.
Out of curiosity, what are you connecting to at the other end? Do you control that, or do you have a good relationship with whoever does?
PJS213Author Commented:
Will I avoid this problem if I use different hardware, such as Netgear or D-Link?
svenkarlsenCommented:
PJS:
re: alternative hardware, possibly lrmoore can give you some hints, but I will not attempt to advice on that.

I suspect that the VPN v. 1.xx will "tie-up" to the first active LAN-adapter found. If your "fixed-wire" LAN-adapter is build into the computer, then even if you do not have a wire plugged into the fixed-wire LAN, that connection may still be considered active (to some extend) within the internal environment of the computer.

If this is the case: test the following:

1. On desktop, right-click My Network Places and select Properties
    In the window showing your network connections, you have one or two called "Local area connection n"
    (if they've not been renamed).
    If you have two, determine which belongs to your build-in LAN-adapter and disable it (Right-click and select disable)

2. Now boot the box and test for functionality (probably no change, but do it anyhow - the boot is required...)

3. Uninstall the VPN client

4. Boot the box

5. Re-install the VPN-client


lrmooreCommented:
Suggest PAQ instead
Computer101Commented:
PAQed - no points refunded (of 500)

Computer101
E-E Admin

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.