Activating php extensions

Is it possible to activate the php extensions php_curl.dll and php_gd.dll by appending .htaccess or another local file?

I do not have access to /etc/php.ini and cannot uncomment the lines required to activate php extensions I require.

There lines are:
;extension=php_curl.dll
;extension=php_gd.dll

I know it's possible to override values set in /etc/php.ini by adding them to a the local file .htaccess.

eg.
php_value magic_quotes_gpc 0

As far as I understand, the php server needs to be restarted in order for the extensions to be loaded. Maybe somebody out there knows a trick?

Red Hat Linux release 8.0 (Psyche)
Apache Version 1.3.28 (Unix)
PHP Version 4.3.2
KosmokAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

heskyttbergCommented:
Hi!

This can only be done with certain values.
An extension must be loaded when php starts and in this case this is when Apache starts.
And the linse should not be .dll in a RedHat environment.

So if you want thoose extension you have to talk the server owner into activating them.

Regards
/Hasse
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
niggCommented:
Hi,

You can try the following, but I never tested it:

At top of page write:

<?
/* You might set the absolute path where the extension exsists, like /home/user/extension/my_ext.so */
ini_set("extension","php_gd.so");

?>
0
heskyttbergCommented:
Hi!

An extension cannot be loaded in this fashion, since it needs to restart the whole php engine in order to load an extension.
For info on settings to change in this manner see:
http://se.php.net/manual/en/function.ini-set.php

Regards
/Hasse
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apache Web Server

From novice to tech pro — start learning today.