Solved

Cisco Dialup PPP aux port default route

Posted on 2003-11-02
7
2,154 Views
Last Modified: 2008-02-01
The dialup modem connects to the ISP but I recieve no  default gateway.

If I manually add a route: "ip route 0.0.0.0 0.0.0.0 Dialer1"
it works but then my: "ip route 0.0.0.0 0.0.0.0 eth1/0 200" gets trumped even when my Dialer1 isnt conneted.
I cannot do: "backup int dialer1" under eth1/0


interface Async65
 description connected to Internet
 no ip address
 ip nat outside
 encapsulation ppp
 ip tcp header-compression passive
 dialer in-band
 dialer rotary-group 1
 dialer watch-group 8
 async mode dedicated
 no keepalive
!
interface Dialer1
 description connected to Internet
 ip address negotiated
 ip nat outside
 encapsulation ppp
 no ip route-cache
 ip tcp header-compression passive
 dialer in-band
 dialer idle-timeout 30
 dialer string 5551212
 dialer hold-queue 10
 dialer watch-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname bob
 ppp chap password bob
 ppp pap sent-username bob password bob
0
Comment
Question by:akourafas
7 Comments
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
try this:

ip route 0.0.0.0 0.0.0.0 dialer1 220
ip route 0.0.0.0 0.0.0.0 <ip address of upstream>

The reasoning behind this is that your dialer1 interface  has a higher cost factor (220) than your default route (1) in this configuration.
I also use the explicit ip address of the upstream router rather than the interface as the gateway. You may loose connectivity to the upstream router without your interface going down, and your default gateway won't change dynamically.. this configuration takes that into consideration..
0
 
LVL 1

Author Comment

by:akourafas
Comment Utility
Thanks lrmoore, but I still got troubles.

Here is my config and a show route
Even though the eth1/0 external interface couldnt communicate with its static gateway (i unplugged 172.16.1.1) the route remained the primary route.

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco2620
!
!
ip subnet-zero
!
!
no ip domain lookup
!
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT \T" TIMEOUT 45 CONNECT \c
modemcap entry supra:FD=&F:AA=S0=1:CD=&C1:DTR=&D3:HFL=&K3:BER=\N3:BCP=%C1:NER=\N0:NCP=%C0:NEC=E0:NRS=Q1
!
!
!
!
interface Tunnel0
 description tunnel-to-main-tunnel0
 ip address 192.168.255.2 255.255.255.0
 keepalive 10 3
 tunnel source Ethernet1/0
 tunnel destination 66.203.73.1
!
interface FastEthernet0/0
 description connected Internal Network
 ip address 10.16.16.4 255.255.255.0
 ip nat inside
 duplex auto
 speed auto
!
interface Ethernet1/0
 ip address 172.16.1.20 255.255.255.0
 ip nat outside
 half-duplex
!
interface Async65
 description connected to Internet
 no ip address
 ip nat outside
 encapsulation ppp
 dialer in-band
 dialer rotary-group 1
 dialer watch-group 8
 async mode dedicated
 no keepalive
!
interface Dialer1
 description connected to Internet
 ip address negotiated
 ip nat outside
 encapsulation ppp
 no ip route-cache
 dialer in-band
 dialer idle-timeout 30
 dialer string 15084372391
 dialer hold-queue 10
 dialer watch-group 1
 no cdp enable
 ppp authentication chap pap callin
 ppp chap hostname bob
 ppp chap password bob
 ppp pap sent-username bob password bob
!
router eigrp 1
 passive-interface Ethernet1/0
 passive-interface Async65
 network 10.5.5.0 0.0.0.255
 network 192.168.255.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip nat inside source route-map out-dialer1 interface Dialer1 overload
ip nat inside source route-map out-dialer2 interface Ethernet1/0 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.1
ip route 0.0.0.0 0.0.0.0 Dialer1 220
!
access-list 1 permit 10.16.16.0 0.0.0.255
dialer watch-list 1 ip 192.168.251.0 255.255.255.0
dialer-list 1 protocol ip permit
route-map out-dialer1 permit 10
 match ip address 1
 match interface Dialer1
!
route-map out-dialer2 permit 10
 match ip address 1
 match interface Ethernet1/0
!
snmp-server community public RO
snmp-server enable traps tty
!
line con 0
 exec-timeout 0 0
 login
line aux 0
 script dialer Dialout
 modem InOut
 modem autoconfigure type supra
 transport input all
 autoselect ppp
 stopbits 1
 speed 115200
line vty 0 4
 password bob
 login
!
!
!
end

Cisco2620#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.1.1 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
S       172.17.0.0 [1/0] via 10.16.16.44
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet1/0
S    192.168.251.0/24 [1/0] via 10.16.16.44
S    192.168.20.0/24 [1/0] via 10.16.16.44
     10.0.0.0/24 is subnetted, 1 subnets
C       10.16.16.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 172.16.1.1
Cisco2620#
0
 
LVL 1

Author Comment

by:akourafas
Comment Utility
Soory bad show route last time, dialer had disconnected

Cisco2620#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.16.1.1 to network 0.0.0.0

     140.186.0.0/32 is subnetted, 2 subnets
C       140.186.46.3 is directly connected, Dialer1
C       140.186.46.108 is directly connected, Dialer1
     172.17.0.0/24 is subnetted, 1 subnets
S       172.17.0.0 [1/0] via 10.16.16.44
     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, Ethernet1/0
S    192.168.20.0/24 [1/0] via 10.16.16.44
     10.0.0.0/24 is subnetted, 1 subnets
C       10.16.16.0 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 172.16.1.1
Cisco2620#
*Mar  1 00:27:33.027: As65 DDR: idle timeout
*Mar  1 00:27:33.027: DDR: Dialer Watch: watch-group = 1
*Mar  1 00:27:33.027: DDR:        network 192.168.251.0/255.255.255.0 DOWN,
*Mar  1 00:27:33.027: DDR:        primary DOWN


Notes;
The tunnel interface connects to my main router.
The eigrp sends the 192.168.251.0 network route that I monitor.
I add and remove it statically during testing.
Gotta love dialer-watch, it is working perfectly.
Just my default route issues



0
Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

 
LVL 1

Expert Comment

by:ed_reyes
Comment Utility
Not sure if you need a dialer interface for this scenario.  I have a similar config which does dial backup with a watch list.  I have crypto on these interfaces but I removed all those lines for this example.
You might want to try something like this:

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Test
!
logging buffered 10000 debugging
!
enable secret 5 <deleted>
!
memory-size iomem 15
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
!
!
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
chat-script modem "" "atdt\T" TIMEOUT 60 CONNECT \c
chat-script rstusr "" "at&fs0=1e0&r2&d2&c1&b1&h1&m4&k1q0&w" "OK"
!
!
interface Tunnel202
 ip address 10.10.220.1 255.255.255.0
 tunnel source Ethernet0/0
 tunnel destination 2.4.6.8
 tunnel key <deleted>
!
interface Ethernet0/0
 ip address 123.234.111.222 255.255.255.252
 no ip route-cache
 no ip mroute-cache
!
interface FastEthernet0/0
 ip address 172.16.0.1 255.255.255.0
 speed auto
!
interface Async5
 ip address negotiated
 encapsulation ppp
 no ip route-cache
 ip tcp header-compression passive
 no ip mroute-cache
 delay 10000
 dialer in-band
 dialer idle-timeout 60
 dialer watch-disable 45
 dialer string <deleted>
 dialer watch-group 10
 dialer-group 10
 async default routing
 async mode dedicated
 ppp authentication pap callin
 ppp pap sent-username <deleted> password 0 <deleted>
!
router eigrp 1
 network 123.234.111.220
 network 10.0.0.0
 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 0.0.0.0 0.0.0.0 Async5 100
no ip http server
ip pim bidir-enable
!
dialer watch-list 10 ip 192.168.1.0 255.255.255.0
dialer watch-list 10 delay connect 60
dialer watch-list 10 delay disconnect 10
dialer-list 10 protocol ip permit
!
router eigrp 1
 network 10.0.0.0
 network 172.16.0.0
 auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.102
ip route 0.0.0.0 0.0.0.0 Async5 100
no ip http server
ip pim bidir-enable
!
dialer watch-list 10 ip 192.168.1.0 255.255.255.0
dialer watch-list 10 delay connect 60
dialer watch-list 10 delay disconnect 10
dialer-list 10 protocol ip permit
0
 
LVL 1

Author Comment

by:akourafas
Comment Utility
Please close, solved the problem using: route 0.0.0.0 0.0.0.0 x.x.x.x track 123

http://www.cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
Comment Utility
PAQed, with points refunded (500)

Computer101
E-E Admin
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
PRTG Network Monitor lets you monitor your bandwidth usage, so you know who is using up your bandwidth, and what they're using it for.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now