Root & User Account Authenticvation failed

Dear Experts,

I am using Red hat 9.0.Tomorrow I was (sunday) using XCHAT as root.  When I login next time, as Root or my one user account.  It gives message "Authentication Failed". But when I login with non existing accounts then it simply blank the text area for another user name entry.

This way my system is useless.  It do not want to format my system. Because there is very important data.  So tell tell me the right way to access my system.
turiyainSystem AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Do you mean root is the only user you have in your linux box? if yes, are you sure you used the correct root password?

If you forgot you root password, can you physicaly access the linux box? if yes, try download the linux on a CD or floppy from here or, boot up with this CD or floppy, run fdisk -l to found out the partition of /etc, mount the /etc, in the /etc/shadow, change the entry 'root:$1$ve.2WRaU$F8FZqVNwcgQftsnWCG5Ig0:12202:0:99999:7:::'  to 'root::12202:0:99999:7:::' this will remove the root password, so after you reboot the original linux, there will be no root password, after login as root (without the password) add the root password by 'passwd' or 'passwd root'.
turiyainSystem AdministratorAuthor Commented:
I am having two user

1. Root - default
2. vijay - created

I am using the correct password.  Both the mentioned user account are giving the message 'authentication failed'.   I accessed the system with these accounts and their password many times.  There is scope of error in typing or spelling.
How you access your linux distro? using XCHAT? have you setup anything to restric access after last login?

is it the same error even you physicaly access the server? have you try remove the root password and login as root without prassword as I suggest above?

try and post your result please
Protecting & Securing Your Critical Data

Considering 93 percent of companies file for bankruptcy within 12 months of a disaster that blocked access to their data for 10 days or more, planning for the worst is just smart business. Learn how Acronis Backup integrates security at every stage

boot your box with the parameter
at you LILO prompt
then you can reset all passwords in /etc/passwd and/or /etc/shadow
turiyainSystem AdministratorAuthor Commented:

I am confused with your link:, I have visited it. Tell me that what file I have to download to make bootable floppy.
Because in the home page a lot of options on the mentiioned link.  Please give me the final link address.
Sorry for the confusion, try this
and this also a good one

Both can get a linux on a floppy with the fdisk :)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Why to close and delete this question? is the asker find the solution? if yes, what's the solution?

Also if need to close, why not PAQ'd and no refund?
turiyainSystem AdministratorAuthor Commented:
Pall always try to give his best answers.  I appreciate it.  And I do not want to discourage him.

Give him the 30 points and close the question.

Hope that pall not mind it.  and in future give me his valueable knowledge.

I'm not looking for points, I'm just wanted to know how you solve you problem, I'm here to learn and try my best to help, that's why I keep asking the solution.

Also I think this TA have some hints for others, so why delete it? I suggest to keep this.
turiyainSystem AdministratorAuthor Commented:
Just i want to close the matter.  Because i tried to down load the files but all in vain.  Is it not possible to give  information not depends on other unavail resources. For e.g. to down load files from net...
So i request to give information on resources avail on hand as like Boot able CD,bootable floopy or some tricky tip.

Just downlaod the, if you wanted to create the boot disk from unix/linux. procedure

put a formatted floppy into floppy drive, in the console prompt run "dd if=hal91.img of=/dev/fd0"

if you going to create the boot disk from M$ windoz download the above img and, put the formatted floppy into the floppy drive get into Dos prompt run "rawrite2 -f hal91.img -d a:" (ensure the rawrite.exe and hal91.img on the same directory)

So that you can create the boot disk, and I create this many time for my friends and they all happy on it. (this kind of linux only for restore your password or system)

for create a floppy from your existing RH linux try take a look on this

Hope this can give you more hints

turiyainSystem AdministratorAuthor Commented:

Thanking you....
What a surprise.  axpecting this from your
turiyainSystem AdministratorAuthor Commented:
Please do not delete this question.. Keep it for others information.

       at LILO prompt press control +X
        there  u plz  type linux single
         ur system boot and will not ask any passwords
         there u can chage the passwords ..
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Security

From novice to tech pro — start learning today.