I have reformated my computer recently and now reinstalled VB6 with sp5.

For some reason I did not had the Msinet.ocx in my component list, so I downloded it and registred it with regsvr32.

Now it shows in vb but when I try to drag it to a form vb tell me that I dont have a licence for that component.

I have been using this ocx before, has never been a problem, what am I missing ?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

from where did you download it, i didn't  see it available on MS  download? i update VB6 with sp5 without difficulty, try again
SNilssonAuthor Commented:
Dont remember from where, but I also had support files from my project containing msinet.ocx, I tried that file also same effect.

Apply the sp5 patch again ?
Sure, I can run it again, but there was no errors and everything else is working as expected.

When I installed Visual studio I installed everything but C++, could it be that Msinet.ocx is installed along with that ?
install the active x option of visual studion inet comes within that.

still if you want you can download it from

check the legalities for using it

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

SNilssonAuthor Commented:
Thanks, I must have missed/unchecked that install option the first time :)
Glad could help!
I had a similar thing like that... but with VB.NET... sorted now
Bhagyesh Trivedi
Try to unregister en reregister it worked for me ;)
make shure you have the latest IE version installed
does this work for Excel VBA? I'm getting same error for a macro I've written.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.