ASP.NET Remote Debugging (client using IIS5 XP and server using IIS6 2K3)

Hi,

I have a problem when using VS.NET 2002 from my client machine using XP Pro IIS5.  I can create a web application on the server running 2K3 IIS6, but it cannot configure the root directory.  It tells me it could be because of the client/server running different versions of IIS.  I also have FrontPage Extensions 2002 installed on both, though I just use the file share web access method.  Is there some settings on the server side that I can set to allow this to work properly?

Thanks!
lconnellAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

harwantgrewalCommented:
you want to debug your appliction on the client write..? for that make a user which belong to the group vs developers I guess this will help you debuging you application at client side

Harry
0
msdixonCommented:
did you install the .Net server components on the server? it automatically sets up debuggin for you.
0
lconnellAuthor Commented:
I am trying to create and debug from a client to the server.  Meaning the ASPX project is on the server, I want to debug from the client.

.NET server components?  I installed VS.NET 2002 which installs the deubbing components.  By doing this though, when I try create an ASPX project locally or remotely, it tells me it can't connect to the web server.  So to fix this I have to uninstall IIS, then reinstall it using the ASP.NET options in W2K3 Server.  

I am not sure what else to do.
0
lconnellAuthor Commented:
Figured it out.

All you have to do is make sure you have an account on the server with privileges in the debug group i also made me an administrator also.  Now I did do this before posting here, so what the problem ended up to be was my isp provider doesn't allow port 80 open so i had to change IIS to port 81 thus breaking my debug connection from my client, because its looking to connect on port 80.  :)
0
LunchyCommented:
PAQed, with points refunded (500)

Lunchy
Friendly Neighbourhood Community Support Admin
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.