Solved

remote printing

Posted on 2003-11-03
10
1,087 Views
Last Modified: 2010-04-21
I have set up a lan using a router/switch.  When I try to print remotely nothing happens.  I have set the server ip and the path to
/dev/lp0.  I think the port is blocked.  I cannot allow the port in redhat 9 setup.

Gavin.
0
Comment
Question by:mbpssgms
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 9

Expert Comment

by:majorwoo
ID: 9672482
by remote printer you mean the printer at your office?
0
 

Author Comment

by:mbpssgms
ID: 9673661
No, the printer is connected to a machine on this lan.

Also, I am about to submit another imp q about rhn, I don't know which to buy.

Gavin
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 9673883
about buying rhn? you mean wich product to buy from redhat? I personally may go to the free side, the http://fedora.redhat.com/ Fedora Project - I havent tried it yet, I may get a chance tonight.

Is this a linux or windows machine it is connected to? It's a windows machien you will need to use samba and connect to it as a samba printer.
0
Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

 
LVL 12

Expert Comment

by:paullamhkg
ID: 9675752
majorwoo is right if you wanna your M$ windoz to print from your RH9, you need to have samba setup in your linux, in your /etc/samba/smb.conf there should be an entry in Share Definitions eg.

[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
#   Set public = yes/no  (yes to allow yser 'guest account' to printer, no for disallow)
   guest ok = yes/no
   writeable = no
   printable = yes

this will share out the printer for access.

unless your printer is shared out from M$ windoz, you need to mount the windows shared device into your linux box something like

mount //windowspcname/sharedprintername  /dev/lp0

try read the man page of mount
0
 
LVL 23

Expert Comment

by:brettmjohnson
ID: 9675812
It sounds like you are setting up remote LPR port printing.  Try setting up IPP printing instead.

Assuming the printer is on the RH9 machine:
Open the URL http://localhost:631 in your favorite browser.
Select the Printers page and set up the printer to export.
Make a note of the printer name (not the discription) the printer name
is the CUPS queue name.  The printer queue name should not contain spaces.

On the client, open the URL http://localhost:631 in your favorite browser.
On the Printer page, select Add printer.  For Printer Name enter the same name
as the printhost uses for that printer.  (Its not necessary, but it is convenient.)
For the Description enter the pretty name you want to appear in print dialogs.
Optionally specify the printer's physical Location.  Continue onto the next pane.
Specify Internet Printing Protocol and  specify ipp://printserver/queuename  as the
network printer URI. Fill in the printer model, options, etc.


0
 

Author Comment

by:mbpssgms
ID: 9677778
Brettmjohnson,
I think your method will work since both machines run rh9.  )I never use win).  I will try this when I have a spare moment.

Majorwoo,
Your reply to my rhn is the one I was after.  Pls visit

http://www.experts-exchange.com/Operating_Systems/Linux/Q_20786587.html

for a couple of q's and the points.

Gavin
0
 
LVL 9

Expert Comment

by:majorwoo
ID: 9678844
Bear in mind the defauly in rh9 is still lpr, so you will need to switch over to CUPS to use that method

(going to the other link now)
0
 

Author Comment

by:mbpssgms
ID: 9694492
brettmjohnson,

I followed your instructions to the url, but to modify or configure the printer there I need a cups username and passwd.  What do I use here, or am I going about it wrong?

Gavin.
0
 
LVL 9

Accepted Solution

by:
majorwoo earned 100 total points
ID: 9694612
your cups username/password is your root username/password - you can add other users to the cups group too if its setup
0
 

Author Comment

by:mbpssgms
ID: 9715562
Brettmjohnson,

Sorry I am taking ages, but I'm busy.

Where do I find the 'export' option.  Sinc e when I open cups this isn't obvious.

Gavin
0

Featured Post

[Webinar] How Hackers Steal Your Credentials

Do You Know How Hackers Steal Your Credentials? Join us and Skyport Systems to learn how hackers steal your credentials and why Active Directory must be secure to stop them. Thursday, July 13, 2017 10:00 A.M. PDT

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Fine Tune your automatic Updates for Ubuntu / Debian
In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Learn how to get help with Linux/Unix bash shell commands. Use help to read help documents for built in bash shell commands.: Use man to interface with the online reference manuals for shell commands.: Use man to search man pages for unknown command…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

729 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question