Solved

CGI.Auth_User not populated through IIS

Posted on 2003-11-03
5
3,225 Views
Last Modified: 2013-12-20
I have a ColdFusion application that was working fine until a few days ago.  For some reason it is no longer picking up the NT authentication.  It is installed on IIS.

I get this error message when going to the first page:

"The second parameter (StartPos) of the function RemoveChars(String, StartPos, Count), which is now equal to 1, must be less than or equal to the length of the first parameter (String), which is now equal to and has length of 0  
 
 
The Error Occurred in C:\Inetpub\wwwroot\eTAD\tad.cfm: line 23
 
21 : <p>Username:<cfoutput>#CGI.Auth_User#</cfoutput> - <cfoutput>#dompos#</cfoutput></p>
22 :  
23 : <cfset user=LCase(RemoveChars(CGI.Auth_User, 1, dompos))>
24 :
25 : <!--- <cfoutput>dompos=#dompos#</cfoutput><br> --->"

As you can see in line 21 , I am printing out CGI.Auth_User.  It comes back blank.  In IIS, this application's directory is set to NT Authentication and is NOT set for anonymous.  "dompos" is the position of the first "\" character.  This is used to separate the domain from the user when the Auth_User is being populated properly.

This problem is fairly time-sensitive for me, so any help would be great!
0
Comment
Question by:edsteele
  • 3
5 Comments
 
LVL 17

Expert Comment

by:anandkp
Comment Utility
I tried this :<cfoutput>#CGI.Auth_User#</cfoutput> & its outputting a NULL value
hence ur RemoveChars() is throwing up a error !

I'll chk up with my sysadmin & get back to u.
0
 
LVL 1

Author Comment

by:edsteele
Comment Utility
Thank you.  That is exactly what I am seeing!
0
 
LVL 2

Accepted Solution

by:
jonnygo55 earned 300 total points
Comment Utility
it sounds like the ntfs permissions for the directory has changed...perhaps allowing too much access...thus your users are not having to login using their nt authenication...so check the directory security itself(not through iis) and see if there is anything fishy there...it should be restricted to admins, IUSR, system, and perhaps ColdFusion service....
0
 
LVL 1

Author Comment

by:edsteele
Comment Utility
The permissions haven't been touched in months.  I double checked them and they look ok.  Administrators have full access and everyone has read access.
0
 
LVL 1

Author Comment

by:edsteele
Comment Utility
I had to turn off anonymous access through IIS.  Once I did that, it worked.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Article by: kevp75
Hey folks, 'bout time for me to come around with a little tip. Thanks to IIS 7.5 Extensions and Microsoft (well... really Windows 8, and IIS 8 I guess...), we can now prime our Application Pools, when IIS starts. Now, though it would be nice t…
Periodically we have to update or add SSL certificates for customers. Depending upon your hosting plan you may be responsible for the installation and/or key generation. In the wake of Heartbleed many sites were forced to re-key. We will concen…
The purpose of this video is to demonstrate how to insert an Iframe into WordPress. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Open Page or Post…
The purpose of this video is to demonstrate how to integrate Mailchimp with WordPress, by placing a Mailchimp signup form on a WordPress Page or Post. This will be demonstrated using a Windows 8 PC. Mailchimp will be used. Log into your Mailchi…

763 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

6 Experts available now in Live!

Get 1:1 Help Now