NDRs on emails that get delivered

Exchange 2000
SBS 2000

Some users are occasionally getting ndr's on internet emails, but the emails reach their destination (75 - 95% of the time).  It seems like these emails are occasionally delayed too (take up to a couple hrs to be received).

Follows is an ndr for a email a user sent to my netzero account.  i received the email and the user received this:
Your message did not reach some or all of the intended recipients.
      Subject:      test 1102
      Sent:      11/3/03 11:03 AM
The following recipient(s) could not be reached:
      K Moran on 11/3/03 11:03 AM
            There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            < mx03.gis.net #2.5.0 smtp; 250 OK id AAA94N9A5ASY7DCJ (from netzero.com:64.136.28.83)>


We have had our isp (gis) for some time and nothing has been recently changed in our configuration.  The problem does not occur all the time (ie- perhaps every 3rd or 4th email sent to a specific address), but often enough to be really frustrating.

At one point I believed the problem to have been related to delivery and read receipts, but this does not seem to be the case, as the problem occurs even with receipts off.

Any help is greatly appreciated
K
keithmoranAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

OneHumpCommented:
This could be tough to troubleshoot without being hands on...

If you send 10 messages to NetZero, do all 10 arrive?  If not, do all of your bounces come fromt he same host (64.136.28.83)?  They have two hosts, one in LA and one in New York.  The other is 64.136.20.83.  I'm curious to know if you can't connect to LA.  It could be a routing problem.  You did mention that this problem happens for several recipient domains, correct?

Please answer those questions and we'll go from there.

OneHump
0
keithmoranAuthor Commented:
a bit tough even with hands on, since users only give me 5 mins at a time to investigate.
8-)


if 10 messages sent to netzero perhaps 7 arrive.  

in netzero's case it seems most (if not all) bounces from 64.136.28.83

It is correct that this (ndrs for emails that reach their destination) happens for multiple recipient domains (at least 4).

I'll paste the headers for a message which the user did receive a ndr for but which i also received, just in case it provides any insight:
(username changed from actual to 'john doe')
======================================
Received: from mx24.lax.untd.com (mx24.lax.untd.com [10.130.24.84])
      by maildeliver03.nyc.untd.com with SMTP id AAA94PEU2AJ4G5K2
      for <keithmoran@netzero.com> (sender <john_doe@stepboston.org>);
      Mon,  3 Nov 2003 09:37:28 -0800 (PST)
Received: from outbound28-2.lax.untd.com (localhost [127.0.0.1])
      by mx24.lax.untd.com with SMTP id AAA94PEUZAZEPCY2
      for <keithmoran@netzero.com> (sender <john_doe@stepboston.org>);
      Mon,  3 Nov 2003 09:37:27 -0800 (PST)
Received: from mx03.gis.net (mx03.gis.net [208.218.130.11])
      by mx24.lax.untd.com with SMTP id AAA94N9A5ASY7DCJ
      for <keithmoran@netzero.com> (sender <john_doe@stepboston.org>);
      Mon,  3 Nov 2003 08:02:35 -0800 (PST)
Received: from step-sbs.step-inc.local ([141.154.60.37]) by mx03.gis.net; Mon,
 03 Nov 2003 11:02:34 -0500
content-class: urn:content-classes:message
Return-Receipt-To: "John Doe" <john_doe@stepboston.org&
gt;
Subject: test 1102
MIME-Version: 1.0
Content-Type: multipart/alternative;
      boundary="----_=_NextPart_001_01C3A223.E4682E36"
Date: Mon, 3 Nov 2003 11:02:33 -0500
Disposition-Notification-To: "John Doe" <john_doe@stepboston.org>
X-MimeOLE: Produced By Microsoft Exchange V6.0.6249.0
Message-ID: <521A1942752EBB4DB6E256072BD56FFF0A1A0F@step-sbs.step-inc.local&g
t;
X-MS-Has-Attach:
X-MS-TNEF-Correlator:
Thread-Topic: test 1102
Thread-Index: AcOiI+NxBxaweQ3sEdiuXAADR23hkw==
From: "John Doe" <john_doe@stepboston.org>
To: <keithmoran@netzero.com>
X-Rcpt-To: <keithmoran@netzero.com>
X-ContentStamp:1:1:2710060351
========================================
0
OneHumpCommented:
Do you know how to manually send a message via a telnet to port 25?  If no, please let me know and I'll show you.

Try a telnet to 64.136.28.83 on port 25.  I'd also like to confirm that they all come from that IP.  Your ISP might be broadcasting their network address improperly, or something like that.  This could be causing connectivity problems with certain hosts running certain routers on the Internet.

Let's see what happens when you telnet.

OneHump
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

JasonBighamCommented:
0
OneHumpCommented:
Ah yes, the FireBox.  Do you have a FireBox Keith?  If so, JB gets the points.
0
keithmoranAuthor Commented:
OH-

550 access denied when i telnet to port 25 on 64.136.28.83....
same with 64.136.20.83 ?
(I tried same with a cpl other smtp servers i have access to.. connected and sent fine)

is there a way to determine if my isp is broadcasting their network address correctly?  I'd be very happy if it turned out to be a snafu on their end (so I could get back to 'work').

K-

0
keithmoranAuthor Commented:
I saw that posting this am when i was still in research stage.

No Firebox. ISA server, but that does not seem to be at issue...

thanx anyhow jb


0
OneHumpCommented:
"is there a way to determine if my isp is broadcasting their network address correctly?  I'd be very happy if it turned out to be a snafu on their end (so I could get back to 'work')."

Not without having access to your ISPs routers.

I dont' think that's it though.  If you are getting access denied, you have another problem.  That server has either your ISP's server, or their subnet, blocked.  I did run their IP through a spam database and found that they were listed on one (XBL), but I doubt that's it.

I would call NetZero and find out why it's happening.  It may clue you into the root cause.  Since you are having this problem with other hosts, your ISPs server is probably RBL listed.

OneHump
0
keithmoranAuthor Commented:
OH-

no rbl listing and netzero is notoriously slow about tech support replies.
btw: I think the xbl listing is old too (http://www.selwerd.cx/xbl/ has been down for a while).

can you tell me what happens when you telnet to 64.136.28.83?
(I called a buddy on another network to try, he got 550 access denied as well).

scratchin my noggin on this one.
I'll probably just put a call into gis tomorrow,
unfortunately they are part of ba-dsg.net so..
a little cog in a big wheel.


K
0
OneHumpCommented:
220 mx26.lax.untd.com ESMTP
helo mydomain.com
250 mx26.lax.untd.com Hello xxxxxxx.xxxxxxxx.com pleased to meet you

They are doing something.  I wouldnt call tech support.  I would call their main office and tell them that your company is trying to send to their company and you are getting an "access denied" message.  They are blocking you for some reason.  My home ISP once told me that he had tried for months to get something similar fixed with AOL.  I called AOL direct and they had a special line for admins.  I got is fixed in 10 minutes.

OneHump
0
OneHumpCommented:
One thought is that NetZero is busted.  Check this out:

http://www.dnsreport.com/tools/dnsreport.ch?domain=netzero.com

Look at the bottom row labeled "Mail".

It looks like they may have issues on their end.  I can connect, but that means little if few others can.

OneHump
0
David WilhoitSenior Consultant, ExchangeCommented:
"There was a SMTP communication problem with the recipient's email server.  Please contact your system administrator.
            < mx03.gis.net #2.5.0 smtp"

mx03 isn't even listed in the DNS records of gis.net. 06,07,and 08 are the 3 MX records listed, which may be why netzero won't accept mail from it.

D
0
OneHumpCommented:
Why would someone deny mail from a mailer not reflected by an MX record?  Many outbound relays don't have MX records because they are outbound.  :)  

It seems that Keith and a friend of his on another network can't connect to one of NetZero's MXs.

OneHump
0
David WilhoitSenior Consultant, ExchangeCommented:
yea, don't think of that much, but with all the reverse DNS checks going on these days, thought it might be a aprt of the problem.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OneHumpCommented:
Kidego - Can you try for us?  Try a telnet to 64.136.28.83.
0
David WilhoitSenior Consultant, ExchangeCommented:
220 mx19.lax.untd.com ESMTP
ehlo
501 Syntax error in HELO/EHLO
ehlo kidego.net
500 Command unrecognized
helo kidego.net
250 mx19.lax.untd.com Hello ga-cmng-cuda2-c1c-16.atlaga.adelphia.net pleased to
meet you
0
OneHumpCommented:
Nice server, doesnt talk esmtp.  haha.

Thanks.
0
David WilhoitSenior Consultant, ExchangeCommented:
yea. Most of the servers out there now that are used heavily, are blocked from ESMTP verbs. What's the point of having them?
0
OneHumpCommented:
It's stupidity.  You'd think chunking and pipelining would help matters.  Fools.
0
David WilhoitSenior Consultant, ExchangeCommented:
OK, here's what I see: stepboston.org has MX records pointing to mail.gis.net:

mail.gis.net.        stepboston.org        stepboston.org.        A        MX       3600       Pref:0
mail2.gis.net.        stepboston.org        stepboston.org.        A        MX       3600       Pref:10

Now, I'm not able to connect at all to mail2, and mail never even gives me a banner or allows me to issue a helo, but it does connect. this server must be under HEAVY usage. Also, no (A) records for mail or mail2, if that makes a difference.

D
0
OneHumpCommented:
No A record?
0
David WilhoitSenior Consultant, ExchangeCommented:
Not that I saw, jsut sent you the whole record listing....
0
keithmoranAuthor Commented:
i sent gis a few questions this morning, no response yet.

Any chance the lack of A records could be do to a cname record in gis' setup?  I have very little clue about cname, only that it can somehow sit in place of A record.

K
0
David WilhoitSenior Consultant, ExchangeCommented:
(A) records are there, jsut didn't show up the first couple of times I ran the report. Sorry bout the false statement. My issue is that the mail servers didn't exactly respond when I tried to connect. Weirdness.

d
0
keithmoranAuthor Commented:
As it turns out the ISP had been trying to 'move'  the email server we were relaying through (i still have yet to get an answer from them on what 'move' means with respect to an email server).  They did not bother to mention it to any of their users, evidently we were not the only people to experience 'odd' email behavior.  

Kidego & Onehump, THANX for heading me in the right direction !!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.