Solved

Adding a sever to Active Directory Domain

Posted on 2003-11-03
14
375 Views
Last Modified: 2010-04-13
Dear experts,

I am adding a new server to an AD Domain with one server and one domain.  Active Directory is working on the server I have set as the PDC from all I can tell.  

I have another server that I want to act as a BDC.  I am using the active directory Insallation wizard and I get to the part to access the domain by typing in a username, password and the domain name and click next I get this message:

"The Domanin XX is not an active directory domain or an active directory domain controller for the domain could not be contacted"

I am puzzled.  I can access the PDC server through My Network Places and login to access the shares.

I am not sure what I should be looking for?

If anyone can get me going in the correct direction, I would be grateful.

Reggie
0
Comment
Question by:ReggieM
14 Comments
 
LVL 1

Expert Comment

by:mrochac
ID: 9674068
Have you tried running dcpromo on your main server? an is it for sure you DC cause it sounds like you dont have a DC running? i would make sure AD is on the primary server.

Resus.
0
 

Expert Comment

by:daven17
ID: 9674137
On the new server, make sure that the original server is set as your primary DNS in your tcp/ip settings, otherwise you will not be able to locate active directory.  BTW, there is no PDC/BDC in Windows 2000.  Active Directory is a multi-master design.

daven
0
 

Author Comment

by:ReggieM
ID: 9679820
Experts,

Thank you for the comments.  

My current server is setup as the primary DNS but it forwards this infomation on to the actual DNS, outside of this LAN.  I do not host our Domanin Name here.

Could that be the issue?

Also I am at a loss about the DC comment.  How do I check to see if it is a DC without running the dcpromo?  Active Directory is definantely running or installed on the main server.  Shouldn't this make it a domain controller?

I have the TCP/IP configuration on the new server with static address with the DNS pointed to the main server.  I have tried using DHCP as well and still get the error message.

0
 

Author Comment

by:ReggieM
ID: 9682007
Dear Experts,

I cannot see anything wrong with my DNS settings.  On the primary server. All of the machines in the network are using the DHCP server and getting access to the internet.  

I configured a machine to have the static DNS of 192.168.1.200 which is the Server that is set for forwarding the DNS and the machine had no problem with conecting to the internet.

So how do I get my newest server to see the AD on my LAN?  The DNS is set to cvm.local.  I feel like I am running around in circles chasing my tail and I am missing something very easy.

Thanks in advance for the help.
0
 

Expert Comment

by:daven17
ID: 9682204
Try the following: make sure that the (new) server is not a member of a domain (go to My Computer properties > Network Identification and check that it is in a workgroup, not in a domain).  Then try to add it to your cvm.local domain.  It will ask you for the administrator user name/pw of the cvm.local domain.  If you are able to add it there, then reboot the computer once you've joined the domain and run dcpromo to make the server a domain controller.  If you cannot join the domain, make sure you can ping your main server, and try running nslookup to see if it can resolve the name of your main server (ie. "nslookup mainserver.cvm.local").  If you cannot resolve the name, then you have a DNS problem.  Good luck!

0
 

Author Comment

by:ReggieM
ID: 9683379
Daven17,

Thank you very much.  That was the issue getting past that one part of setting up AD.  

I hope you may find the time to help me some more.

In DCPromo I get to the place of "Enter the full DNS name fo the existing Domain for whcich this server will become an additional Domain Controller"

I browse and there is my domain cvm.local

I select it and I get the error " The domain cannot be contacted. Ensure that the DNS Doman name is typed correctly. This condition my be caused by a DNS lookup problem"

I can get past this part of the screen by typing in cvm wich is followed by a message saying do you mean cvm.local? I say yes and it lets me get to the point of a picture with two machines trying to send data to each other.  Then I get:

Error Joining Domain
"The connection failed with the following error: " The specified domain either does not exist or could not be contacted"

So I am back at square one.  I have been trying a lot of options using microsofts article 260371 but have had no luck..

I do not know if it the existing server or the server thats being added need to modified.

Thankyou again
0
How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

 

Expert Comment

by:NewWizard
ID: 9684606
Hi, ReggieM,

Double check your 2nd server's Preferred DNS Server IP is pointing to your 1st server IP address.  Don't point it to either 127.0.0.1 or ISP DNS.  You must use the IP where reside AD info/record.  

Ex: 192.168.1.1 --> 1st server w/ Active Directory installed

For your 2nd server:
IP:  192.168.1.200
sub: 255.255.255.0
DNS: 192.168.1.1     <--- 1st server IP


See if this work!

NewWizard
0
 

Expert Comment

by:daven17
ID: 9686720
ReggieM:

In one of your comments, you mentioned that your DNS server was forwarding requests to your ISP's DNS server.  If you go into the DNS MMC, is your server listed there with the cmv.local zone listed under "Forward Lookup Zones"?  If it is not, then you need to add your local zone and set your main server as the Start of Authority.  If the zone is listed there, then open up its properties and check the SOA tab to make sure that main-server.cmv.local is listed as the primary server, and it should also be listed under the Name Servers tab with the proper ip address (192.168.1.200).  If you are forwarding all DNS requests, then that is why you cannot contact your domain controller.  Your main server MUST be the primary DNS server/SOA for your cmv.local domain.  
Were you able to "nslookup main-server.cmv.local" and get 192.168.1.200 back?

daven17
0
 

Author Comment

by:ReggieM
ID: 9687506
Daven17,

I have all of the parameters you mentioned.  I typed in the nslookup command from the Second server and did get back the IP address of the DNS server.  The main server is set as Primary.  It is forwarding to the ISP addresses. The SOA states '2' for Serial number, has the name of the server as the Primary server and admin as the responsible person.  I am not sure where the setting for "forwarding all DNS requests" is?  In the properties section of the main server in DNS settings I have a box checked for forwarding with the IP addresses it should forward to, but I do not see anything that indicates forwarding all DNS requests, even though I believe that is implied.

I have not set any DNS settings on the Secondary server yet.  Well I did setup a zone in DNS to see if that changed anything and it did not seem to so I deleted the zone off the secondary server.  I am wondering if the DNS settings are seperate from the AD setup? Should I go through and replicate the setting of the main server to the second server making it secondary and then run dcpromo?

Do you know what "refresh" and "reload" will do to my forward lookup zone?

Thank you for the help.
0
 

Accepted Solution

by:
daven17 earned 500 total points
ID: 9688031
You do not need to set up DNS on your second server (it will not help with this issue).  The reason I am hung up on you DNS settings is that the errors you are getting are indicating that there is a problem contacting your domain controller.  Active Directory uses DNS to locate domain controllers, so if the DNS server or zone on the primary server is not configured correctly, then it will not be able to locate the domain controller.  It is apparently working, since you got the correct response from nslookup.  There may be a security issue on your primary server.  Did you install it originally?  Is it Windows 2000 server with SP4?  Have any special group policies been applied to it?  Have you made any changes to the DNS server (besides the forwarding.  The forwarding that you selected will only forward requests that your existing server cannot resolve, so that shouldn't be a problem).

I understand that you were able to make your secondary server a member server in the cvm.local domain.  Can you browse My Network Places and view resource (ie. shares) on your primary server (from the secondary server) without it prompting you for a username/pw?  If you were able to join the domain & access resources ok, the problem seems to be with the primary server.  Make sure you are running at least SP3 (preferrably SP4) on the server, and check to make sure Authenticated Users have read access to your Primary server in the DNS MMC.  
0
 

Author Comment

by:ReggieM
ID: 9688947
Daven17,

I went and rand the nslookup command again and this is actually what I get back.

C:\Documents and Settings\Administrator>nslookup main-server.cvm.local
Server:  ip67-89-17-165.z17-89-67.customer.algx.net
Address:  192.168.1.200

*** ip67-89-17-165.z17-89-67.customer.algx.net can't find main-server.cvm.local:
 Non-existent domain

It returns the IP address but gives me this second line which would indicate it is not finding the domain.

I can access the main server through my network places without any difficulty. SP4 is on both severs.  I have not been able to get active directory installed on the second server so I have not been able to make it a secondary server.  Unless I am understanding this incorrectly.

I have been reading a ton of information on this issue and my head is spinning.  Do you think we are looking at a reverse lookup issue?  Also what I am doing with the forward is quite common is it not?  I mean not hosting my Domain Name at this location.  

Are you familiar with the Netdaig tool?  The MS article 260371 brings this up a tool to troubleshoot.  Also I did a refresh on the forward look up zone and now have an entry type Host inthe cvm.local lookup zone.  It did not seem to change a thing though.

I appreciate the assistance greatly.
0
 

Author Comment

by:ReggieM
ID: 9905460
Dear PashaMod,

I have not been able to resolve this issue.  I am still very puzzled about it.

Can I reload this question?

0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

NTFS file system has been developed by Microsoft that is widely used by Windows NT operating system and its advanced versions. It is the mostly used over FAT file system as it provides superior features like reliability, security, storage, efficienc…
Is your company's data protection keeping pace with virtualization? Here are 7 dynamic ways to adapt to rapid breakthroughs in technology.
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

21 Experts available now in Live!

Get 1:1 Help Now