coldfusion will not connect to an access database

i get this error..i am running mx on win xp

[]java.sql.SQLException: No datasource named BlueprintDatabase is configured in jrun-resources.xml
The root cause was that: java.sql.SQLException: No datasource named BlueprintDatabase is configured in jrun-resources.xml
finnstoneAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

finnstoneAuthor Commented:
i should add that it works for odbc datasources just not access ones and that i have the access ones already set up as odbc sockets in my datasource manager in control panel.

this is weird. it stoppe working after i downloaded sp8 for ms access jet engine.
Renante EnteraSenior PHP DeveloperCommented:
You will have to recreate your odbc socket using your ms access database.

Then add again the datasource on your ColdFusion MX Administrator specifying the odbc socket you created as your Database.  Be sure that your datasource name should be BlueprintDatabase since that is what you are using.

Goodluck!
eNTRANCE2002 :-)

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
anandkpCommented:
Try deleting ur DSN in CFAdmin & recreate it !
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

proceptCommented:
Hi,

the SP may have changed he dirvers.... try re-creating an ODBC data source for that Access DB and then try againto connect through CF.

BTW. If you have the option of directly connecting to it with CF MX (no ODBC), I would recommend doing just that, will be much faster.

Chris
finnstoneAuthor Commented:
i solved it myself but see the answe is here too
Renante EnteraSenior PHP DeveloperCommented:
I am glad that you have resolve it by yourself.  Actually, I have encountered the same problem that's why I posted it immediately for your reference.

By the way, thanks for the points and A.

Regards !
eNTRANCE2002 :-)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Servers

From novice to tech pro — start learning today.